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Who is this book for?

Anyone who wants to get up to speed quickly with LibreOffice Writer will find this book valuable.
You may be new to word processing software, or you may be familiar with another office suite.

What’s in this book?

This book introduces some of the main features of Writer, the word processor component of
LibreOffice:

* Text entry, editing, and formatting (Chapter 3)

* Page-layout methods, including frames, columns, and tables (Chapter 4)

e Export to PDF, including bookmarks (Chapter 5)

* Templates and styles (Chapters 6, 7, and 10)

* Embedding or linking of graphics, spreadsheets, and other objects (Chapter 8)
* Built-in drawing tools (Chapter 8)

* Tables of data (Chapter 9)

* Mail merge (Chapter 11)

* Tables of contents, indexes, and bibliographies (Chapter 12)

* Master documents, to group a collection of shorter documents into a single long document
(Chapter 13)

* Fields and forms (Chapters 14 and 15)
* Database integration, including a bibliography database (Chapters 11, 12, 15)
* And many more

Where to get more help

This book, the other LibreOffice user guides, the built-in Help system, and user support systems
assume that you are familiar with your computer and basic functions such as starting a program,
opening and saving files.

Help system

LibreOffice comes with an extensive Help system. This is your first line of support for using
LibreOffice.

To display the full Help system, press F1 or go to Help > LibreOffice Help on the Menu bar. In
addition, you can choose whether to activate Tips, Extended tips, and the Help Agent by going to
Tools > Options > LibreOffice > General on the Menu bar.

If Tips are enabled, hover the mouse pointer over any of the icons to see a small box (tooltip) with
a brief explanation of the icon’s function. For a more detailed explanation, select Help > What's
This? on the Menu bar and hover the pointer over the icon.

Free online support

The LibreOffice community not only develops software, but provides free, volunteer-based support.
See Table 1 and this web page: http://www.libreoffice.org/get-help/

You can get comprehensive online support from the community through mailing lists and the Ask
LibreOffice website, http://ask.libreoffice.org/en/questions/.
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Other websites run by users also offer free tips and tutorials. This forum provides community
support for LibreOffice: http://en.libreofficeforum.org/

This site provides support for LibreOffice, among other programs:
http://forum.openoffice.org/en/forum/

Table 1: Free support for LibreOffice users

Free LibreOffice support

Ask LibreOffice

Questions and answers from the LibreOffice community
http://ask.libreoffice.org/en/questions/

User guides, how-tos, and other documentation.

Documentation http://www.libreoffice.org/get-help/documentation/
https://wiki.documentfoundation.org/Documentation/Publications

FAQs Answers to frequently asked questions
http://wiki.documentfoundation.org/Faq

Mailing lists Free community support is provided by a network of experienced users

http://www.libreoffice.org/get-help/mailing-lists/

International support

The LibreOffice website in your language.
http://www.libreoffice.org/international-sites/

International mailing lists
http://wiki.documentfoundation.org/Local_Mailing_Lists

Accessibility options

Information about available accessibility options.
http://www.libreoffice.org/get-help/accessibility/

Paid support and training

Alternatively, you are able to pay for support services. Service contracts can be purchased from a
vendor or consulting firm specializing in LibreOffice.

What you see may be different

lllustrations

LibreOffice runs on Windows, Linux, and Mac OS X operating systems, each of which has several
versions and can be customized by users (fonts, colors, themes, window managers). The
illustrations in this guide were taken from a variety of computers and operating systems. Therefore,
some illustrations will not look exactly like what you see on your computer display.

Also, some of the dialogs may be different because of the settings selected in LibreOffice. You can

either use dialogs from your computer system or dialogs provided by LibreOffice (default). Follow

these steps to change to using LibreOffice dialogs if settings have been altered:

1) On Linux and Windows operating systems, go to Tools > Options > LibreOffice >
General on the Menu bar to open the dialog for general options.

2) On a Mac operating system, go to LibreOffice > Preferences > General on the Menu bar
to open the dialog for general options.

3) Select Use LibreOffice dialogs in Open/Save dialogs to display the LibreOffice dialogs

on your computer display.
4) Click OK to save your settings and close the dialog.
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Icons

The icons used to illustrate some of the many tools available in LibreOffice may differ from the
ones used in this guide. The icons in this guide have been taken from a LibreOffice installation that
has been set to display the Tango set of icons.

You can change your LibreOffice software package to display Tango icons as follows:

1) On Linux and Windows operating systems, go to Tools > Options > LibreOffice > View on
the Menu bar to open the dialog for view options.

2) On a Mac operating system, go to LibreOffice > Preferences > View on the Menu bar to
open the dialog for view options.

3) In User interface > Icon size and style, select Tango from the options available in the
drop-down list.

4) Click OK to save your settings and close the dialog.

Some Linux operating systems, for example Ubuntu, include LibreOffice as part of
the installation and may not include the Tango icon set. You should be able to
download the Tango icon set from the software repository for your Linux operating
system.

Note

Using LibreOffice on a Mac

Some keystrokes and menu items are different on a Mac from those used in Windows and Linux.
The table below gives some common substitutions for the instructions in this chapter. For a more
detailed list, see the application Help.

Windows or Linux  Mac equivalent Effect
Tools > Options LibreOffice > Preferences Access setup options
menu selection
Right-click Control+click and/or right-click Opens a context menu
depending on computer setup
Ctrl (Control) 3 (Command) Used with other keys
F5 Shift+38+F5 Open the Navigator
Fi11 #+T Open the Styles and Formatting window

What are all these things called?

The terms used in LibreOffice for most parts of the user interface (the parts of the program you see
and use, in contrast to the behind-the-scenes code that actually makes it work) are the same as for
most other programs.

For example, a dialog is a special type of window. Its purpose is to inform you of something, or
request input from you, or both. It provides controls for you to use to specify how to carry out an
action. The technical names for common controls are shown in Figure 1. In most cases we do not
use the technical terms in this book, but it is useful to know them because the Help and other
sources of information often use them.
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Page Style: Default
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Page order
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First page number: 1 ]
Print
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Figure 1: Dialog showing common controls

1) Tabbed page (not strictly speaking a control).
2) Radio buttons (only one can be selected at a time).
3) Checkbox (more than one can be selected at a time).

4) Spin box (click the up and down arrows to change the number shown in the text box next to

it, or type in the text box).
5) Thumbnail or preview.
6) Drop-down list from which to select an item.
7) Push buttons.

In most cases, you can interact only with the dialog (not the document itself) as long as the dialog
remains open. When you close the dialog after use (usually, clicking OK or another button saves

your changes and closes the dialog), then you can again work with your document.

Some dialogs can be left open as you work, so you can switch back and forth between the dialog

and your document. An example of this type is the Find & Replace dialog.

Who wrote this book?

This book was written by volunteers from the LibreOffice community. Profits from sales of the

printed edition will be used to benefit the community.
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How is LibreOffice licensed?

LibreOffice 4.2 is distributed under the Open Source Initiative (OSI) approved Mozilla Public
License (MPL). The MPL license is available from http://www.mozilla.org/MPL/2.0/.

May | distribute LibreOffice to anyone? May I sell it? May | use it in my business?

Yes.

How many computers may | install it on?
As many as you like.

Is LibreOffice available in my language?

LibreOffice has been translated (localized) into over 40 languages, so your language probably
is supported. Additionally, there are over 70 spelling, hyphenation, and thesaurus dictionaries
available for languages, and dialects that do not have a localized program interface. The
dictionaries are available from the LibreOffice website at: www.libreoffice.org.

How can you make it for free?

LibreOffice is developed and maintained by volunteers and has the backing of several

organizations.

How can | contribute to LibreOffice?

You can help with the development and user support of LibreOffice in many ways, and you do
not need to be a programmer. To start, check out this web page:

http://www.documentfoundation.org/contribution/

May | distribute the PDF of this book, or print and sell copies?
Yes, as long as you meet the requirements of one of the licenses in the copyright statement at
the beginning of this book. You do not have to request special permission. We request that you
share with the project some of the profits you make from sales of books, in consideration of all

the work we have put into producing them.
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What’s new in LibreOffice Writer 4.2?

LibreOffice 4.2 offers many new features, in addition to those in the 4.1 release. These new
features are listed on these wiki pages:

https://wiki.documentfoundation.org/ReleaseNotes/4.1

https://wiki.documentfoundation.org/ReleaseNotes/4.2

Here are some of the features (not a full list):

Images embedded in Writer can now be rotated easily in 90 degree increments.
Writer text frames now support having a gradient as background.

The Comments bar now can easily be toggled using a button in the ruler.
Footnote and footer comment handling has been improved.

Comments to text ranges can now include multiple paragraphs.

Embedding fonts in a Writer document.

Media file types Windows Media Audio (WMA), Windows Media Video (WMV), Advanced
Audio Coding (AAC), Flash Video (FLV), Multiplexed OGG Video (OGX), RMI MIDI Audio
and SND (SouND) Audio are now accessible from Insert > Movie and Sound.

Support for legacy Mac word processor documents:

Microsoft Word for Mac 5.1
Write Now 4.0
MacWrite Pro 1.5
AppleWorks 6.0
Match Case option has been added to the search bar.

The Find hotkey Ctrl+F is a toggle.
File > Recent Documents > Clear List feature has been added.

Recent Documents can now be accessed directly from the toolbar using the arrow on the
Open button.

Multiple styles can be deleted at the same time.

Embedding images into HTML files enables sending merge emails with images in HTML
format.

Character border: format one or more characters with a border.
Spelling checker popup menu now allows change tracking operations.

Multiple styles can be selected in the Style and Formatting window to delete or hide them.

A new default template has been designed for Writer.

RTF import has added initial support for group shapes.

Writer can now create *.DOT files.

Graphical bullets are imported and exported in the DOC, DOCX and RTF filters.
The DOCX import filter now handles non-bitmap drawing shapes.

Further improvements for DOCX interoperability.

Preface

15


https://wiki.documentfoundation.org/ReleaseNotes/4.2
https://wiki.documentfoundation.org/ReleaseNotes/4.1




j LibreOffice

The Document Foundation

Chapter 1
Introducing Writer



What is Writer?

Writer is the word processor component of LibreOffice. In addition to the usual features of a word
processor (spelling check, thesaurus, hyphenation, autocorrect, find and replace, automatic
generation of tables of contents and indexes, mail merge, and others), Writer provides these

important features:
* Templates and styles (see Chapters 6 and 7)
* Page-layout methods, including frames, columns, and tables (Chapter 4)

* Embedding or linking of graphics, spreadsheets, and other objects (Chapter 8)
¢ Built-in drawing tools (Chapter 8)

* Master documents, to group a collection of shorter documents into a single long document

(Chapter 13)
* Change tracking during revisions (Chapter 3)
¢ Database integration, including a bibliography database (Chapters 11, 12, 15)
e Export to PDF, including bookmarks (Chapter 5)
* And many more

Parts of the main Writer window

The main Writer workspace is shown in Figure 2. Its features are described in this section.

% WorkingWithGraphics.odt - LibreOffice Writer E]@
File Edit View | Insert Format Tabley Tools Window Help

B oR2Ega s B- S 2 E-P meE 9 &
|_E| COoHealling 0 v Liberdtion Sans v 32 ﬂ|g|& || EI El @ - &
5 1 Z J! 4L L 4L J.3 L J.+ 4L J.S L J.FJ;A

Title bar Menu bar Standard toolbar Formattihg toolbar
The Document Foundation

Status bar é]
Writer Guide

:{ 111} ):
Page 1/ 35 | 11062 words, 53093 characters| OOoFirstPage | English (USA) m | [& s ol B R

Figure 2: Parts of the main Writer window (without sidebar)

Title bar

The Title bar is located at the top of the Writer window, and shows the file name of the current
document. When the document is newly created, the document name will appear as Untitled X,

where X is a number.
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Menus

The Menu bar is located just below the Title bar. When you select one of the menus, a submenu
drops down to show further options such as:

e Executable commands, such as Close or Save, found in the File menu.

* Commands to open dialogs, indicated by the command being followed by an ellipsis (...),
such as Find or Paste Special found in the Edit menu.

* Further submenus, indicated by a right-pointing black arrow, such as Toolbars and Zoom
found in the View menu. Moving the cursor onto these causes them to open.

Toolbars

Writer displays toolbars in different ways: docked (fixed in place), or floating. Some toolbars have
sections which you can tear off. Docked toolbars can be moved to different locations or made to
float, and floating toolbars can be docked.

The top docked toolbar, just under the Menu bar, is called the Standard Toolbar. It is consistent
across all the LibreOffice applications (Writer, Calc, Draw, Impress).

The second toolbar at the top is context sensitive. For example, when working with text, the
Formatting toolbar is displayed. When the cursor is on a graphic (image type), the Graphics toolbar
is displayed, and the Pictures toolbar is displayed docked at the bottom of the screen. An additional
toolbar (Bullets and Numbering) is displayed next to the Formatting toolbar, when for example, the
cursor is in a numbered/bulleted list.

Displaying or hiding toolbars
To display or hide toolbars, choose View > Toolbars, then click on the name of a toolbar in the list.

An active toolbar shows a check mark beside its name. Tear-off toolbars are not listed in the View
menu.

Submenus and tear-off toolbars
Combination toolbar buttons having a down arrow will display submenus, tear-off toolbars, and
other ways of selecting things, depending on the toolbar.

Figure 3 shows a tear-off toolbar from the Drawing toolbar. Once removed from the parent toolbar
it displays a title bar.

Tear-off toolbars can be floating or docked along an edge of the screen or in one of the existing
toolbar areas. To move a floating tear-off toolbar, drag it by the title bar, as shown in Figure 5.

_ Flowchart v x
e yHIE EE 960 E
se=edv PPV
crpaEed > evawee
reavap XeAVED
LR Qs o e
| | ' e
M i -k -
Click here and drag Toolbar tears off and floats

Figure 3: Example of a tear-off toolbar
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Moving toolbars

To move a docked toolbar, place the mouse pointer over the toolbar handle (the small vertical bar
to the left of the toolbar), hold down the left mouse button, drag the toolbar to the new location, and
then release the mouse button.

File Edit Vew Insert Format Table Tools
B-B-LHE &
|_a Text Body V Liberation Sans

[

Handles of docked toolbars

Figure 4: Moving a docked toolbar

To move a floating toolbar, click on its title bar and drag it to a new location.

Title bar of fleating toolbar

Bullets and Numbering |
:> I:::;.. IT_EI ﬂ {} ‘i}‘ﬁ' 4}{5 IEI

Figure 5: Moving a floating toolbar

Floating toolbars

Some toolbars activated from the View menu may appear as floating toolbars, for example the
Insert toolbar. Writer also includes several additional context-sensitive toolbars, whose defaults
may appear as floating toolbars in response to the cursor’s current position or selection. You can
dock these toolbars to the top, bottom, or side of the window, if you wish (see “Moving toolbars”
above).

Docking/floating windows and toolbars

Toolbars and some windows, such as the Navigator and the Styles and Formatting window, are
dockable. You can move, resize, or dock them to an edge.

To dock a window or toolbar, hold down Ctrl and double-click on the frame of the floating window
(or in a vacant area near the buttons at the top of the floating window) to dock it in its last position.

Styles and Formatting

@Eﬂ@ﬁl}%

Addresses
Biblingraphy 1
Bibliography Heading
Captnn

Figure 6: Ctrl+double click to dock or undock

To undock a window, hold down Ctrl and double-click on the frame (or a vacant area near the
buttons at the top) of the docked window.
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Docking (AutoHide)

On any window edge where another window is docked you will see a button which allows you to
show or hide the window.

* If you click the button on the window edge to show the window, the window will remain
visible until you manually hide it again (with the same button).

* |If you show the window by clicking the window border, but not the button, you activate the
AutoHide function. The AutoHide function allows you to temporarily show a hidden window
by clicking on its edge. When you click in the document, the docked window hides again.

Contents 10
Contents Heading
Default
Drawing
Endnote

First line indent
Footer

Footer left
Footer right
Footnote
Frame contents
Hanging indent

Hearer

Figure 7: The Hide button

Click in the border to
activate Autohide

Figure 8: Show button and Autohide

Customizing toolbars

You can customize toolbars in several ways, including choosing which buttons are visible and
locking the position of a docked toolbar.

To access a toolbar’s customization options, right-click between the buttons on the toolbar to open
a context menu.

The context menu lists the buttons defined for the selected toolbar but not visible on it. To show or
hide buttons defined for the selected toolbar, choose Visible Buttons from the context menu.
Visible buttons are indicated by being highlighted (Figure 9) or by a check mark beside the button,
depending on your operating system. Click on buttons to hide or show them on the toolbar.

You can also add buttons and create new toolbars, as described in Chapter 16, Customizing
Writer.

In earlier versions of LibreOffice, these options were accessed by clicking on an
Note arrow at the end of the toolbar. The arrow is still present on floating toolbars, but not
on docked ones. However, the arrow has no effect.
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Figure 9: Selection of visible toolbar buttons

Right-click (context) menus

Right-click on a paragraph, graphic, or other object to open a context menu. Often the context
menu is the fastest and easiest way to reach a function. If you're not sure where in the menus or
toolbars a function is located, you can often find it by right-clicking.

Rulers

Rulers are enabled by default. To show or hide the rulers, choose View > Ruler. To disable the
rulers, choose Tools > Options > LibreOffice Writer > View and deselect either or both rulers.
The horizontal ruler has a comments button on its right side to show or hide comments.

Guides
[] Helplines wWhile Moving

View
Horizontal scrollbar
Wertical scrollbar

Display Rul
uler
Graphics and objects B :
Tables Horizontal ruler  |Inch
Drawings and contrals Vertical ruler Inch '
[] Eield codes [ ] smooth scroll

Comments

Figure 10: Accessing the ruler settings
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Status bar

The Writer status bar is located at the bottom of the workspace. It provides information about the
document and convenient ways to quickly change some document features. It can be hidden by
deselecting it in the View menu.

| Page 1/1| 11 waords, 50 characters Defaullt Style Englislh (LUsa) Overwrite .-I L4 .

Page Word & character Page style Language Insert Selecion Document

number count mode mode changes
status

Figure 11: Left end of Status bar

=) Outline Mumbering : Level 2 OO0 | = - + | 100%
Digital Object View Zoom Zoom
signature information layout slider percent

Figure 12: Right end of Status bar

Page number
Shows the current page number, the sequence number of the current page (if different), and
the total number of pages in the document. For example, if you restarted page numbering at 1
on the third page, its page number is 1 and its sequence number is 3.

If any bookmarks have been defined in the document, a right-click on this field pops up a list of
bookmarks; click on the required one.

To jump to a specific page in the document, double-click on this field. The Navigator opens
(see page 35). Click in the Page Number field in the Navigator, type the sequence number of
the required page, and press Enter.

Word and character count
The word and character count of the document is shown in the status bar, and is kept up to
date as you edit. Any text selected in the document will be counted and this count will replace
the displayed count.

What now?

What now?
Docking a Hoat.

Doclking a boat.

11 words, 50 characters 3 words, & characters selected

To display extended statistics such as character counts excluding spaces, double-click the
word count in the status bar, or choose Tools > Word Count.

Page style
Shows the style of the current page. To change the page style, right-click on this field. A list of
page styles pops up; click on one to select a different style.

To edit the current page style, double-click on this field. The Page Style dialog opens. See
Chapters 6 and 7 for more information about styles.

Language
Shows the language at the cursor position, or for the selected text, that is used for checking
spelling, hyphenation, and thesaurus. Click to open a menu where you can choose another
language for the selected text or for the paragraph where the cursor is located. You can also
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choose None (Do not check spelling) to exclude the text from a spelling check or choose
More to open the Character dialog. Any directly formatted language settings can be reset to
the default language from this menu. See Chapter 3, Working with Text, for more information.

Insert mode
This area is blank when in Insert mode. Double-click to change to Overwrite mode; single-click
to return to Insert mode. In Insert mode, any text after the cursor position moves forward to
make room for the text you type; in Overwrite mode, text after the cursor position is replaced by
the text you type. This feature is disabled when in Edit > Changes > Record mode.

Selection mode
Click to choose different selection modes. The icon does not change, but when you hover the
mouse pointer over this field, a tooltip indicates which mode is active.

When you click in the field, a context menu displays the available options.

Mode Effect

Standard selection Click in the text where you want to position the cursor; click
in a cell to make it the active cell. Any other selection is then
deselected.

Extending selection (F8) Clicking in the text extends or crops the current selection.

Adding selection (Shift+F8) A new selection is added to an existing selection. The result
is a multiple selection.

Block selection (Ctrl+Shift+F8) A block of text can be selected.

On Windows systems, you can hold down the Alt key while dragging to select a block of text.
You don't need to enter the block selection mode.

See Chapter 3, Working with Text, for more information about these modes.

Document changes status
The icon that is displayed here changes from this one ( [ ) if the document has no unsaved
changes, to this one (E*‘) if it has been edited and the changes have not been saved.

Digital signature

If the document has been digitally signed, this icon (|:ﬁ) is displayed here; otherwise, it is blank.
To view the certificate, double-click the icon.

Section or object information
When the cursor is in a section, heading, or list item, or when an object (such as a picture or
table) is selected, information about that item appears in this field. Double-clicking in this area
opens a relevant dialog.

Object Information shown Dialog opened

Picture Size and position Picture

List item Level and list style Bullets and Numbering1
Heading Outline numbering level Bullets and Numbering1
Table Name or number and cell reference of cursor | Table Format

Section Name of section Edit Sections

Other (Blank) Fields

1 If alist style was used with a list item or heading, no dialog appears.
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View layout
Click an icon to change between single page, side-by-side, and book layout views (see Figure
13). You can edit the document in any view. Zoom settings (see below and next page) interact
with the selected view layout and the window width to determine how many pages are visible in
the document window.

Zoom
To change the view magnification, drag the Zoom slider, or click on the + and - signs, or right-
click on the zoom level percent to pop up a list of magnification values from which to choose.

= - + | 100%:
|:..-E.|i ._IEIEI_._. .||..im
1 1 2 1
2 3 4 23
3 5 6 4|5

Figure 13: View layouts: single, side-by-side, book

Sidebar

To activate the Sidebar, select View > Sidebar from the Menu Bar. The sidebar is located on the
right side of the edit view. The sidebar (Figure 14) contains four decks: Properties, Styles and
Formatting, Gallery, and Navigator. Each deck has a corresponding icon on the Tab bar to the right
of the sidebar, allowing you to switch between them.

Each deck consists of a title bar and one or more content panels. A panel is like a combination of
toolbar and dialog. Toolbars and sidebar panels share many functions. For example, the buttons
for making text bold or italic exist in both the Formatting toolbar and the Character panel of the
Properties deck.

Some panels contain a More button ( &= ) which when clicked opens a dialog to give greater

choice of editing controls.The dialog that opens locks the document for editing until the dialog is
closed.
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Figure 14: Sidebar Properties deck and text context panels

The decks are described below.

* Properties: Contains tools for direct formatting within the document. The tools are
separated into three panels for text editing:

Character: Modify text by the font type, size, color, weight, style and spacing.

Paragraph: Style the paragraph by alignment, lists or bullets, background color, indent,
and spacing.
Page: Format the page by orientation, margin, size, and number of columns.

If a graphic is selected, then the following panels open:

Graphic: Modify the graphic's brightness, contrast, color mode and transparency.
Position: Modifications to width and height.
Wrap: Permits wrap modifications where these are available.

f a drawing object is selected, then the following panels are available;

Area: Fill and transparency edits are available.
Line: Permits edits to the line style, width, color, arrows, corners and cap styles.
Position and Size: Enables edits to width, height, rotation and flip attributes.

If a frame is selected, then the wrap panel opens but may be grayed-out if frame wrap is
not available.

Caution Be aware that by changing the options on the Page panel you will change the page

A

style in use, modifying not only the current page but all pages using the same page
style.
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e Styles and Formatting: Manage the styles used on the document, applying existing styles,
creating new ones or modifying them. This deck is also a floating toolbar that can be
accessed from Format > Styles and Formatting from the Menu bar.

* Gallery: Add images and diagrams included in the Gallery themes. The Gallery displays as
two sections; the first lists the themes by name (Arrows, Background, Diagrams, etc.) and
the second displays the images in the selected category. Select the New Theme button to
create new categories. To insert an image, or add a new image to the gallery, drag and
drop the selected image. This deck is also a docked toolbar that can be accessed from
Tools > Gallery or the Gallery button on the Standard Toolbar.

* Navigator: Browse the document and reorganize its content by selecting different content
categories, such as headings, tables, frames, graphics, etc. The Sidebar Navigator does
not contain a List Box On/Off button. This deck is also a floating toolbar that can be
accessed from View > Navigator or the Navigator button on the Standard Toolbar.

Navigator x

Jn

@-& P 19 3 e
]

= & eE & -

= [Z| Headings 2
+  Copyright <

Mote for Mac users 2

What is Writer? -

#  Parts of the main Writer window s
Changing document views ["‘\".S

#  Starting a new document -
Cpening an existing document LS
[ S S | ———L

Figure 15: The Navigator deck

The Sidebar has on its left edge a Hide button (see Figure 16); click this button to hide the panel by
collapsing it to the right edge of the window. Click the button on a collapsed panel to reopen it.

To adjust the width of the panel, place the cursor on the left edge of the panel, click and drag to
right or left depending on the starting width. With the Properties deck selected, you cannot drag to
less than a certain width. With any of the other decks selected, you can drag the panel width to a
minimum useable width; an arrow then indicates that when you release the mouse button, the
Sidebar will collapse to the width of the Tab bar (see Figure 17).
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Figure 16: Sidebar Hide button

Changing document views
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2

Figure 17: Panel dragged past minimum useable
width showing arrow

Writer has three ways to view a document: Print Layout, Web Layout, and Full Screen. To change
the view, go to the View menu and click on the required view.

Print Layout is the default view in Writer. In this view, you can use the Zoom slider and the View
Layout icons on the Status bar to change the magnification.

You can also choose View > Zoom > Zoom from the Menu bar to display the Zoom & View
Layout dialog, where you can set the same options as on the Status bar.

In Web Layout view, you can use only the Zoom slider; the View Layout buttons on the Status bar
are disabled, and most of the choices on the Zoom & View Layout dialog are not available.

-

Zoom & View Layout

w

Zoom factor
" optimal
() Fit width and height
) Fit wid

() Variable: | 100%:

View layout
@ Automatic
() Single page
() Columns: |2

Book mode

| ok || canel || hep

Figure 18: Choosing Zoom and View Layout options
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In Full Screen view, the document is displayed using the zoom and layout settings previously
selected. To exit Full Screen view and return to either Print or Web Layout view, press the Esc key
or toggle the Full Screen button on the floating toolbar in the top left-hand corner. You can also
use Ctrl+Shift+J to enter or exit Full Screen view.

Starting a new document

You can start a new, blank document in Writer in several ways. If a document is already open in
LibreOffice, the new document opens in a new window.

From the Start Center

When LibreOffice is open but no document is open, the Start Center is shown. Click the Create:
Writer Document button to create a new text document, or click the Templates button to start a
new document using a template.

it 8]

File Tools Help

= QOpen File

‘ Templates

Create: [J LibreOffice

Thet Decusment Foundation

% Writer Document Y

Calc Spreadsheet Chapter 1

Infroducing Wiiter

Impress Presentation
Draw Drawing .
Math Form

WGE400 INew-IntrodudingWriter

™ Base Database / ..
‘ -

v

Figure 19: LibreOffice Start Center

From the Quickstarter

When LibreOffice is installed on computers running Windows or Linux, a Quickstarter feature may
also be installed. Computers with a Mac operating system do not have a Quickstarter.

The Quickstarter is an icon that is placed in the system tray during system startup. It indicates that
LibreOffice has been loaded and is ready to use. The Quickstarter must be enabled in Tools >
Options > LibreOffice > Memory by selecting the checkbox.

Right-click the Quickstarter icon (Figure 20) in the system tray to open a pop-up menu from which
you can create a new document, or open the Template Manager dialog. You can also double-click
the Quickstarter icon to display the Template Manager dialog.
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See Chapter 1, Introducing LibreOffice, in the Getting Started guide for more information about
starting Writer and using the Quickstarter.

% Text Document
Spreadsheet
Presentation
|&] Drawing
Database
Formula

@ From Template...

" Open Document...

v Load LibreQffice During System Start-Up

¢ Exit Quickstarter =
a

Figure 20: Quickstarter pop-up menu

From the operating system menu

You can open the LibreOffice Start Center or the Writer component from the operating system
menu in the same way that you start other programs. When LibreOffice was installed on your
computer, in most cases a menu entry for each component was added to your system menu. If you
are using a Mac, you should see the LibreOffice icon in the Applications folder. When you double-
click this icon, LibreOffice opens at the Start Center (Figure 19).

From the menu bar, toolbar, or keyboard

When LibreOffice is open, you can also start a new document in one of the following ways.
* Press the Ctrl+N keys.
* Use File > New > Text Document.
* Click the New button on the Standard Toolbar.

From a template

You can use templates to create new documents in Writer. A template is a set of predefined styles
and formatting. Templates serve as the foundation of a set of documents, to make sure they all
have a similar layout. For example, all the documents of the Writer Guide are based on the same
template. As a result, all the documents look alike; they have the same headers and footers, use
the same fonts, and so on.

A new LibreOffice installation does not contain many templates. It is possible for you to add new
templates to your installation and use them for new documents. This is explained in Chapter 10,
Working with Templates. More templates can be downloaded from http://templates.libreoffice.org/
and other websites.

Once you have templates on your system, you can create new documents based on them by using
File > Templates > Manage (Ctrl+Shift+N), File > New > Templates or click the arrow button next
to the New Document button on the Standard Toolbar and select Templates from the drop-down
list. This opens the Template Manager dialog where you can choose the template you want to use
for your document.
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The example shown in Figure 21 uses a template in the Documents > My Templates folder.
Double-click on the required template. A new document is created based on the styles and formats
defined in the template.

|8 0 0 Template Manager

rm Spreadsheets  Presentations | Drawings |

Eopen [ Edit @P{openies Set as default ‘f_xIE Maove to folder - = Export @ Delete Q -

L

All Templates My Templates

= | ad

LO_3_4_book_te LO_3_4_chapter_ LO_3_4_printed_ mediawiki

mplate template book_template

Figure 21: Creating a document from a template

Opening an existing document

When no document is open, the Start Center (Figure 19) provides an Open File button for
navigating to saved files. It also displays, in the right pane, recently opened documents; click one
to open it.

You can also open an existing document in one of the following ways. If a document is already
open in LibreOffice, the second document opens in a new window.

* Choose File > Open.
* Click the Open button on the Standard Toolbar.

* Click the down-arrow on the Open button on the Standard Toolbar to select a recent
document.

* Press Ctrl+O on the keyboard.
* Use File > Recent Documents to make a selection.
¢ Use Open Document on the Quickstarter.

Except for the selection of recent documents, the actions above launch the Open dialog. Select the
file you want, filtering by version if required and available, and then click Open. If a document is
already open in LibreOffice, the second document opens in a new window.

In the Open dialog, you can reduce the list of files by selecting the type of file you are looking for.
For example, if you choose Text documents as the file type, you will only see documents Writer
can open (including ODT, DOC, TXT). This method opens Word (DOC and DOCX) files as well as
LibreOffice files and other formats.

You can also open an existing Writer document using the same methods you would use to open
any document in your operating system.

If you have associated Microsoft Office file formats with LibreOffice, you can also open these files
by double-clicking on them.
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Saving a document

To save a new document in Writer, do one of the following:
* Press Ctri+S.
* Choose File > Save.
* Click the Save button on the Standard Toolbar.

When the Save As dialog appears, enter the file name, verify the file type, and click Save.

To save an opened document with the current file name, select one of the above options. This will
overwrite the last saved state of the file.

To save an opened document with a different file name in order to preserve the original and have
edits saved in another version, choose File > Save As, give it another name and/or select a
different file type. A document can be saved with the same file name if the file type is changed, but
must have a different name if the same file type is retained. File > Save a Copy behaves in a
similar fashion.

Saving a document automatically

You can choose to have Writer save your document automatically in a temporary file at regular
intervals. Automatic saving, like manual saving, overwrites the last saved state of the target file in
the temporary file. To set up automatic file saving:

8) Select Tools > Options > Load/Save > General.

9) Click on Save AutoRecovery information every and set the time interval. The default
value is 15 minutes. Enter the value you want by typing it or by pressing the up or down
arrow keys.

Saving as a Microsoft Word document

If you need to exchange files with users of Microsoft Word who are unwilling or unable to receive
Open Document Format (ODF) files, you can save a document as a Microsoft Word file.

1) Important—First save your document in the file format used by LibreOffice Writer, ODT. If
you do not, any changes you made since the last time you saved will only appear in the
Microsoft Word version of the document.

2) Then click File > Save As.

3) On the Save As dialog, in the File type (or Save as type) drop-down menu, select the type
of Word format you need. You may also choose to change the file name.

4) Click Save.

From this point on, all changes you make to the document will occur only in the new (Microsoft
Word) document. You have changed the name and file type of your document. If you want to go
back to working with the ODT version of your document, you must open it again.

To have Writer save documents by default in the Microsoft Word file format, go to
Tools > Options > Load/Save > General. In the section named Default file format
and ODF settings, under Document type, select Text document, then under
Always save as, select your preferred file format.

Tip
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It is recommended that if you use a Microsoft Word format, you use the DOC and
Caution not the DOCX (XML) format. There is anecdotal evidence that the DOCX format
experiences problems even within native Microsoft applications. Saving in ODF
A format gives you the option to redo the document if the recipient of your document
experiences trouble with the Microsoft format.

Warn when not saving in ODF or default format

Document type: Text document v
Always save as: é:JDF Text Document iq
CDF Text Document Template
ODF Text Document

Microsaft Ward 2007/2010,/2013 XML

e

Inified Office Format text
Text
OpenOffice.org 1.0 Text Document Template
OpenDocument Text (Flat XML)
Dffice Open ¥ML Text
Microsoft Word 97/2000,/%P/2003 I
ext Encoded
Rich Text
DocBook

OpenOffice.org 1.0 Text Document
Microsoft Waord 2003 XML
oCUmen TITEr

Figure 22: Saving a file in Microsoft Word format

Password protection

Writer provides two levels of document protection: read-protect (file cannot be viewed without a
password) and write-protect (file can be viewed in read-only mode but cannot be changed without
a password). Thus you can make the content available for reading by a selected group of people
and for reading and editing by a different group. This behavior is compatible with Microsoft Word
file protection.

1) Use File > Save As when saving the document. (You can also use File > Save the first
time you save a new document.)

2) On the Save As dialog, select the Save with password option, and then click Save.

File name: ‘020IWGS—IntroducingWriter
File type: ODF Text Document (.odt)
Save with password: Automa
[ Edit filter settings

3) The Set Password dialog opens.
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Set Password

File encryption password

Enter password to open

Confirm password

Mote: After a password has been set, the document will only
open with the password. Should you lose the password, there
will be no way to recover the document. Please also note that
this password is case-sensitive.

K ] [ Cancel

File sharing password
[ ] open file read-only

Enter password to allow editing

Confirm password

Figure 23: Two levels of password protection

Here you have several choices:

* To read-protect the document, type a password in the two fields at the top of the
dialog.

*  To write-protect the document, click the More Options button and select the Open
file read-only checkbox.

*  To write-protect the document but allow selected people to edit it, select the Open file
read-only checkbox and type a password in the two boxes at the bottom of the dialog.

4) Click OK to save the file. If either pair of passwords do not match, you receive an error
message. Close the message box to return to the Set Password dialog and enter the
password again.

In LibreOffice 3.5, a different encryption was introduced to replace the previously used one. In
consequence, files encrypted with LibreOffice 3.5 or later can not be opened by earlier versions of
LibreOffice. Files with the old encryption can be used in LibreOffice 3.5 and later.

Caution . , : . :
j LibreOffice uses a very strong encryption mechanism that makes it almost

impossible to recover the contents of a document if you lose the password.

Changing the password for a document

When a document is password-protected, you can change the password while the document is
open. Choose File > Properties > General and click the Change Password button.
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Closing a document

If only one document is open and you want to close that document, go to File > Close on the
Menu bar or click on the X on the Title bar. The X may be located on either the right or left end of
the Title bar.

If more than one document is open and you want to close one of them, go to File > Close on the
Menu bar or click on the X on the Menu bar of that document’s window. When only the last
document is open, the X on the Menu bar disappeatrs.

If the document has not been saved since the last change, a message box is displayed. Choose
whether to save or discard your changes.

Closing LibreOffice

To close LibreOffice completely, go to File > Exit on the menu bar in Windows and Linux operating
systems. In a Mac operating system, go to LibreOffice > Quit LibreOffice on the menu bar.

When you close the last document using the X on the Title bar of the window, then LibreOffice will
close completely. A Mac operating system does not have this function; instead, you need to go to
LibreOffice > Quit LibreOffice on the menu bar.

You can also use a keyboard shortcut as follows:
* In Windows and Linux — Ctrl+Q
* In Mac OS X — Command $#+Q

If any documents have not been saved since the last change, a message box is displayed. Choose
whether to save or discard your changes.

Using the Navigator

In addition to the Page Number field on the Status bar (described on page 23), Writer provides
other ways to move quickly through a document and find specific items by using the many features
of the Navigator, the Navigation toolbar, and related buttons.

The Navigator lists all of the headings, tables, text frames, graphics, bookmarks, and other objects
contained in a document.

To open the Navigator do one of the following;
* Click its button (|<*|) on the Standard Toolbar.
* Press F5.

* Choose View > Navigator on the Menu bar.
* Double-click on the Page number field on the status bar.

* Click the Navigator tab (#) ) on the Sidebar (View > Sidebar to open it).

You can dock the Navigator to either side of the main Writer window or leave it floating, even from
the Sidebar, (see “Docking/floating windows and toolbars” on page 20).

To hide the list of categories and show only the buttons at the top, click the List Box On/Off button
(Z1)). Click this button again to show the list. The Sidebar Navigator does not have this button.
Click the + sign or triangle by any of the lists to display the contents of the list.

Table 2 summarizes the functions of the buttons at the top of the Navigator.
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The Navigator has different functions in a master document. See Chapter 13,

Note Working with Master Documents.

Havigator D
®-& T 2 k-
EE b ®eaE E-

[ Tables

; [ _‘ Text frames
. Image

(¥ OLE objects
=] Bookmarks
[Z] sections

= Hyperlinks

|E3| References

O

(=] indexes
E Comments
[ Nraw ohierts

WE400 INew-IntrodudngWriter (active) ™|

O O

Figure 24: The Navigator

Table 2: Function of buttons in the Navigator

I Toggle: Not active in ordinary documents (left image). In a master document (right
image), switches between the master document file and its subdocuments.

@ - Navigation: Opens the Navigation toolbar (see page 37).

Previous, Next: Jumps to the previous or next item in the selected category (page,

& T graphic, hyperlink, comment, and so on). To select the category of items, see “Using
the Navigation toolbar” on page 37.

1 @ Page number: Jumps to the page sequence number showing in the box. Type the
required page number or select it using the up and down arrows.

W Drag Mode: Select Hyperlink, Link, or Copy. See “Choosing drag mode” on page 39
for details.

= List Box On/Off: Shows or hides the list of categories. (Not Sidebar).

El Content View: Switches between showing all categories and showing only the
selected category.

@ Set Reminder: Inserts a reminder (see page 39).

E Ly Header/Footer: Jumps between the text area and the header or footer area (if the
page has them).

55 Anchor <—> Text: Jumps between a footnote anchor and the corresponding footnote

text.

i
4

Heading Levels Shown: Choose the number of heading levels to be shown.
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Moving quickly through a document

The Navigator provides several convenient ways to move around a document and find items in it:

* To jump to a specific page in the document, type its sequence number in the box at the top
of the Navigator and press Enter. The sequence number may be different from the page
number if you have restarted numbering at any point.

* When a category is showing the list of items in it, double-click on an item to jump directly to
that item’s location in the document. For example, you can jump directly to a selected
heading, graphic, or comment by using this method.

To see the content in only one category, highlight that category and click the Content View
button. Click the button again to display all the categories. You can also change the number
of heading levels shown when viewing Headings.

* Use the Previous and Next buttons to jump to other objects of the type selected in the
Navigation toolbar. (See next page for details.)

A hidden section (or other hidden object) in a document appears gray in the
Note Navigator, and displays the word “hidden” as a tooltip. For more about hidden
sections, see Chapter 4, Formatting Pages.

Objects are much easier to find if you have given them names when creating them,

instead of keeping LibreOffice’s default names of graphicsl, graphics2, Tablel,

Table2, and so on—which may not correspond to the position of the object in the
Tip document.

To rename an image, right-click on the image, select Picture > Options, and then
edit the name in the dialog. Similarly, to rename a table, right-click on the table,
select Table > Table, and then edit the name.

Using the Navigation toolbar
To display the Navigation toolbar (Figure 25), click the Navigation button (@ - ) (second button

from the left at the top of the Navigator, Figure 24) or the small Navigation button near the lower
right-hand corner of the document window below the vertical scroll bar (Figure 26).

Mawvigation [j
HOE o5 E 0 2 [E
E«wE0&EEHE

Page

ki

i
4

Figure 25: Navigation toolbar

Prwinus-h\\ w
— (2]
Navigation
Next|= — (3]
GOGMS | - - + | 100%

Figure 26: Previous, Navigation, and Next buttons
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The Navigation toolbar has buttons for all the object types shown in the Navigator, plus some
extras (for example, the results of a Find command).

Click a button to select that object type. Now all the Previous and Next buttons (in the Navigator
itself, in the Navigation toolbar, and on the scroll bar) will jump to the previous or next object of the
selected type. This is particularly helpful for finding items like index entries, which can be difficult to
see in the text. The names of the buttons (shown in the tooltips) change to match the selected
category; for example, Next Graphic, Next Bookmark, or Continue search forward.

Rearranging chapters using the Navigator

You can rearrange chapters and move headings in the document by using the Navigator.
1) Click the Content View button to expand the headings, if necessary.

2) (Optional) If you have several subheading levels, you can more easily find the headings
you want, by changing the Heading Levels Shown selection to show only 1 or 2 levels of
headings.

3) Click on the heading of the block of text that you want to move and drag the heading to a
new location on the Navigator, or click the heading in the Navigator list, and then click
either the Promote Chapter or Demote Chapter button. All of the text and subsections
under the selected heading move with it.

To move only the selected heading and not the text associated with the heading, hold down
Ctrl, and then click the Promote or Demote button.

The tooltips Promote Chapter and Demote Chapter can be misleading; all
headings—whether at Level 1 (chapter) or lower—can be rearranged using this
function; and the feature might be better described as Move Up or Move Down
(within the document, without changing the heading level) to distinguish it more
clearly from Promote Level and Demote Level, which change the heading level
within the document (see below).

Tip

4) To quickly change the outline level of a heading and its associated subheadings, select the
heading in the Navigator, and then click either the Promote Level or Demote Level
button. This action does not change the location of the heading, only its level.

To increase the outline level of only the selected heading, but not its associated
subheadings, hold down Ctrl, and then click the button.

Promote Demote

chapter chapter
Promote Demote

lewel lewel

Figure 27: Reorganizing with the Navigator

Users of Microsoft Word will note the similarity between this functionality and Word's

Note Outline View.
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Setting reminders

One of the little-known features of Writer that you may find quite useful is the possibility of jumping
between reminders. Reminders let you mark places in your document that you want to return to
later on, to add or correct information, make some other change, or simply mark where you
finished editing. The possible uses of reminders are limited only by your imagination.

To set a reminder at the cursor's current location, click on the ( [@ ) button in the Navigator. You
can set up to 5 reminders in a document; setting a sixth causes the first to be deleted.

Reminders are not highlighted in any way in the document, so you cannot see where they are,
except when you jump from one to the next—the location of the cursor then shows the location of
the reminder.

To jump between reminders, first select the Reminder button on the Navigation toolbar. Then click
the Previous and Next buttons. Reminders are not saved with the document.

Choosing drag mode

To select the drag and drop options for inserting items such as other documents and images, into a
document using the Navigator, choose one of the following from the drop-down menu of the Drag
Mode button.

Insert As Hyperlink
Creates a hyperlink when you drag and drop an item into the current document.

Insert As Link
Inserts the selected item as a link where you drag and drop in the current document. Text is
inserted as protected sections. However, you cannot create links for graphics, OLE obijects,
references, or indexes using this method.

Insert As Copy

Inserts a copy of the selected item where you drag and drop in the current document. You
cannot drag and drop copies of graphics, OLE objects, or indexes.

Undoing and redoing changes

When a document is open, you can undo the most recent change by pressing Ctrl+Z, or clicking
the Undo button (%= ~ ) on the Standard Toolbar, or choosing Edit > Undo from the Menu bar.

The Edit menu shows the latest changes that can be undone.

File |Edit View Insert Format Table Tools Wi

E = Undo: Typing: 'undone’ Ctrl+2 lf
= I :\:._,_' : trl+Y
¢ |

@ Repeat: Typing: 'undong’ Cirl+Shift+Y
L

L "l

1

(]
L}

- -
oYy iy

4

Figure 28: Edit > Undo last action
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Click the down arrow button of the Undo combination button to get a list of all the changes that can
be undone. You can select multiple changes and undo them at the same time (see Figure 29).

—O SE-D |

Actions to undo: 1

Delete Image i
Typing: ‘button’

Typing: '

Typing: ‘ombination’ L
Replace: icon’ -= ¢

Typing: ‘arrow’ |
Typing: ' i
Typing: ‘own’ li
Replace: 'small tri...he right' -=d  [*]
FAAEAMNaET TRAT FAan Ae Tirmhme

Figure 29: List of actions that can be undone

After changes have been undone, Redo becomes active. To redo a change, select Edit > Redo, or
press Ctrl+Y or click on the Redo button (& ~ ). As with Undo, click on the down arrow button of

the combination button to get a list of the changes that can be restored.
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Choosing options that affect all LibreOffice components

This section covers some of the settings that apply to all the components of LibreOffice and are
particularly important when using Writer. Other general options are discussed in Chapter 2, Setting
up LibreOffice, in the Getting Started guide.

Click Tools > Options. The list on the left-hand side of the Options — LibreOffice dialog varies
depending on which component of LibreOffice is open. The illustrations in this chapter show the list
as it appears when a Writer document is open.

Click the marker (+ or triangle) by LibreOffice on the left-hand side. A list of pages drops down.
Selecting an item in the list causes the right-hand side of the dialog to display the relevant page.

The Revert button (located in the lower right of the full Options dialog) has the same
Note effect on all pages of the dialog. It resets options to the values that were in place
when you opened the dialog.

If you are using a version of LibreOffice other than US English, some field labels may be different
from those shown in the illustrations.

User Data options

Because Writer can use the name or initials stored in the LibreOffice — User Data page for
several things, including document properties (created by and last edited by information) and the
name of the author of comments and changes, you will want to ensure that the correct information
appears here.

Fill in the form (not shown here) or amend or delete any existing incorrect information. If you do
not want user data to be part of the document’s properties, clear the box at the bottom.

General options

The options on the LibreOffice — General page are described below.

Help
Tips [ Extended tips

Open/save dialogs
Use LibreOffice dialogs

Document status
[ ] Printing sets "document modified” status

[] Allow to save document even when the document is not modified

Year (two digits)

e

Interpret as years between 1930 |3 and 2029
Figure 30: Setting general options for LibreOffice
Help - Tips

When Tips is active, one or two words will appear when you hold the mouse pointer over an
icon or field, without clicking.
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Help - Extended tips
When Extended tips is active, a brief description of the function of a particular icon or menu
command or a field on a dialog appears when you hold the mouse pointer over that item.

Open/Save dialogs — Use LibreOffice dialogs
To use the standard Open and Save dialogs for your operating system, deselect the Use
LibreOffice dialogs option. When this option is selected, the Open and Save dialogs supplied
with LibreOffice will be used. See Chapter 1, Introducing Writer, for more about the LibreOffice
Open and Save dialogs. This book uses the LibreOffice Open and Save dialogs in illustrations.

Document status - Printing sets “document modified” status
If this option is selected, then the next time you close the document after printing, the print date
is recorded in the document properties as a change and you will be prompted to save the
document again, even if you did not make any other changes.

Document status - Allow to save document even when the document is not modified
Normally when a document has not been modified, the File > Save menu option and the Save
button on the Standard Toolbar are disabled and the keyboard shortcut Ctr/+S has no effect.
Select this option to allow documents to be saved even when they have not been modified.

Year (two digits)
Specifies how two-digit years are interpreted. For example, if the two-digit year is set to 1930,
and you enter a date of 1/1/30 or later into your document, the date is interpreted as 1/1/1930
or later. An “earlier” date is interpreted as being in the following century; that is, 1/1/20 is
interpreted as 1/1/2020.

Memory options

The options on the LibreOffice — Memory page control how LibreOffice uses your computer’s
memory and how much memory it requires.

Undo

Mumber of steps 100 =

Graphics cache

Use for LibreQffice 20 > MB
Memory per object 5.2 +1| MBE
Remowe from memory after 00:10 |5 hh:mm

Cache for inserted ohjects
Mumber of objects 20 S

LibreOffice Quickstarter
| Load LibreOffice during system start-up

Figure 31: Choosing Memory options for LibreOffice

Before changing these options, you may wish to consider the following points:

* More memory can make LibreOffice faster and more convenient (for example, more undo
steps require more memory); but the trade-off is less memory available for other
applications and you could run out of memory altogether.

* |f your documents contain a lot of objects such as images, or the objects are large,
LibreOffice’s performance may improve if you increase the memory for LibreOffice or the
memory per object. If you find that objects seem to disappear from a document that
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contains a lot of them, increase the number of objects in the cache. (The objects are still in
the file even if you cannot see them on screen.)

* To load the Quickstarter when you start your computer, select the option near the bottom of
the dialog. This makes LibreOffice start faster; the trade-off is that LibreOffice uses some
memory even when not being used. This option (called Enable systray Quickstarter on
Linux) is not available on Mac OS X or on systems where the Quickstarter module has not
been installed.

View options

The options on the LibreOffice — View page affect the way the document window looks and
behaves. Some of these options are described below. Set them to suit your personal preferences.

User Interface Graphics output
Scaling 100% | Use hardware acceleration

Icon size and style Use Anti-Aliasing

Automatic | w | |Automatic (Tango) |+

Mouse
Use system font for user interface Mouse positioning
Mo automatic positioning |
Menu Middle Mouse button
Icons in menus  [Automatic | Automatic scroling -
Font Lists Selection

Show preview of fonts

Transparency |75% %
Show font history [¥] Transp v A

Figure 32: Choosing View options for LibreOffice applications

User Interface - Scaling
If the text in the help files or on the menus of the LibreOffice user interface is too small or too
large, you can change it by specifying a scaling factor. Sometimes a change here can have
unexpected results, depending on the screen fonts available on your system. However, it does
not affect the font size of the text in your documents.

User Interface - Icon size and style
The first box specifies the display size of toolbar icons (Automatic, Small, or Large); the
Automatic icon size option uses the setting for your operating system. The second box
specifies the icon style (theme); here the Automatic option uses an icon set compatible with
your operating system.

User Interface — Use system font for user interface
If you prefer to use the system font (the default font for your computer and operating system)
instead of the font provided by LibreOffice for the user interface, select this option.

User interface — Screen font Anti-Aliasing
(Not available in Windows; not shown in Figure 32.) Smooths the screen appearance of text.
Enter the smallest font size to apply anti-aliasing.

Menu - Icons in menus
Causes icons as well as words to be visible in menus. Choice of Automatic, Hide or Show.
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Font Lists — Show preview of fonts
Causes the font list to look like Figure 33, Left, with the font names shown as an example of
the font. With the option deselected, the font list shows only the font names, not their formatting
(Figure 33, Right). The fonts you will see listed are those that are installed on your system.

Fonts which are tuned for use with a specific script, such as Arabic, Hebrew, Malayalam, and
so on, now show an additional preview of some sample text in the target script.

Liberation Sans 12 v| & 4 A ||| Liberation Sans| 12 w
A

: = Liberation Sans -
LIbE—fE?IIIDﬂ Sans Liberation Sans Marrow
Liberation Sans Marrow Liberation Serif

, . . Liffey Script SF
Liberation Serif LilyUPC
Tl Feimt FF Linux Biclinum G

_ Linux Libertine Display G

Lyupc dniusing Linux Libertine G
Linux Biolinum G Lucida Bright

. ) . . Lucida Caligraphy
Linux Libertine Display G Lucida Console

. . . Lucida Fax
I'mu_x I.leI‘.tHlE G Lucida Handwriting
Lucida Bright Lucida Sans

- - Lucida Sans Typewriter

Lucida Cﬂ&g?ﬂﬁﬁy Lucida Sans Unicode
Lucida Console v Mackintosh S hd

Figure 33: Font list (Left) showing preview; (Right) without preview

Font Lists — Show font history

Causes the last five fonts you have assigned to the current document to be displayed at the top
of the font list.

Graphics output — Use hardware acceleration
Directly accesses hardware features of the graphical display adapter to improve the screen
display. Not supported on all operating systems and LibreOffice distributions.

Graphics output — Use Anti-Aliasing
Enables and disables anti-aliasing, which makes the display of most graphical objects look
smoother and with fewer artifacts. Not supported on all operating systems and LibreOffice
distributions.

Press Shift+Ctrl+R to restore or refresh the view of the current document after
changing the anti-aliasing settings, to see the effect.

Tip
Mouse positioning
Specifies if and how the mouse pointer will be positioned in newly opened dialogs.

Middle mouse button
Defines the function of the middle mouse button.

* Automatic scrolling — dragging while pressing the middle mouse button shifts the view.

¢ Paste clipboard — pressing the middle mouse button inserts the contents of the “Selection
clipboard” at the cursor position.

The “Selection clipboard” is independent of the normal clipboard that you use by Edit >
Copyl/Cut/Paste or their respective keyboard shortcuts. Clipboard and “Selection clipboard”
can contain different contents at the same time.
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Function Clipboard Selection clipboard

Copy content Edit > Copy or Ctrl+C Select text, table, or object.
Paste content Edit > Paste or Ctrl+V pastes Clicking the middle mouse button

at the cursor position. pastes at the mouse pointer position.
Pasting into another No effect on the clipboard The last marked selection is the
document contents. content of the selection clipboard.

Selection — Transparency
Determines the appearance of selected text or graphics, which appear on a shaded
background. To make the shaded background more or less dark, increase or decrease the
Transparency setting.

If you prefer selected material to appear in reversed color (typically white text on a black
background), deselect this option.

Print options

On the LibreOffice — Print page, set the print options to suit your default printer and your most
common printing method.

Reduce print data

Settings for: (=) Printer () Print to file
(¥ Reduce transparency # Reduce gradient
() Automatically (s) Gradient stripes |64 |

(1 No transparenc i
! p  § () Intermediate color

v Reduce bitmaps | | Convert colors to grayscale
() High print quality
() Normal print quality
(=) Resolution |[200 DPI (default)
™ Include transparent objects

(¥ PDF as Standard Print Job Format

4k

Printer warnings
[ | Paper size v Transparency

| Paper orientation

Figure 34: Choosing general printing options to apply to all LibreOffice components

The option PDF as Standard Print Job Format is not available on Windows. Select this option to
change the internal print job format from a Postscript document description to a PDF description.
This format has a number of advantages over Postscript. For more information, see
http://www.linuxfoundation.org/collaborate/workgroups/openprinting/pdf_as_standard_print_job_format

Deselecting this option reverts to the Postscript document workflow system.

In the Printer warnings section near the bottom of the page, you can choose whether to be warned
if the paper size or orientation specified in your document does not match the paper size or
orientation available for your printer. Having these warnings turned on can be quite helpful,
particularly if you work with documents produced by people in other countries where the standard
paper size is different from yours.

46 LibreOffice 4.2 Writer Guide


http://www.linuxfoundation.org/collaborate/workgroups/openprinting/pdf_as_standard_print_job_format
http://www.linuxfoundation.org/collaborate/workgroups/openprinting/pdf_as_standard_print_job_format

If your printouts are incorrectly placed on the page or chopped off at the top, bottom,
Tip or sides or the printer is refusing to print, the most likely cause is page-size
incompatibility.

Paths options

On the LibreOffice — Paths page, you can change the location of files associated with, or used by,
LibreOffice to suit your working situation. In a Windows system, for example, you might want to
store documents by default somewhere other than My Documents.

To make changes, select an item in the list shown in Figure 35 and click Edit. On the Select Paths
dialog (not shown), add or delete folders as required, and then click OK to return to the Options
dialog. Note that many items can have at least two paths listed: one to a shared folder (which
might be on a network) and one to a user-specific folder (normally on the user’s personal
computer). Items with more than one path allowed will use an Edit Paths dialog (not shown).

Paths used by LibreOffice

|Ty|:|e |F‘aﬂ'| |
AutoCorrect C:\Documents and Settings'Pat and JohnApplication DatalLibreQffice\$useriaut
AutoText C:'\Documents and Settings'Pat and John'\Application Data'LibreOffice {4 useriaut
Backups C:\Documents and Settings'Pat and John'Application DatalLibreQfficelduseribag
Dictionaries C:\Documents and Settings'Pat and John'\Application Data'LibreQffice 4 user o
Gallery C:\Documents and SettingsPat and John\Application Data'LibreOffice\4userigall
Images C:\Documents and Settings\Pat and John\Application Data\LibreCffice\$wuserigall
My Documents  C:\Documents and Settings'Pat and JohniMy Documents

Templates C:\Program Files\LibreOffice 4\program!, .\share\templatecomman; C: \Documents

Temporary fles C\DOCUME~1\PATAND ~ 1Y QCALS ~1 Temp

Default ] l Edit. ..

Figure 35: Viewing the paths of files used by LibreOffice

You can use the entries in the LibreOffice — Paths dialog to compile a list of files,
Tip such as those containing AutoText, that you need to back up or copy to another
computer.

Colors options

On the LibreOffice — Colors page, you can specify colors to use in LibreOffice documents. You
can select a color from a color table or selection list, edit an existing color, or define new colors.
These colors will then be available in color selection lists in LibreOffice.

For details on how to maodify a color or create a new color, see Chapter 14, Customizing
LibreOffice, in the Getting Started guide.
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Figure 36: Defining colors to use in color lists in LibreOffice

Fonts options

You can define replacements for any fonts that might appear in your documents. If you receive
from someone else a document containing fonts that you do not have on your system, LibreOffice
will substitute fonts for those it does not find. You might prefer to specify a different font from the
one the program chooses.

Replacement table
Font Replace with
Liberation Sans ¥ | |Open Sans v b4

Screen only Replace with

Liberation Sans

Apply replacement table

Font settings for HTML, Basic and SOL sources

Fonts |Aut|:|rnatic W

Mon-proportional fonts only

Size |m v

Figure 37: Defining a font to be substituted for another font

On the LibreOffice — Fonts page:
1) Select Apply Replacement Table option.

2) Select or type the name of the font to be replaced in the Font box. (If you do not have this
font on your system, it will not appear in the drop-down list in this box, so you need to type
itin.)
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3) Inthe Replace with box, select a suitable font from the drop-down list of fonts installed on

your computer.

4) The check mark to the right of the Replace with box turns green. Click on this check mark.
A row of information now appears in the larger box below the input boxes. Select Always to
replace the font, even if the original font is installed on your system. Select Screen only to

replace the screen font only and never replace the font for printing. The results of
combining these selections are given in Table 3. A listing in the display pane can be

removed by selecting it and clicking the red cross.

5) In the bottom section of the page, you can change the typeface and size of the font used to

display source code such as HTML and Basic (in macros).

Table 3: Font substitution replacement actions

Always Screen only  Replacement action

checkbox checkbox

checked blank Font replacement on screen and when printing, whether the font is
installed or not.

checked checked Font replacement only on screen, whether the font is installed or not.

blank checked Font replacement only on screen, but only if font is not available.

blank blank Font replacement on screen and when printing, but only if font is not
available.

Security options

Use the LibreOffice — Security page to choose security options for documents containing hidden

information and for opening documents that contain macros.

Security options and warnings
Adjust security related options and define warnings for hidden
information in documents.

Passwords for web connections

Persistently save passwords for web connections

Protected by a master password (recommended)

Passwords are protected by a master password. You will be
asked to enter it once per session, if LibreOffice retrieves a
password from the protected password list.
Macro security
Adjust the security level for executing macros and specify trusted
macro developers.
Certificate Path

Select the Network Security Services certificate directory to use
for digital signatures.

Options...

Connections...

Master Password...

Macro Security...

Certificate...

Figure 38: Choosing security options for opening and saving documents

Security Options and warnings

If you record changes, save multiple versions, or include hidden information or notes in your
documents, and you do not want some of the recipients to see that information, you can set
warnings to remind you to remove it, or you can have LibreOffice remove some of it

automatically. Note that (unless removed) much of this information is retained in a file whether
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the file is in LibreOffice’s default Open Document format, or has been saved to other formats,
including PDF.

Click the Options button to open a separate dialog with specific choices (Figure 39).

Passwords for web connections
You can enter a master password to enable easy access to websites that require a user name
and password. If you select the Persistently save passwords for web connections option, a
new dialog opens where you can specify the password. LibreOffice will securely store all
passwords that you use to access files from web servers. You can retrieve the passwords from
the list after you enter the master password.

Macro security

Click the Macro Security button to open the Macro Security dialog, where you can adjust the
security level for executing macros and specify trusted sources.

Certificate Path

This option appears only on Linux and Mac systems. On Windows, LibreOffice uses
Note the default Windows location for storing and retrieving certificates.
Users can digitally sign documents using LibreOffice. A digital signature requires a personal
signing certificate. Most operating systems can generate a self-signed certificate. However, a
personal certificate issued by an outside agency (after verifying an individual's identity) has a
higher degree of trust associated with it than does a self-signed certificate. LibreOffice does not
provide a secure method of storing these certificates, but it can access certificates that have
been saved using other programs. Click Certificate and select which certificate store to use.

Security options and warnings
The following options are on the Security options and warnings dialog (Figure 39).

Remove personal information on saving
Select this option to always remove user data from the file properties when saving the file. To
manually remove personal information from specific documents, deselect this option.

-

Security options and warnings

Security warnings

Warn if document contains recorded changes, versions, hidden information or notes:

[ ] when printing [ ] When creating PDF files

Security options
[ ] Remove personal information on saving
|:| Recommend password protection on sawving
Ctrl-dick required to follow hyperlinks
[ ] Block any links from documents not among the trusted locations (see Macro Security)

ok || concel || neb

Figure 39: Security options and warnings dialog
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Ctrl-click required to follow hyperlinks
The default behavior in LibreOffice is to Ctrl+click on a hyperlink to open the linked document.
Many people find creation and editing of documents easier when accidental clicks on links do
not activate the links. To set LibreOffice to activate hyperlinks using an ordinary click, deselect
this option.

The other options on this dialog should be self-explanatory.

Personalization

Using Personalization, you can add a theme to your LibreOffice installation. Choices on this page
are to not use a Theme, use a pre-installed Theme if one is available, select a Theme from the
Mozilla Firefox site, or add your own design. This option defaults to Pre-installed Theme at
installation time.

Firefox Themes
(" Plain look, do not use Themes

{(*) Pre-installed Theme (if available)

() Own Theme Select Theme

Figure 40: Personalization options

To install a Theme, click the Select Theme button to open the install dialog (Figure 41). From here
you can enter an address (URL) to the theme or click the Visit Firefox Themes button. An internet
connection is required for this process. Installation instructions are on this dialog.

First visit Firefox Themes
(https:/faddons.mozila. orgffirefox/themes). Find the
Theme you like, and want to choose for LibreQffice.

Wisit Firefox Themes:

Then, in your web browser's location bar, copy the
address of the page that contains the Theme to
dipboard, and paste it to the input field below.

Theme address:

ok || caned || heb

Figure 41: Theme installation dialog

Full details about Themes are on the website: https://addons.mozilla.org/en-US/firefox/themes/

|=] Untitled 1 - LibreOffice Writer g@

File Edit View Insert Format Table Tools Window Help
BrBEe v BER ¥E - B @ w2 Yo 9 0

Iil-lJ Default Style v | \Liberation Sans w12 ~ B I Uil

2

Figure 42: An example of an installed theme
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Appearance options

Writing, editing, and (especially) page layout are often easier when you can see the page margins
(text boundaries), the boundaries of tables and sections, grid lines, and other features. In addition,
you might prefer to use colors that are different from LibreOffice’s defaults for such items as
comment indicators or field shadings.

On the LibreOffice — Appearance page, you can specify which items are visible and the colors
used to display various items.

* To show or hide items such as text boundaries, select or deselect the options next to the
names of the items.

* To change the default colors for items, click the down-arrow in the Color setting column by
the name of the item and select a color from the list box. Note that you can change the list
of available colors as described in Chapter 14, Customizing LibreOffice, in the Getting
Started guide.

* To save your color changes as a color scheme, click Save... and you will be prompted for a
name.

Color scheme

Scheme LibreOffice W

Custom colors

User interface elements |Color setting |Preview |
General i
Document background [ automatic |+ I:I

Text boundaries [ automatic |+ I:I
Application background [ automatic [+ I:I

Object boundaries O automatic [+ I:I

Table boundaries [ automatic |w I:I
Font color Il cutomatic | w -

[ Unvisited links Bl cutomatic | -

1 sficited limlen — | ] [

Figure 43: Showing or hiding text, object, and table boundaries

Accessibility options

Accessibility options include whether to allow animated graphics or text, how long help tips remain
visible, some options for high contrast display, and a way to change the font for the user interface
of the LibreOffice program.

Accessibility support relies on the Java Runtime Environment for communication with assistive
technology tools. The Support assistive technology tools option is not shown on all LibreOffice
installations. See Assistive Tools in LibreOffice in the Help for other requirements and information.

Select or deselect the options as required.
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Miscellanecus cptions

[] Support assistive technology tools (program restart required)
[] Use text selection cursor in read-only text docurnents

Allow anirmated graphics

Allow animated text

[V] Help tips disappear after 4 +| seconds

Options for high contrast appearance

Automatically detect high contrast mode of operating system
["] Use automatic font color for screen display

Use systern colors for page previews

Figure 44: Choosing accessibility options
Advanced options

Java options

If you install or update a Java Runtime Environment (JRE) after you install LibreOffice, or if you
have more than one JRE installed on your computer, you can use the LibreOffice — Advanced
options page to choose the JRE for LibreOffice to use.

Optional (unstable) options

Enable experimental features
Selecting this option enables features that are not yet complete or contain known bugs. The list
of these features is different version by version.

Enable macro recording (limited)
This option enables macro recording, with some limitations. Opening a window, switching
between windows, and recording in a different window to that in which the recording began, is
not supported. Only actions relating to document contents are recordable, so changes in
Options or customizing menus are not supported.

Expert Configuration button

Permits detailed changes to the LibreOffice configuration. Most users will have no need to use
this.

Choosing options for loading and saving documents

You can set the Load/Save options to suit the way you work.

If the Options dialog is not already open, click Tools > Options. Click the marker (+ or triangle) to
the left of Load/Save.

General

Most of the choices on the Load/Save — General page are familiar to users of other office suites.
Some items of interest are described below.
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Load
Load user-spedific settings with the document
Load printer settings with the document

Save

Save AutoRecovery information every |15 %= Minutes
[ ] Automatically save the document too
[ ] Edit document properties before saving [ ] Always create backup copy
Save URLs relative to file system Save LURLs relative to internet
Default file format and ODF settings
ODF format version: |1, 2 Extended (recommended) w
Warn when not saving in QDF or default format

Document type: Text document b

Always save as: ODF Text Document W

Figure 45: Choosing Load and Save options

Load user-specific settings with the document

A LibreOffice document contains certain settings which are read from the user's system. When
you save a document, these settings are saved with it.

Select this option so that when a document loads, it ignores the stored settings in favor of the
settings on your computer.

Even if you do not select this option, some settings are taken from your LibreOffice installation:
e Settings available in File > Print > Options
* Name of Fax
* Spacing options for paragraphs before text tables
* Information about automatic updating for links, field functions and charts

* Information about working with Asian character formats.

The following settings are always loaded with a document, whether or not this option is
marked:

¢ Data source linked to the document and its view.

If you deselect this option, the user’s personal settings do not overrule the settings in the
document. For example, your choice (in the options for LibreOffice Writer) of how to update
links is affected by the Load user-specific settings option.

Load printer settings with the document

If enabled, the printer settings will be loaded with the document. This can cause a document to
be printed on a distant printer (perhaps in an office setting), if you do not change the printer
manually in the Print dialog. If disabled, your standard printer will be used to print this
document. The current printer settings will be stored with the document whether or not this
option is selected.

Save AutoRecovery information every _ Minutes

Choose whether to enable AutoRecovery and how often to save the information used by the
AutoRecovery process.
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AutoRecovery in LibreOffice saves the information needed to restore all open documents in
case of a crash. If you have this option set, recovering your document after a system crash will
be easier.

Automatically save the document too
Specifies that LibreOffice saves all open documents when saving auto recovery information.
Uses the same time interval as AutoRecovery does.

Edit document properties before saving
If this option is selected, the document’s Properties dialog pops up to prompt you to enter
relevant information the first time you save a new document (or whenever you use Save As).

Always create backup copy
Saves the previous version of a document as a backup copy whenever you save a document.
Every time LibreOffice creates a backup copy, the previous backup copy is replaced. The
backup copy gets the extension BAK. Authors whose work may be very lengthy should always
consider using this option.

Save URLs relative to file system / to internet
Use these options to select the default for relative addressing of URLSs in the file system and on
the Internet. Relative addressing is only possible if the source document and the referenced
document are both on the same drive.

Arelative address always starts from the directory in which the current document is located. In
contrast, absolute addressing always starts from a root directory. The following table
demonstrates the difference in syntax between relative and absolute referencing:

Examples File system Internet
relative ../images/img.jpg ..[images/img.jpg
absolute file:///lc/work/images/img.jpg http://myserver.com/work/images/img.jpg

If you choose to save relatively, the references to embedded graphics or other objects in your
document will be saved relative to the location in the file system. In this case, it does not matter
where the referenced directory structure is recorded. The files will be found regardless of
location, as long as the reference remains on the same drive or volume. This is important if you
want to make the document available to other computers that may have a completely different
directory structure, drive or volume names. It is also recommended to save relatively if you
want to create a directory structure on an Internet server.

If you prefer absolute saving, all references to other files will also be defined as absolute,
based on the respective drive, volume or root directory. The advantage is that the document
containing the references can be moved to other directories or folders, and the references
remain valid.

Default file format and ODF settings
ODF format version. LibreOffice by default saves documents in Open Document Format
(ODF) version 1.2 Extended. While this allows for improved functionality, there may be
backwards compatibility issues. When a file saved in ODF 1.2 is opened in an earlier version of
LibreOffice (using ODF 1.0/1.1), some of the advanced features may be lost. Two notable
examples are cross-references to headings and the formatting of numbered lists. If you plan to
share documents with people who are still using older versions of LibreOffice, you may wish to
save the document using ODF version 1.0/1.1, even though some information will be lost.

Document type: The default is Text document. If you routinely share documents with users of
Microsoft Word, you might want to change the Always save as attribute for text documents to
one of the Word formats. Current versions of Microsoft Word can open ODF files, so this may
no longer be needed.
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If you need to save in Microsoft Word format, it is good practice to save in
Caution LibreOffice (OpenDocument) format (ODT) first and then do a Save As from your
finished document to a Microsoft Word format. For best results, save to the DOC
A and not the DOCX format. Saving first in ODT format gives you the option to redo
the document if the recipient of your document experiences trouble with the
Microsoft format.

VBA Properties

On the Load/Save — VBA Properties page, you can choose whether to keep any macros in
Microsoft Office documents that are opened in LibreOffice. These macros are disabled in
LibreOffice.

Microsoft Word 97/2000/XP
Load Basic code
Executable code
Save original Basic code

Microsoft Excel 97 /2000 /XP
Load Basic code
Executable code
Save original Basic code

Microsoft PowerPoint 97 /2000 /XP
Load BEasic code
Save original Basic code

Figure 46: Choosing Load/Save VBA Properties

If you choose Load Basic code, you can edit the macros in LibreOffice. The changed code is
saved in an LibreOffice document but is not retained if you save into a Microsoft Office format.

If you are importing a Microsoft Word or Excel file containing VBA code, you can select the option
Executable code. Whereas normally the code is preserved but rendered inactive, with this option
the code is ready to be executed.

If you choose Save original Basic code, the macros are retained unchanged if you save the file
into Microsoft Office format.

Save original Basic code takes precedence over Load Basic code. If both options are selected
and you edit the disabled code in LibreOffice, the original Microsoft Basic code will be saved when
saving in a Microsoft Office format.

To remove any possible macro viruses from the Microsoft Office document, deselect Save original
Basic code. The document will be saved without the Microsoft Basic code.

Microsoft Office

On the Load/Save - Microsoft Office page, you can choose what to do when importing and
exporting Microsoft Office OLE objects (linked or embedded objects or documents such as
spreadsheets or equations).

Select the [L] check boxes to convert Microsoft OLE objects into the corresponding LibreOffice
OLE objects when a Microsoft document is loaded into LibreOffice (mnemonic: “L” for “load”).
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Select the [S] check boxes to convert LibreOffice OLE objects into the corresponding Microsoft
OLE objects when a document is saved in a Microsoft format (mnemonic: “S” for “save”).

Embedded objects

(]
+|  MathType to LibreOffice Math or reverse s
WinWard to LibreQffice Writer ar reverse !

Excel to LibreOffice Calc or reverse
PowerPoint to LibreQffice Impress or reverse L
Smartart to LibreQffice shapes or reverse W

[L]: Load and convert the object

[5]: Convert and save the object

Figure 47: Choosing Load/Save Microsoft Office options

HTML compatibility

Choices made on the Load/Save — HTML Compatibility page (not shown) affect HTML pages
imported into LibreOffice and those exported from LibreOffice. See HTML documents;
importing/exporting in the Help, and the Getting Started book, for more information.

Choosing options for Writer

Settings chosen on the pages in the LibreOffice Writer section of the Options dialog determine how
your Writer documents look and behave while you are working on them.

If the Options dialog is not already open, click Tools > Options.

Click the marker (+ or triangle) by LibreOffice Writer on the left-hand side of the dialog. A list of
pages drops down (see Figure 48).

-
Options - LibreOffice Writer - General
+ LibreOffice Update
+ Load/Save
+ Language Settings Update
- (oY)
®1
Formatting Aids
Grid O1
Basic Fonts (Western) Settings
Print
Table Measu
Changes
Comparison Tab sb
Compatibility
AutoCaption
Mail Merge E-mail

Figure 48: LibreOffice Writer options
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General options

The choices on the LibreOffice Writer — General page affect the updating of links and fields, the
units used for rulers and other measurements, and the default tab stop positions.

Update links when loading Automatically Update
) Always Ficlds
{*) On reguest Charts
) Mever

Settings

Measurement unit  |Inch W

Tab stops 0.25" %

Word Count
Additional separators  |—

Figure 49: Choosing general options for Writer

Update links when loading
Depending on your work patterns, you may not want links to be updated when you load a
document. For example, if your file links to other files on a network, you won’'t want those links
to try to update when you are not connected to the network.

Update fields and charts automatically
You may not want fields or charts to update automatically when you are working, because that
slows down performance.

Settings — Tab stops
The Tab stops setting specifies the distance the cursor travels for each press of the Tab key.
This setting is also used for the indent distance applied by the Increase Indent and Decrease
Indent buttons on the Formatting Toolbar, which affect the indentation of entire paragraphs.

Using the default tab stops to space out or indent material on a page is not recommended. If
you use the default tab interval and then send the document to someone who uses a different
default tab interval, then your tabbed material will be displayed using the other person’s default
tab settings. In addition, any changes to the default tab stops will change the existing default
tab stops in any document you open afterward, as well as tab stops you insert after making the
change.

To avoid these unwanted changes, define your own tabs in paragraph styles or individual
paragraphs (see “Defining your own tab stops and indents” in Chapter 3, Working with Text).

Word Count
Allows extra word boundary characters. This feature overrides long dash (—) and short dash
(-) to be word boundary characters for the purposes of counting words, and allows the user to
specify additional word boundary characters
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View options

Two pages of options set the defaults for viewing Writer documents: View (described here) and
Formatting Aids (described below).

Enabling the Guides helps you to precisely position a drawing object on a page by providing

horizontal and vertical parallel lines the height and width of the object, across the complete working

area of the screen as the object is moved.

If the remaining items on the LibreOffice Writer — View page are not self-explanatory, you can
easily test their effects in a blank document.

This is a good page to check if, for example, you cannot see graphics on the screen or you see
field codes instead of the text or numbers you are expecting.

Guides View
[] Helplines While Moving Horizontal scrollbar
) Vertical scrollbar
Display
: : Ruler
Graphics and objects
Tables Horizontal ruler  |Inch »
Drawings and controls Vertical ruler Inch W
[ Eield codes [ ] smooth scrol

Comments

Figure 50: Choosing View options for Writer

Formatting Aids options

The display of symbols such as paragraph ends and tabs helps you when writing, editing, and
doing page layout. For example, you might want to know if any blank paragraphs or tabs are
included or if any tables or graphics are too wide and intrude into the margins of the page.
Selections here determine which symbols show when you select the Nonprinting Characters
button in the Standard Toolbar.

On the LibreOffice Writer — Formatting Aids page, select the required options.

Display of Direct cursor
Paragraph end [ ] Direct cursor
Custom hyphens Inzert
Spaces

() Paragraph alignment

Mon-breaking spaces () Left paragraph margin
Tabs () Tabs
Breaks () Tabs and spaces
[] Hidden text
] Fields: Hidden text Cursor in protected areas
[ | Fields: Hidden paragraphs Enable

Layout assistance

[ ] Math baseline alignment

Figure 51: Choosing Formatting Aids options
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Direct cursor lets you enter text, images, tables, frames, and other objects in any
blank area in your document. Writer inserts blank paragraphs and tabs to position the
Note text or objects.

This feature is incompatible with rigorous use of styles and can lead to many
formatting oddities, so it should be avoided by professional writers.

Grid options

Specifying shap to grid can be very helpful when you are trying to align several objects such as
graphics or tables.

On the LibreOffice Writer — Grid page, you can choose whether to enable this feature and what
grid intervals to use. If the grid intervals (subdivisions) are too large, you may find that you do not
have enough control in placing the objects.

Grid
[] 5nap to grid
[ ] visible grid
Resolution Subdivision
Horizontal:  |0.39° (= Horizontal: |2 = space(s)
Vertical: 0.39" = Vertical: 2 *| space(s)
[ ] synchronize axes

Figure 52: Choosing Grid options

Basic Fonts (Western) options

The default fonts specified on the LibreOffice Writer — Basic Fonts (Western) page (Figure 53)
apply to both Writer documents and HTML (Web) documents. They define the basic fonts for the
predefined templates. If you want to change the defaults, do so on this page. If you have Asian
language support enabled (see Figure 61 on page 67) there will be a page for Basic Fonts
(Asian) as well.

You can also modify specific templates (as described in Chapter 10) or choose other fonts for use
in specific documents, either by applying direct formatting or by defining and applying styles in
those templates and documents.

When choosing fonts on this page, you are not limited to single fonts or to the ones shown in the
drop-down list. You can specify a “font family” as a comma-separated set of fonts that includes
those suitable for Windows, Macintosh, Linux, and other operating systems. These choices are
particularly important in HTML documents.

If the document is viewed on a system that does not have the first font specified, it will use one of
the other fonts if that one is available. Otherwise, it will substitute a font that is available on the
system.

Type the list of fonts, separated by commas, in the boxes. If you want these defaults to apply to the
current document only, select that option. The Default button resets the values on this page to the
defaults installed with LibreOffice.

60 LibreOffice 4.2 Writer Guide



Basic fonts (Western)

Font Size
Default: Liberation Sans W 12 | »™
Heading: |Bitstream Vera Sans b 14 |W
List: Liberation Sans w12 W
Caption:  |Liberation Sans W 12 | »™
Index: Liberation Sans w 12 | »

[ ] current document only

Default

Figure 53: Choosing default fonts

Print options

On the LibreOffice Writer — Print page, you can choose which items are printed with the
document by default. These options are in addition to those on the LibreOffice — Print page
(Figure 37).

Contents Pages Comments
Pictures and objects Left pages (¥} None
Form controls Right pages ) Comments anly
Page background []Brochure {3 End of document
[ ] Print textin bladk () End of page
[ ] Hidden text
[ ] Text placehalder

Other

[ ] Print automatically inserted blank pages
|:| Paper tray from printer settings

Fax |[Mong] W

Figure 54: Choosing Print options for Writer

Some considerations:

* When you are working on drafts and you want to save printer ink or toner, you might want

to deselect some of the items in the Contents section.

* The Print text in black selection causes color text (but not graphics) to print as black on a

color printer; on a black-and-white printer, this option causes color text to print as solid
black instead of shades of gray (dithered).

¢ The Print text in black option has a different effect than the Convert colors to grayscale
option on the Options - LibreOffice — Print page (Figure 34), which prints all graphics as
grayscale on color printers. (On black-and-white printers, color in graphics normally prints

as grayscale.)
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* If you are printing double-sided on a non-duplexing printer, you might choose to print only
left or right pages, then turn the stack over and print the other pages.

Ti You can override any of these defaults when printing a document. Click File > Print,
P then use the options on the various pages of the Print dialog.

Table options
On the LibreOffice Writer — Table page, you can specify the default behavior of tables.

Default Input in tables
Heading Mumber recognition
Repeat on each page [ ] Mumber format recognition
[ ] Do not spiit [ ] alignment
Border
Keyboard handling
Maove cells Insert cell
Row: 0,20 = Fow: 0,20 =
Column: |0.20° | Column: |0.98° |

Behavior of rows/columns

) Fixed Changes affect the adjacent area only
) Fixed, proportional  Changes affect the entire table
() Yariable Changes affect the table size

Figure 55: Choosing default Table options

Some considerations:

¢ |f most of your tables will require borders or headings, select those options. If most of your
tables are used for page layout, deselect borders and headings.

* Number recognition can be very useful if most of your tables contain numerical data;
Writer will recognize dates or currency, for example, and format the numbers appropriately.
However, if you want the numbers to remain as ordinary text, this feature can be quite
irritating, so you will want to deselect it.

* The Keyboard handling section specifies the distances that cells move when you use
keyboard shortcuts to move them and the size of rows and columns inserted using
keyboard shortcuts.

* The choices in the Behavior of rows/columns section determine the effects that changes to
rows or columns have on adjacent rows or columns and the entire table. You might need to
test these selections to fully understand the effects.

Changes options

If you plan to use the change-tracking feature of Writer, use the LibreOffice Writer - Changes
page to choose the way inserted and deleted material is marked, whether and how attribute
changes are marked, and whether and how change bars are marked in the margins.
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Text display

Insertions

Atfributes:  |Underlined v I

Color: By author v Mt—
Deletions

Attributes:  [Strikethrough v

Colar: By author v —E 818 EE—
Changed attributes

Attributes:  Bold v _b

Color: By authar v I lttrl Ute S—

Lines changed

Mark: Left margin v -
Color: I Elack | — -

Figure 56: Choosing options for tracking changes

Compatibility options

Do you need to import Microsoft Word documents into LibreOffice Writer? If so, you might want to
select some or all of the settings on the LibreOffice Writer - Compatibility page (Figure 57). If
you are not sure about the effects of these settings, leave them as the defaults provided by
LibreOffice. For information about the settings not described below, see the Help. All settings
selected will apply to the current document.

Compatibility options for Untitled1

IJse printer metrics for document formatting

Add spacing between paragraphs and tables (in current document)

Add paragraph and table spacing at tops of pages (in current document)
IUse QpenOffice.org 1.1 tabstop formatting

Do not add leading (extra space) between lines of text

IIse OpenOffice.org 1.1 line spacing

Add paragraph and table spadng at bottom of table cells

IUse OpenOffice.org 1.1 object positioning

IIse OpenOffice.org 1. 1 text wrapping around objects

Consider wrapping style when positioning objects

Expand word space on lines with manual line breaks in justified paragraphs

EITTI=T T T I=]=]

IUse as Default

Figure 57: Choosing compatibility options

Use printer metrics for document formatting
If this option is selected, the printer specified for the document determines how the document is
formatted for viewing on screen. The line breaks and paragraph breaks you see on screen
match those that apply when the document is printed on that printer.

This setting can be useful when several people are reviewing a document that will eventually
be printed on a specific printer or when the document is exported to PDF (a process that uses
“Adobe PDF” as the printer).

Chapter 2 Setting up Writer 63



If this option is not selected, a printer-independent layout will be used for screen display and
printing.

Add spacing between paragraphs and tables (in current document)
In LibreOffice Writer, paragraph spacing is defined differently than it is in MS Word documents.
If you have defined spacing between two paragraphs or tables, spacing is also added in the
corresponding MS Word documents.

If this option is selected, Microsoft Word-compatible spacing is added between paragraphs and
tables in LibreOffice Writer documents.

Add paragraph and table spacing at tops of pages (in current document)
You can define paragraphs to have space appear before (above) them. If this option is
selected, any space above a paragraph will also appear if the paragraph is at the beginning of
a page or column, if the paragraph is positioned on the first page of the document, or after a
manual page break.

If you import a Microsoft Word document, the spaces are automatically added during the
conversion.

Add paragraph and table spacing at bottom of table cells
Specifies that the bottom spacing is added to a paragraph, even when it is the last paragraph in
a table cell.

Use as Default
Click this button to use the current settings on this page as the default in LibreOffice.

AutoCaption options

Do you want LibreOffice to automatically insert captions for tables, pictures, frames, and OLE
objects that have been inserted in a Writer document?

You may not always want captions for every table, for example, if you use tables for
Note layout as well as for tables of data. You can always add captions to individual tables,
graphics, or other objects (right-click > Caption).

If you do want automatic captions on one or more object types, use the options on the LibreOffice
Writer > AutoCaption page. Enable the check box next to an object you want to be automatically
captioned (LibreOffice Writer Picture in the example shown).With the item highlighted, specify
the characteristics of the caption.

The supplied categories for captions are Drawing, lllustration, Table, and Text. However, you are
not limited to the supplied categories. If you want to use another name (for example, Figure) for
the caption label, type the required term in the box. In the example shown, Figure has been added
to the list.

Additional information about numbering captions by chapter, character styles, frame styles, and
other items on the AutoCaption page, is given in later chapters in the Writer Guide.
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Add captions automatically Caption
when inserting:

— Category Figure W
|| LibreOffice Writer Table -
|| LibreQffice Writer Frame Numbering Arabic (12 3) w
|| LibreOffice Writer Picture :
| _|Other OLE Objects dumbering seraratn
|| Other OLE Objects S
|| Other OLE Objects
| Other OLE Objects L2l Gl
|| Other OLE Objects Positi el
|_|Further obijects osthon —
Caption order Numbering captions by chapter
Category first | Level 1 |
Separator
Figure 1:
Category and frame format
Character style Mone |

[ ] apply border and shadow

Figure 58: Setting up a new category for automatic captions on graphics

Mail Merge E-mail options

You can produce form letters using Writer and then use the mail merge function to personalize
those letters and send them to a number of addresses taken from a data source, such as an
address book. Mail merged documents can be printed and mailed, or sent by e-mail. (See Chapter
11, Using Mail Merge, for details.)

Use the LibreOffice Writer - Mail Merge E-mail page to set up the user and server information
for sending form letters by e-mail. If you are not sure what information to put in any of the fields,
consult your e-mail program or your Internet service provider.

User information

Your name:

E-Mail address:
[ ] send replies to different e-mail address

milw addr

m

55,

el

Dutgoing server (SMTP) Settings

4

Server name: Port: |25

[] Use secure connection {S5L)

l Server Authentication ]

Test Settings. ..

Figure 59: Specifying settings for use when e-mailing mail-merged form letters
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Choosing options for HTML documents

You can configure LibreOffice to treat HTML documents in Writer differently than regular
documents.

1) If the Options dialog is not already open, click Tools > Options.
2) Click the expansion symbol (+ sign or triangle) by LibreOffice Writer/Web on the left-hand
side of the Options dialog. A list of pages drops down.

Here you can customize settings related to printing, formatting aids, view options, table defaults,
the grid, and a default background for HTML documents you're working with in Writer.

The pages for View, Formatting Aids, Grid, Print, and Table are similar to the pages described
above under LibreOffice Writer, but are for Writer/Web HTML pages instead.

The Background page allows you to specify the default background color for documents in
Writer/Web. The background is valid for both new HTML documents and for those that you load, as
long as these have not defined their own background.

Choosing language settings

You may need to do several things to set the language settings to what you want:
¢ Install the required dictionaries
¢ Change some locale and language settings
* Choose spelling options

Install the required dictionaries

LibreOffice automatically installs several dictionaries with the program. To add other dictionaries,
be sure you are connected to the Internet, and then use Tools > Language > More Dictionaries
Online. LibreOffice will open your default web browser to a page containing links to additional
dictionaries that you can install. Follow the prompts to select and install the ones you want.

Change some locale and language settings

You can change some details of the locale and language settings that LibreOffice uses for all
documents or for specific documents.

In the Options dialog, choose Language Settings > Languages. Click the expansion symbol (+
sign or triangle). The exact list shown depends on the Enhanced language support settings (see
Figure 61).

# LibreOffice
* Lload/Save
% LibreOffice = Lanauage Settings:
* LloadfSave i Languages
=l language Settings Writing Aids
Languages Searching in Japanese
Writing Aids Asian Layout
English sentence checking English sentence checking
+  LibreOffice Writer + LibreOffice Writer
+ - LibreOffice Writer fWeb + - LibreQffice Writer Web
+ LibreOffice Base +  LibreCffice Base
+ Charts + Charts
+ Internet + - Internet

Figure 60: LibreOffice language options, with Asian language
options enabled on the right side
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On the right-hand side of the Language Settings — Languages page (Figure 61), change the
User interface, Locale setting, Default currency, and the settings under Default languages for
documents as required. In the example, English (USA) has been chosen for all the appropriate
settings.

If you want the language setting to apply to the current document only, instead of being the default
for all new documents, select For the current document only.

If necessary, select the options to enable support for Asian languages (Chinese, Japanese,
Korean) and support for CTL (complex text layout) languages such as Hindi, Thai, Hebrew, and
Arabic. If you choose either of these options, the next time you open the Options dialog, you will
see some extra pages under Language Settings, as shown in the right side of Figure 60. These
pages (Searching in Japanese, Asian Layout, and Complex Text Layout) are not discussed here.

Language of
User interface Default - English (USA) w
Locale setting English {USA) v
Decdmal separator key Same as locale setting . )
Default currency 1JSD & English (USA) W
Date acceptance patterns Mo ;MO

Default languages for documents
Western “& English (USA) w

|:| Asian

[ ] complex text layout (CTL)

L]
1

e Eais L SiTIE

[
m

[ ] For the current document anly

Enhanced language support
|:| Ignore system input language

Figure 61: Choosing language options

Choose spelling options

To choose the options for checking spelling, choose Language Settings > Writing Aids. In the
Options section of the page, choose the settings that are useful for you.

Some considerations:

¢ |f you do not want spelling checked while you type, deselect Check spelling as you type.
This option can also be deselected using the AutoSpellcheck button on the Standard
Toolbar.

¢ |If you want grammar to be checked as you type, you must have Check spelling as you
type enabled too.

* If you use a custom dictionary that includes words in all uppercase and words with
numbers (for example, AS/400), select Check uppercase words and Check words with
numbers.

* Check special regions includes headers, footers, frames, and tables when checking
spelling.

Here you can also check which of the user-defined (custom) dictionaries are active, or you can add
or remove user installed dictionaries by clicking the New or Delete buttons. Dictionaries installed
by the system cannot be deleted.
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Writing aids

Available language modules

z Hunspell SpelCheder ” Edit
v | Lightproof grammar checker (English] — =
|| ibhvohen Hyphenator s

Liser-defined dictionaries

|+ | standard [All] N
| technical [AI] tew. .
| _|en-GB '[ English {UK) T

|_|en-US 'T English (Usa) T Edit...
|+ | IgnoreallList [All]

Delete

Check spelling as you type s =
Chedk grammar as you type =)
Check uppercase words
Chedk words with numbers
Check spedial regions

Get more dictionaries online. ..

Figure 62: Choosing languages, dictionaries, and options for checking spelling

English sentence checking

On the Language Settings > English sentence checking page, you can choose which items are
checked for, reported to you, or converted automatically. This menu is also found in the English
dictionaries extension installed by default by LibreOffice. Select Tools > Extension Manager,
select the English spelling dictionaries and click the Options button to reveal the menu. Select
which of the optional features you wish to check.

After selecting the additional grammar checks, you must restart LibreOffice, or reload the
document, for them to take effect.

Grammar checking
Possible mistakes Capitalization Word duplication Parentheses

Punctuation

» Word spacing Em dash Quotation marks (¥ Multiplication sign

Sentence spacing En dash Apostrophe Ellipsis
More spaces Minus sign

Others
Convert to metric (°C, km/h, m, kg, I) Thousand separation of large numbers
Convert to non-metric (°F, mph, ft, Ib, gal)

Figure 63: Choosing options for checking sentences in English

Grammar checking

Possible mistakes
Checks for things such as; with it's, he don't, this things and so on.

Capitalization
Checks for the capitalization of sentences. The sentence boundary detection depends on
abbreviations.
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Word duplication
Checks for all word duplication, increased from the default number of words checked.

Parentheses
Checks for pairs of parentheses and quotation marks.

Punctuation

Word spacing
This option is selected by default. It checks for single spaces between words, indicating
instances of double or triple spaces, but not of more than that.

Sentence spacing
Checks for single spacing between sentences, indicating when one or two extra spaces are
found.

More spaces
Checks word and sentence spacing for more than two extra spaces.

Em dash; En dash
These options force a non-spaced em dash to replace a spaced en dash, or force a spaced en
dash to replace a non-spaced em dash, respectively.

Quotation marks
Checks for correct typographical double quotation marks.

Multiplication sign
This option is selected by default. It replaces an 'x' used as a multiplication symbol with the
correct typographical symbol.

Apostrophe
Replaces an apostrophe with the correct typographical character.

Ellipsis
Replaces three consecutive periods (full stops) with the correct typographical symbol.

Minus sign
Replaces a hyphen with the correct minus typographical character.

Others

Convert to metric; Convert to non-metric
Converts guantities in a given unit to quantities in the other type of unit: metric to imperial or
imperial to metric.

Thousands separation of large numbers
Converts a number with five or more significant digits to a common format, that is one which
uses the comma as a thousands separator, or to the ISO format which uses a narrow space as
a separator.
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Controlling Writer’s AutoCorrect functions

Some people find some or all of the items in Writer's AutoCorrect feature annoying because Writer
changes what you type when you do not want it changed. Many people find some of the
AutoCorrect functions quite helpful; if you do, then select the relevant options. But if you find
unexplained changes appearing in your document, this is a good place to look to find the cause.

To open the AutoCorrect dialog, choose Tools > AutoCorrect Options. (You need to have a
document open for this menu item to appear.) In Writer, this dialog has five tabs. Many of the
options are described in Chapter 3, Working with Text, in this book.

o =
| -
AutoCorrect
Replacements and exceptions for language: |Eng|ish (UsA) [V]
EEE hfxcepﬁuns Options |Localized Options | Ward Completion
Replace With: Text only
- - Mew
applicaiton application [A
applicaitons applications
applyed applied Delete
appointiment appointment [ =
Att- at the
—ngince SR -
| | audizmes andiarirs lvl |
QK l ’ Cancel ] I Help ] I Reset l

Figure 64: The AutoCorrect dialog in Writer

70

LibreOffice 4.2 Writer Guide



j LibreOffice

The Document Foundation

Chapter 3
Working with Text



Introduction

This chapter covers the basics of working with text in Writer, the word-processing component of
LibreOffice. It assumes that you are familiar with the use of a mouse and keyboard and that you
have read about Writer's menus and toolbars and other topics covered in Chapter 1, Introducing
Writer.

We recommend that you also follow the suggestions in Chapter 2, Setting up Writer, about
displaying formatting aids, such as end-of-paragraph marks, and selecting other setup options.

When you have read this chapter, you should know how to:
e Select, cut, copy, paste, and move text
* Find and replace text
* Insert special characters
* Format paragraphs and characters
* Create numbered or bulleted lists
* Check spelling and grammar, use the thesaurus, and choose hyphenation options
* Use the autocorrection, word completion, autotext, and line numbering features
* Track changes, undo and redo changes, and insert comments
* Link to other parts of a document

Selecting text

Before you can do anything with text, you need to select it. Selecting text in Writer is similar to
selecting text in other applications.

In addition to selecting blocks of text, you can select items that are not consecutive, and columns
(vertical blocks) of text.

Selecting items that are not consecutive

To select nonconsecutive items (as shown in Figure 65) using the mouse:
1) Select the first piece of text.
2) Hold down the Ctrl key and use the mouse to select the next piece of text.
3) Repeat as often as needed.

Now you can work with the selected text (copy it, delete it, change the style, and so on).

To select nonconsecutive items using the keyboard:

1) Select the first piece of text. (For more information about keyboard selection of text, see the
topic “Navigating and Selecting with the Keyboard” in the LibreOffice Help (F1).)

2) Press Shift+F8. This puts Writer in “Adding selection” mode.

3) Use the arrow keys to move to the start of the next piece of text to be selected. Hold down
the Shift key and select the next piece of text.

4) Repeat as often as required.
Now you can work with the selected text.
Press Esc to exit from this mode.
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Around the World in 80 Days - Jules Verne

overspread Passepartout's round face; clearly he had not comprehended his
master.

'Monsieur is going to leave home?"

"Yes," returned Phileas Fogg. "We are goinground the world."

Passepartout ppened wide his eyes, raised his eyebrows, held up his hands, and seemed about
to collapse, so overcome was he with stupefied astonishment.

"Round the world!l' he murmured.

"In eighty days," responded [Mr/Fogg. "So we haven't a moment to lose."
"But the trunks?" gasped Passepartout, unconsciously swaying his head from right to left.

"We'll have no trunks; only a carpet—bag, with two shirts and three pairs of stockings for me)
and the same for you] We'll buy our clothes on the way. Bring down my mackintosh and
traveling—cloal, and some stout shoes, though we shall do little walking. Make haste!"

Figure 65: Selecting items that are not next to each other

Selecting a vertical block of text

You can select a vertical block or “column” of text that is separated by spaces or tabs (as you might
see in text pasted from e-mails, program listings, or other sources), using LibreOffice’s block
selection mode. To change to block selection mode, use Edit > Selection Mode > Block Area, or
press Ctrl+F8, or click on the Selection icon in the status bar and select Block selection from the
list.

— Standard selection
Selection icon

Extending selection

Adding selection
# [Block selection
English (USA) m | [5]| |

Now you can highlight the selection, using mouse or keyboard, as shown in Figure 66.

January March
April June

Tuly September
October Novembery December

Figure 66: Selecting a vertical block of text

Cutting, copying, and pasting text

Cutting and copying text in Writer is similar to cutting and copying text in other applications. You
can copy or move text within a document, or between documents, by dragging or by using menu
selections, icons, or keyboard shortcuts. You can also copy text from other sources such as Web
pages and paste it into a Writer document.

To move (drag and drop) selected text using the mouse, drag it to the new location and release it.
To copy selected text, hold down the Ctrl key while dragging. The text retains the formatting it had
before dragging.

To move (cut and paste) selected text, use Ctrl+X to cut the text, insert the cursor at the paste-in
point and use Ctr/+V to paste. Alternatively, use the buttons on the Standard toolbar.
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When you paste text, the result depends on the source of the text and how you paste it. If you click
on the Paste button, then the pasted text keeps its original formatting (such as bold or italics). Text
pasted from Web sites and other sources may also be placed into frames or tables. If you do not
like the results, click the Undo button or press Ctrl+Z.

To make the pasted text take on the formatting of the surrounding text:
* Choose Edit > Paste Special, or
* Click the arrow on the combination Paste button, or
* Click the Paste button without releasing the left mouse button.
Then select Unformatted text from the resulting menu.

The range of choices on the Paste Special menu varies depending on the origin and formatting of
the text (or other object) to be pasted. See Figure 67 for an example with text on the clipboard.

-~

Paste Special

Source:  LibreQffice 4.2 Text Document

Selection
LibreQffice Writer
Formatted text [RTF]
HTML (HyperText Markup Language)
Unformatted text —

Figure 67: Paste Special menu

Finding and replacing text and formatting

Writer has two ways to find text within a document: the Find toolbar for fast searching and the Find
& Replace dialog. In the dialog, you can:

* Find and replace words and phrases

* Use wildcards and regular expressions to fine-tune a search
* Find and replace specific attributes or formatting

* Find and replace paragraph styles

Using the Find toolbar

If the Find toolbar is not visible, you can display it by choosing View > Toolbars > Find from the
Menu bar or by pressing Ctrl+F. The Find toolbar is shown docked at the bottom of the LibreOffice
window (just above the Status Bar) in Figure 68, but you can float it or dock it in another location.
For more information on floating and docking toolbars, see Chapter 1, Introducing Writer.

Using the Find toolbar

If the Find toolbar is not visible,
menu bar or by pressing Cirf+F.

38 |Find V Find Al DMab:hCase Q

Page 7 /45 12073 words, 69633 characters Q0oPagestyle

Figure 68: Docked position of Find toolbar
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To use the Find toolbar, click in the text input box and type your search text, then press Enter to
find the next occurrence of that term from the current cursor position. Click the Find Next or Find
Previous buttons as needed.

Click the Find All button to select all instances of the search term within the document. Select
Match Case to find only the instances that exactly match the search term. Click the button next to

Match Case (€% ) to open the Find & Replace dialog and still keep the Find toolbar open.

The Find toolbar can be closed by clicking the red X button on the left, or by pressing Esc on the
keyboard when the text cursor is in the search box. Ctrl+F toggles the Find toolbar off and on.

Using the Find & Replace dialog

To display the Find & Replace dialog, use the keyboard shortcut Ctrl+H, or choose Edit > Find &
Replace from the Menu bar, or click the Find and Replace button ( & ) on the Find toolbar. Once

opened, optionally click the Other Options symbol to expand the dialog (see Figure 69). Click the
button again to reduce the dialog options.

e =
Find & Replace
Search for
|
icon |
Find Al
Replace with
|
button| E4
Replace All
Match case Whole words only
=l Other Options
Current selection only [ ] Backwards
[ ] Regular expressions [ ] search for Paragraph Styles
[ ] similarity search [ ] comments
I Help l I Close

Figure 69: Expanded Find & Replace dialog

To use the Find & Replace dialog:
1) Type the text you want to find in the Search for box.
2) To replace the text with different text, type the new text in the Replace with box.
3) You can select various options, such as matching the case or matching whole words only.

Among the Other Options, choices include searching only in selected text, searching from
the current cursor position backwards toward the beginning of the file, or searching for
similar words.
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* Select Similarity search and click the button to the right to open a dialog in which
you can modify the text search by length and number of characters different from
the search term (see Figure 70).
* Select Combine to combine settings to modify the search.
* Select Comments to enables searching in comments text.
See the following sections for some other options choices.
4) When you have set up your search, click Find. As the document view moves to each found
instance, replace the text by clicking Replace.

Search for
crucible Rl
Find All
Alignment
.

R¢ Similarity Search

Settings

<]
e _lE ]

il
-~

Exchange characters |2

Add characters 2 Cancel

[] Remove characters 2 =5 Help

QT Oy [ Dackmwaras

esions Induding Styles

Similarity search | % [] comments

Regular expr

Figure 70: Similarity search dialog

If you click Find All, Writer selects all instances of the search text in the document.

Tip Similarly, if you click Replace All, Writer replaces all matches.
Caution Use Replace All with caution; otherwise, you may end up with some highly
embarrassing (and hilarious) mistakes. A mistake with Replace All might require a
manual, word-by-word, search to fix.

Finding and replacing specific attributes and formatting

A very powerful use of Find & Replace takes advantage of the Attributes and Format options. For
example, you might want to replace underlined words with italics.

To find document attributes:

1) Onthe Find & Replace dialog (with Other Options displayed, as in Figure 69), click the
Attributes button.
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2)

3)

Select the attribute you wish to search for from the list in the Attributes dialog and click OK.
The names of the selected attributes appear under the Search for box. For example, to
search for text that has been changed from the default font color, select the Font Color
attribute.

Click Find to search the document.

To find specific formatting, open the Find & Replace dialog (with Other Options displayed, as in
Figure 69):

1)
2)

3)

4)

5)

To search for text with specific formatting, enter the text in the Search for box. To search for
specific formatting only, delete any text in the Search for box.

Click Format to display the Text Format (Search) dialog. The tabs on this dialog are similar
to those on the Paragraph and Paragraph Style dialogs.

Choose the formats you want to search for and then click OK. The names of the selected
formats appear under the Search for box. For example, you might search for all text in 14-
point bold Times New Roman. The option Search for Paragraph Styles, changes to
Including Styles.

Search for

W

| bold, Times New Roman, 14pt I

To replace the format, click in the Replace with text box, choose the format to use, and
then click OK. The format selected will be displayed below this text box. To replace text as
well as formatting, type the replacement text in the Replace with box.

Replace with
:

Replace Al

Liberation 5ans, 12pt, Mot Italic, normal

To search for specific text with specific formatting (for example, the word hello in bold),
specify the formatting, type the text in the Search for box and leave the Replace with box
blank.

To remove specific character formatting, click Format, select the Font tab, then select the
opposite format (for example, No Bold). The No Format button on the Find & Replace
dialog clears all previously selected formats.

Click Find, Find All, Replace, or Replace All.

Unless you plan to search for other text using those same attributes, click No
Format to remove the attributes after completing your search. If you forget to do
this, you may wonder why your next search fails to find words you know are in the
document.

Tip

Chapter 3 Working with Text 77



Finding and replacing paragraph styles

If you combine material from several sources, you may discover that lots of unwanted paragraph
styles have suddenly shown up in your document. To quickly change all the paragraphs from one
(unwanted) style to another (preferred) style:
1) On the expanded Find & Replace dialog (Figure 69), select Search for Paragraph Styles.
(If you have attributes specified, this option is labeled Including Styles. Select No Format to
remove any attributes and return the option to Search for Paragraph Styles.) The Search
for and Replace with boxes now contain a list of styles in use in the document.
2) Select the styles you want to search for and replace.

3) Click Find, Find All, Replace, or Replace All.
Repeat steps 2 and 3 for each style that you want to replace.

Finding and replacing special characters

To enter special characters into the Search for and Replace with text input boxes, select the text
box and press Ctrl+Shift+S. Select the required character from the Special Characters dialog and
click OK. This version of the Special Characters dialog only permits a single character to be
selected and does not allow the font family to be selected.

Using wildcards and regular expressions

Most users will be familiar with the concept of a wildcard—a special character that represents one
or more unspecified characters. Wildcards make text searches more powerful but often less
specific. LibreOffice enables you to use combinations of characters known as regular expressions
which are more specific than simple wildcards but less so than a literal string. Regular expressions
are very powerful but not very intuitive. They can save time and effort by combining multiple finds
into one.

Table 4 shows a few of the regular expressions used by LibreOffice.

Tip The online help describes many more regular expressions and their uses.

To use wildcards and regular expressions when searching and replacing:
1) On the Find & Replace dialog, click Other Options to see more choices. On this expanded
dialog (Figure 69), select the Regular expressions option.
2) Type the search text, including the wildcards, in the Search for box and the replacement

text (if any) in the Replace with box. Not all regular expressions work as replacement
characters; the line break (\n) is one that does work.

3) Click Find, Find All, Replace, or Replace All (not recommended).

To search for a character that is defined as a wildcard, type a backslash (\) before
Note the character to indicate that you are using it literally. For example, to find the text
$5.00, you would conduct a search using \$5\ . 00.
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Table 4: Examples of search wildcards (regular expressions)

To find e th's. Examples and comments
expression
Any single character . (a period or b.d finds bad, bud, bid, and bed.
full stop)
One of the specified [xyz] b[liu]n finds bin and bun.
characters
Any single character in [X-y] [r-tleed finds reed, seed, and teed; ranges must be in
this range alphabetically ascending order.
Any single character [~X] p[~a]st finds post and pest, but not past.
except the characters
inside the brackets
The beginning of a word \<start \<log finds logbook and logistics, but not catalog.
The end of a word end\> log\> finds catalog, but not logistics.
A paragraph marker $ Does not work as a replacement character. Use \n
instead.
Aline break \n Finds a line break that was inserted with Shift+Enter.

When used as a replacement character, it inserts a
paragraph marker.

Inserting special characters

A special character is one not found on a standard English keyboard. For example, © % & ¢ L i 0
@ ¢ are all special characters. To insert a special character:

1) Place the cursor in your document where you want the character to appear.
2) Click Insert > Special Character to open the Special Characters dialog (Figure 71).

3) Select the characters (from any font or mixture of fonts) you wish to insert, in order; then
click OK. The selected characters are shown in the lower left of the dialog. As you select
each character, it is shown on the right, along with the numerical code for that character.

Tip

Different fonts include different special characters. If you do not find a particular
special character you want, try changing the Font selection.

Inserting non-breaking spaces and hyphens

Non-breaking spaces

To prevent two words from being separated at the end of a line, press Ctrl+Shift when you type
the space between the two words.

Non-breaking hyphen

You can use a non-breaking hyphen in cases where you do not want the hyphen to appear at
the end of a line, for example in a number such as 123-4567. To insert a non-breaking hyphen,
press Shift+Ctrl+minus sign.

These are also available through Insert > Formatting Mark.
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Figure 71: The Special Characters dialog, where you can insert special characters

Inserting en and em dashes

To enter en and em dashes, you can choose the Replace dashes option under Tools >
AutoCorrect Options (Figure 83 on page 87). This option replaces two hyphens, under certain
conditions, with the corresponding dash.

In Table 5, the A and B represent text consisting of letters A to z or digits 0 to 9.

Table 5: Inserting dashes

Text that you type Result

A - B (A, space, hyphen, space, B) A—B (A, space, en dash, space, B)
A -- B (A, space, hyphen, hyphen, space, B) A—B (A, space, en dash, space, B)
A--B (A, hyphen, hyphen, B) A—B (A, em dash, B)

A-B (A, hyphen, B) A-B (unchanged)

A -B (A, space, hyphen, B) A -B (unchanged)

A --B (A, space, hyphen, hyphen, B) A-B (A, space, en dash, B)

Another means of inserting en or em dashes is through the Insert > Special Characters menu.
Select the U+2013 or U+2014 character (found in the General punctuation subset), respectively.

A third method uses keyboard shortcuts. These shortcuts vary depending on your operating
system, as described on the next page.
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You can also record macros to insert en and em dashes and assign those macros to
Tip unused key combinations, for example Ctrl+Shift+N and Ctrl+Shift+M. For more
information, see Chapter 17, Customizing Writer.

Windows
On most non-Asian installations of Windows, hold down one of the Alt keys and type on the
numeric keypad: 0150 for an en dash or 0151 for an em dash. The dash appears when you
release the Alt key.

On a keyboard with no numeric keypad, use a Fn (Function) key combination to
type the numbers. (The Fn key is usually to the right of the left-hand Ctrl key on
Tip the keyboard.)

For example, on a US keyboard layout, the combination for an en dash should be
Alt+Fn+mjim and for an em dash it should be Alt+Fn+mjij.

Linux
Hold down the Compose key and type two hyphens and a period for an en dash, or three
hyphens for an em dash. The dash appears when you release the Compose key.

The key that operates as a Compose key varies with the Linux distribution. It is
Tip usually one of the Alt or Win keys, but may be another key, and should be user-
selectable.

Mac OS X
Hold down the Option (Alt) key and type a hyphen for an en dash. For an em dash, the
combination is Shift+Option+Hyphen.

Formatting paragraphs

You can apply many formats to paragraphs using the buttons on the Formatting toolbar. Figure 72
shows the Formatting toolbar as a floating toolbar, customized to show only the buttons for
paragraph formatting. If you have Asian or Complex Text Layout language support enabled, two
additional buttons are available: Left-to-Right and Right-to-Left. The appearance of the icons may
vary with your operating system and the selection of icon size and style in Tools > Options >
LibreOffice > View.

The use of paragraph styles is highly recommended as an alternative to manually
Tip formatting paragraphs, especially for long or standardized documents. For
information on styles and how to use them, see Chapters 6 and 7 in this book.

Manual formatting (also called direct formatting) overrides styles, and you cannot
get rid of the manual formatting by applying a style to it.

A To remove manual formatting, select the text, right-click, and choose Clear Direct
Formatting from the context menu. Alternatively, use Ctrl+M.

Caution
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1 2 3 4 5 B 7 8 9% 101 1213 14

1 Open Styles and 5 Align Right 10 Numbering On/Off
Formatting Window 6 Justified 11 Bullets On/Off

2 Apply Style 7 Line Spacing: 1
3 Align Left 8 Line Spacing: 1.5
4 Centered 9 Line Spacing: 2

12 Decrease Indent
13 Increase Indent
14 Paragraph format dialog

Figure 72: Formatting toolbar, showing icons for paragraph formatting

Formatting can also be carried out using the Sidebar (View > Sidebar). The Sidebar opens with
the Properties deck selected by default. Click the Panel Open (+) button to open the panels if

necessary.

The Paragraph panel contains most of the controls that are described above for the Formatting
toolbar. Figure 73 shows the Paragraph panel on the Properties deck containing those formatting
controls. Clicking the down-arrow of a composite button opens the control for further choices, such
as fixed line spacing, or color palette. The Line Spacing submenu is shown in Figure 74.

Click the More Options button to open the Paragraph Style dialog.

Properties X
# Character L]
=l Paragraph 19 [
1 2 3 4
B
)
5~ -6 S -
Spacing: Indent:
0 11
8= =9 212
= 0.00" 13 (2] "% oo =
= 000" 14 (2] £ 0.0 $
1=~ 18 = 0.00" -
1 Align Left 8 Increase Spacing
2 Align Center 9 Decrease Spacing
3 Align Right 10 Increase Indent

4 Align Justified 11 Decrease Indent

5 Bullets composite button
6 Numbering composite

12 Hanging Indent
13 Above Paragraph

button Spacing
7 Paragraph Background 14 Below Paragraph Spacing
Color

A

L) ﬂ.

Lt

15
16
17

15 Indent From Left

16 Indent From Right

17 Indent First Line

18 Line Spacing composite
button

19 More Options button —
opens Paragraph dialog

Figure 73: Paragraph panel of the Properties deck in the Sidebar
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Single Rl
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Figure 74: Line spacing submenu

Figure 75 shows examples of the alignment options applied to text.

Left aligned text.
Center aligned text.
Right aligned text.
Justified text inserts spacing between words to force the text to reach
from margin to margin.

Figure 75: Text alignment options

When using justified text, the last line is by default aligned to the left. However, you can also align
the last line to the center of the paragraph area or justify it so that spaces are inserted between the
words in order to fill the whole line. If you select the Expand single word option, then whenever
the last line of a justified paragraph consists of a single word, this word is stretched by inserting
spaces between characters so that it occupies the full length of the line. Figure 76 shows an
example of the effect obtained when setting each of these options.

Three options are available for the alignment of the last line of a justified paragraph.
This is an example of a left-aligned last line.

Three options are available for the alignment of the last line of a justified paragraph.
This is an example of a centered last line.

Three options are available for the alignment of the last line of a justified paragraph.
This is an example of a justified last line.

When the last line of a justified paragraph contains a single word, you can stretch this

word to fill the entire line. This is an example with the Expand single word option
s e 1 e C t e

Figure 76: Four choices for the last line of a justified paragraph

These options are controlled in the Alignment page of the Paragraph dialog, reached by choosing
Format > Paragraph from the Menu bar, or by right-clicking in the paragraph and selecting
Paragraph from the context menu, or by clicking the More Options button on the Paragraph panel
in the Properties deck of the Sidebar.
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Text-to-text
Alignment; Automatic v

Figure 77: Options for the last line of a justified paragraph

Setting tab stops and indents

The horizontal ruler shows the tab stops. Any tab stops that you have defined will overwrite the
default tab stops. Tab settings affect indentation of full paragraphs (using the Increase Indent and
Decrease Indent buttons on the Formatting toolbar) as well as indentation of parts of a paragraph
(by pressing the Tab key on the keyboard).

Using the default tab spacing can cause formatting problems if you share documents with other
people. If you use the default tab spacing and then send the document to someone else who has
chosen a different default tab spacing, tabbed material will change to use the other person’s
settings. Instead of using the defaults, define your own tab settings, as described in this section.

To define indents and tab settings for one or more selected paragraphs, double-click on a part of
the ruler that is not between the left and right indent icons to open the Indents & Spacing page of
the Paragraph dialog. Double-click anywhere between the left and right indent icons on the ruler to
open the Tabs page of the Paragraph dialog.

L Ty
Paragraph
Indents & Spacing Alignment Text Flow
Cutline & Mumbering Tabs Drop Caps Borders Background
Position Type Fill character )

4.007 ® Left L ® None —
1.507 O Right - [P

3I|:":|F O CE_I-ItErEIj L O — DE'EtE Q"
.00 () Decimal X [ &)

Delete
Character {:} Character

Figure 78: Specifying tab stops and fill characters

A better strategy is to define tabs for the paragraph style. Refer to Chapters 6 and 7 for more about
paragraph styles.
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Using tabs to space out material on a page is not recommended. Depending on

Tip what you are trying to accomplish, a table is usually a better choice.

Changing the default tab stop interval

Any changes to the default tab setting will affect the existing default tab stops in
Note any document you open afterward, as well as tab stops you insert after making the
change.

To set the measurement unit and the spacing of default tab stop intervals, go to Tools > Options >
LibreOffice Writer > General.

Settings
Measurement unit inch W
Tab stops 0.50" >

Figure 79: Selecting a default tab stop interval

You can also set or change the measurement unit for rulers in the current document by right-
clicking on the ruler to open a list of units, as shown in Figure 80 for the horizontal ruler. Click on
one of them to change the ruler to that unit. The selected setting applies only to that ruler.

%

[ =]

Millimeter
v |Centimeter
Inch
Paoint
Pica
Char

Figure 80: Changing the measurement unit for a ruler

Formatting characters

You can apply many formats to characters using the buttons on the Formatting toolbar, or those in
the Characters panel of the Properties deck of the Sidebar. Figure 81 shows the Formatting toolbar
customized to show only the buttons for character formatting. Figure 82 Shows the Character
panel in the Properties deck of the Sidebar. Clicking the down-arrow of a composite button opens
the control for further choices, such as line styles or color palette. The appearance of the buttons
may vary with your operating system and the selection of icon size and style in Tools > Options >
LibreOffice > View.

It is highly recommended that you use character styles rather than manually formatting characters.
For information on styles and how to use them, see Chapters 6 and 7.

To remove manual formatting, select the text and choose Format > Clear Direct
Tip Formatting from the Menu bar, or right-click and choose Clear Direct Formatting
from the context menu, or use Ctrl+M from the keyboard.
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Window 7 Underline 13 Highlighting composite button
2 Apply Style 8 Superscript 14 Background Color composite button
3 Font Name 9 Subscript 15 Open Character Format Dialog
4 Font Size 10 Increase Font
5 Bold 11 Reduce Font

Figure 81: Formatting toolbar, showing buttons for character formatting

Properties x =
= 15
=l Character 1 2 L] F.
Liberation Sans ] (12 el
3 4 5 6 7 8 9 &
AAA-&A
i
@- s- & - ,,
10 11 12 13 14 o
[+ Paragraph |
* Page =
1 Font name 6 Strikethrough 11 Highlight — composite
button
2 Font size 7 Shadow 12 Character Spacing
composite button
3 Bold 8 Increase Font 13 Superscript
4 ltalic 9 Reduce Font 14 Subscript
5 Underline composite 10 Font Color composite 15 More Options — opens
button button Character dialog

Figure 82: Character panel in the Properties deck of the Sidebar

Autoformatting

You can set Writer to automatically format parts of a document according to the choices made on
the Options page of the AutoCorrect dialog (Tools > AutoCorrect Options).

The Help describes each of these choices and how to activate the autoformats. Some common
unwanted or unexpected formatting changes include:

* Horizontal lines. If you type three or more hyphens (- --), underscores (_ _ _) or equal
signs (===) on a line and then press Enter the paragraph is replaced by a horizontal line as
wide as the page. The line is actually the lower border of the preceding paragraph.

* Bulleted and numbered lists. A bulleted list is created when you type a hyphen (-), asterisk
(*), or plus sign (+), followed by a space or tab at the beginning of a paragraph. A
numbered list is created when you type a number followed by a period (.), followed by a
space or tab at the beginning of a paragraph. Automatic numbering is only applied to
paragraphs formatted with the Default, Text body or Text body indent paragraph styles.
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Figure 83: Autoformat choices on the Options page of the AutoCorrect dialog

If you notice unexpected formatting changes occurring in your document, this is the

Tip first place to look for the cause.

To automatically format the file according to the options you have set, choose Format >
AutoCorrect and select or deselect the items on the submenu.

While Typing
Automatically formats the document while you type.

Apply
Automatically formats the document.

Apply and Edit Changes
Automatically formats the file and then opens a dialog where you can accept or reject the
changes.

AutoCorrect Options
Opens the AutoCorrect dialog (Figure 83).
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Creating numbered or bulleted lists

There are several ways to create numbered or bulleted lists:
* Use autoformatting, as described above.
* Use list (numbering) styles, as described in Chapters 6 and 7 in this book.

* Use the Numbering and Bullets buttons on the Formatting toolbar (see Figure 72) or on
the Paragraph panel of the Properties deck of the Sidebar (see Figure 73). This method is
described here.

To produce a numbered or bulleted list, select the paragraphs in the list and then click on the
appropriate button on the Paragraph panel or the toolbar.

It is a matter of personal preference whether you type your information first, then

Note apply Numbering/Bullets or apply these as you type.

Using the Bullets and Numbering toolbar

You can create a nested list (where one or more list items has a sub-list under it, as in an outline)
by using the buttons on the Bullets and Numbering toolbar (Figure 84). You can move items up or
down the list, or create subpoints, and even change the style of bullets. Use View > Toolbars >
Bullets and Numbering to see the toolbar.

To move a list entry up, together with all of its sub-entries, click the Promote One

Tip Level With Subpoints button.
Bullets and Numbering -
Tl
1 2 3 1 5 6 7 8 % 1N
1 Promote One Level 5 Insert Unnumbered Entry 8 Move Up with Subpoints
2 Demote One Level 9 Move Down with Subpoints
3 Promote One Level with 6 Move Up 10 Restart Numbering
Subpoints
4 Demote One Level with 7 Move Down 11 Bullets and Numbering
Subpoints

Figure 84: Bullets and Numbering toolbar

If you create a nested list using the buttons on this toolbar, all the levels of the list (up to 10) apply
the same numbering (or bullet). However, in many circumstances you will want to use a
combination of numbering formats and bullets when creating nested lists. Such lists, with a mixture
of numbering formats and bullets, can be easily configured as described in the following example.
Additional information on lists, in particular the technique to create your own list style, is described
in Chapter 7, Working with Styles.
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When creating nested lists, one option is to enter all the list paragraphs first and
apply the levels afterwards.

You can use keyboard shortcuts to move paragraphs up or down the outline levels.
Place the cursor at the beginning of the numbered paragraph and press:

Tip Tab Down a level
Shift+Tab Up a level

To insert a tab stop at the beginning of a numbered paragraph (that is, after the
number but before the text), press Ctrl+Tab.

Example: configuring a nested list

We will use a numbering style to produce the following effect:
I. Level-1 list item

A. Level-2 list item
i. Level-3 list item

a) Level-4 list item

This example uses one of the supplied styles, Numbering 1. If you intend to reuse this type of
nested list, you can also create a new style as illustrated in Chapter 7, Working with Styles.

1) Open the Styles and Formatting window (F11) and click the List Styles button at the top.
Specify All in the drop-down list at the bottom of the window. Right-click on the Numbering
1 style and choose Modify from the context menu.

Styles and Formatting =

v {a] & O 5 B W= -

List 1 e
List 2 [
List 3
List 4

Mumbering 2 Mew...
Mumbering 3 —
Mumbering 4
Mumbering 5

All ¥

Figure 85: Modifying a list style

2) On the Numbering Style dialog, go to the Outline page, where you will find that one style
matches our requirements. Click once on that style.
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Figure 86: Choosing a predefined outline-numbering style

3) To modify the layout of the list, use the Options tab (Figures 87 and 88). Notice that the
preview on the right shows the outline selected. In the Level box on the left, select 1, then 2,
3, and 4 and see how the information in the Numbering and After boxes changes.

Use the Options page to set different punctuation; for example, a period (full stop) after “a”
on level 4 instead of a parenthesis.

To make the indentation at each level greater or less than the default, change it on the
Position page. Select the level, then make any changes in the indentation, spacing, or
numbering alignment.

4) Repeat for each level as required, then click OK.

With outline numbering you can define different bullet styles for the different levels
of a bullet list. Use the Bullets tab of the Bullets and Numbering dialog (not shown)

Tip to select the basic style. Return to the Options tab to customize the bullet for each
indent level. Here you can set bullets to any character. See the Image tab for more
bullets.
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Numbering Style: Humbering 1

Crrganizer |Bullets |Mumbering Style |Qutine |Image |Position |Options
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7
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1-10
After
Start at 1 =]

Figure 87: Checking the outline numbering for level-1 list items

Level Numbering
1 Mumber A, B,C, .. v
5 = | L
i Character Style  [Mumbering Symbals V A, -
5 —
5 Show sublevels |1 £3 I.

Figure 88: Numbering style for level-2 list items

Using footnotes and endnotes

Footnotes appear at the bottom of the page on which they are referenced. Endnotes are collected
at the end of a document.

To work effectively with footnotes and endnotes, you need to:
* Insert footnotes.
¢ Define the format of footnotes.

* Define the location of footnotes on the page, and the color and line styles for separator
lines.

Inserting footnotes/endnotes

To insert a footnote or an endnote, put the cursor where you want the footnote/endnote marker to
appear. Then select Insert > Footnote/Endnote from the Menu bar or click the Insert
Footnote/Endnote Directly or Insert Endnote Directly button on the Insert toolbar.

A footnote or endnote marker is inserted in the text and, depending on your choice, the cursor is
relocated either to the footnote area at the bottom of the page or to the endnote area at the end of
the document. Type the footnote or endnote content in this area.
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Figure 89: Using the Insert Footnote Directly icon on the toolbar

If you use Insert > Footnote/Endnote, the Insert Footnhote/Endnote dialog (Figure 90) is
displayed. Here you can choose whether to use the automatic numbering sequence specified in
the footnote settings and whether to insert the item as a footnote or an endnote.

If you use the Insert Footnhote/[Endnote Directly or Insert Endnote Directly icon, the footnote or
endnote automatically takes on the attributes previously defined in the Footnote Settings dialog.

You can edit an existing footnote or endnote the same way you edit any other text.

To delete a footnote or endnote, delete the footnote marker. The contents of the footnote or
endnote are deleted automatically, and the numbering of other footnotes or endnotes is adjusted
automatically.

-

Insert Footnote/Endnote

Numbering

Type
{*) Footnote
() Endnote

|

Figure 90: Inserting a footnote/endnote

Defining the format of footnotes/endnotes

To format the footnotes themselves, click Tools > Footnotes/Endnotes. On the
Footnotes/Endnotes Settings dialog (Figure 91), choose settings as required.

Defining footnote location and separator line

The location of footnotes on the page, and the color and style of the line that separates the
footnotes from the text, are defined in the page style. If you are using several page styles, and may
have footnotes on any of them, you need to define the footnote location and separator line on each
of the page styles.

Choose Format > Page from the Menu bar or right-click on a page and choose Page from the
context menu, to display the Page Style dialog. Go to the Footnote tab (Figure 92) and make your
selections, then click OK to save the changes.
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Figure 91: Defining footnote formatting
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Figure 92: Defining footnote location and separator line
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Checking spelling and grammar

Spelling

Writer provides a spelling checker, which checks to see if each word in the document is in the
installed dictionary. This can mean that proper names which are correctly spelled but which do not
appear in the dictionary will be flagged as misspelled. Also provided is a grammar checker, which
can be used separately or in combination with the spelling checker.

If it is enabled before entering text, AutoSpellcheck checks each word as it is typed. If it is
enabled after text is inserted it checks the text already in the document. A wavy red line is
displayed under any unrecognized words. It can be enabled from the Standard Toolbar by clicking

ABL

the AutoSpellcheck button ( i ), or from Tools > Options > Language Settings > Writing Aids
and selecting it in the Options list.

Right-clicking on an unrecognized word brings up the AutoCorrect context menu. If the document
has change tracking enabled, then the context menu contains options relating to changes in the
text.

bowerxiul context menu. If
powerful
powerless

r exfoliate I

persifiage

Igniore

Ignore All

Add to Dictionary

Always correct to [

Spelling and Grammar

Set Language for Selection »
Set Language for Paragraph »

I Accept Change 2|
Reject Change
Mext Change

Previous Change I

Figure 93: AutoCorrect context menu

Clicking on one of the suggested words in the top section of the menu replaces the underlined
word with the one selected.

The choices in the second section of the menu are:

Ignore
This one instance of the underlined word will be ignored while the document is open. Other
instances, if they exist, will still be underlined. This setting is not stored with the document.

Ignore All
All instances of the word in the document will be ignored, and the word will be added to the
IgnoreAllList user-defined dictionary.
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Add to Dictionary
The word is added by default to the Standard dictionary.

Always correct to
Selecting this opens the submenu, which repeats the suggestions for the word from the top
section listing. Selecting a replacement word here stores the word pair in the replacement table
under Tools > AutoCorrect Options > Replacement. The underlined word is replaced with
the selected word.

Spelling and Grammar
This opens the Spelling and Grammar checker. See the explanations for this which follow.

In the third section of the context menu, language settings for the text can be set. These settings
can be applied to the text, or to the paragraph containing the text.

The fourth section is only visible when change tracking has been enabled and further edits are
carried out after saving the document. If the spelling error was in the saved document, then only
Next and Previous Change are shown. If the spelling error is in the newly added text, then the
content shown in Figure 93 is displayed.

Spelling and grammar

To perform a combined spelling and grammar check on the document (or a text selection), click the
HEC
Spelling and Grammar button on the Standard Toolbar ( W ), or press F7. In order to use this,
the appropriate dictionaries must be installed. By default, four dictionaries are installed: a
spellchecker, a grammar checker, a hyphenation dictionary, and a thesaurus. In operation the
Spelling and Grammar tool checks either the document from the cursor point onwards, or the text
selection. It opens the Spelling and Grammar dialog if any unrecognized words are found, or if
any of the built-in grammar rules are broken. The option to restart from the beginning of the
document is offered on reaching the end of the document.

[ T
Spelling and Grammar: English (USA)
Text language “& English (USA) »
Mot in dictionary
If itis enabled before entering text, AutoSpelicheck checks each word | [ Ignore Onee ]
as itis typed. |
[ Ignore All ]
vl | Add |
Suggestions
Spellchecker [ ghange ]
Autosuggestomn | =
Apalachicola [ Change Al ]
[ AutoCorrect ]
Check grammar
[ Help ] [ Options. .. ] LUndo [ Close ]

Figure 94: Spelling alert using the Spelling and Grammar dialog
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The elements of the Spelling and Grammar dialog are as follows.

Not in dictionary
The sentence containing the error is displayed in the pane. If an unrecognized word is found it
is highlighted.

If the error is grammatical, then it is indicated in a pale colored bar below the Text language
setting (Figure 95). The sentence or the word can be edited in the pane.

Suggestions
The pane contains suggested replacement words for the highlighted word. Select a word and
then select Change or Change All to replace it.

For grammatical errors there is no multiple choice. Select Change to accept the suggestion.

Text language
The language to be used for the spell and grammar checking can be selected from this list. If
the spell check is enabled for this language, a check mark is displayed in front of it.

Ignore Once, Ignore All, and Add
Selecting one of these buttons has the same effect as the item in the AutoCorrect context
menu detailed above.

Change
Replaces the unknown word with the suggested word. If the sentence was edited, the whole
sentence is changed.

For grammar, the suggested replacement is used to correct the text.

Change All
This replaces all instances of the word with the selected replacement word.

AutoCorrect
This behaves in a similar fashion to AutoCorrect described above. However, the word is not
replaced and you must select one of the Change buttons.

Undo
This button is enabled when a change has been made to the sentence, in case you wish to
reverse the change. The button is not accessible if you use a Change button to replace a word.

Options
Selecting this opens the Options dialogue box where you can select user defined dictionaries
and set the spell checking rules.

It is recommended you run the Spelling and Grammar checker twice on your
Note document. A minor software problem may prevent it detecting all the grammatical
errors in a single pass.

Grammar

By default, Check grammar as you type is enabled in Tools > Options > Language Settings >
Writing Aids > Options.

AutoSpellcheck must be enabled for this to work.
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If any errors are detected, they are shown underlined by a wavy blue line. Right clicking on this line

brings up a context menu which may be similar to one of those below.

|4 apple is good.

@ Badartide? An apple is good.
Explanations. .. @ Extraspace.
An apple
Ignare Ignore

A ' Agg " 4

'QJ"" Speling and Grammar Spelling and Grammar
Set Language for Selection  » SetLanguage for Selection
Set Language for Paraaraph » SetLanguage for Paragraph »

orr

nt

noL

The first entry in the menu informs you of the suspected broken grammatical rule

The second menu item in the left example is Explanations, which if selected opens your browser
and takes you to a web page offering more information about the error. This entry is not always

present in the context menu, as seen in the right example.

In the second section of the menu is the suggested correction. Clicking this changes the text to the

suggestion. The example to the right appears blank, but clicking here removes th
causing the error.

In the third section of the menu you can select to ignore the indicated error, or to

e extra space

open the Spelling

and Grammar checker. This dialog is shown below. This example displays the URL which will take

you to a web site for more information on the error indicated.

-

Spelling and Grammar: English (USA) [Lightproof Grammar Checker (en)]
Text language A% English (UsA)
Bad artide? fn.LI:'I’IrEI -
Mot in dictionary |htt|:-:ffen.'n'ikipedia.n:nrgﬁ 'ikifEninsh_arﬁdesﬂiscriminatin:-n_het-n-een_aﬁd_an
A apple a day keeps the doctor away. - [ Ignare Once ]
[ Ignore Rule ]
v
Suggestions
2 cppc e
Check grammar
[ Help ] [ Options... ] Undo [ Close ]

Figure 95: Dialog showing the URL for expanded explanation

In the final section of the menu, you can set the language for the selection or the

paragraph.
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English sentence checking

Additional grammar checking rules can be selected through Tools > Options > Language
Settings > English sentence checking, or through Tools > Extension Manager > English
spelling dictionaries > Options.

Grammar checking

[ ] Possible mistakes || Capitalization [ ] word duplication  [_] Parentheses
Punctuation
Waord spadng []Em dash [ ] Quotation marks Multiplication sign
[] sentence spadng [_] En dash [ ] Apostrophe [] Ellipsis
|:| Maore spaces |:| Minus sign
Others
[ ] Convert to metric (°C, km/h, m, kg, I) [ ] Thousand separation of large numbers

[] Convert to non-metric {°F, mph, ft, Ib, gal)

Figure 96: Additional grammar checking options

On the Language Settings > English sentence checking page, you can choose which items are
checked for, reported to you, or converted automatically. Select which of the optional features you
wish to check.

After selecting the additional grammar checks, you must restart LibreOffice, or reload the
document, for them to take effect.

Grammar checking

Possible mistakes
Check this for things such as; with it's, he don't, this things and so on.

Capitalization
Checks for the capitalization of sentences. The sentence boundary detection depends on
abbreviations.

Word duplication
Checks for all word duplication, rather than just the default words 'and', 'or', 'for' and 'the’'.

Parentheses
Checks for pairs of parentheses and quotation marks.

Punctuation

Word spacing
This option is selected by default. It checks for single spaces between words, indicating
instances of double or triple spaces, but not of more than that.

Sentence spacing
Checks for a single space between sentences, indicating when one or two extra spaces are
found.

More spaces
Checks word and sentence spacing for more than two extra spaces.
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Em dash; En dash
These options force a non-spaced em dash to replace a spaced en dash, or force a spaced en
dash to replace a non-spaced em dash, respectively.

Quotation marks
This checks for correct typographical double quotation marks.

Multiplication sign
This option is selected by default. It replaces an 'x' used as a multiplication symbol with the
correct typographical symbol.

Apostrophe
Replaces an apostrophe with the correct typographical character.

Ellipsis
Replaces three consecutive periods (full stops) with the correct typographical symbol.

Minus sign
Replaces a hyphen with the correct minus typographical character.

Others

Convert to metric; Convert to non-metric
Converts quantities in a given type of unit to quantities in the other type of unit: metric to
imperial or imperial to metric.

Thousands separation of large numbers
Converts a number with five or more significant digits to a common format, that is one which
uses the comma as a thousands separator, or to the ISO format which uses a narrow space as
a separator.

Using built-in language tools

Writer provides some tools that make your work easier if you mix multiple languages within the
same document or if you write documents in various languages:

e Selection of paragraph and character styles
* The functions in Tools > Language

* The use of language settings in Options

* The functions available on the status bar

The main advantage of changing the language for a text selection is that you can then use the
correct dictionaries to check spelling and apply the localized versions of AutoCorrect replacement
tables, thesaurus, and hyphenation rules. A grammar checking dictionary may be available for the
selected language.

You can also set the language for a paragraph or a group of characters as None (Do not check
spelling). This option is especially useful when you insert text such as web addresses or
programming language snippets that you do not want to check for spelling.

Using paragraph and character styles

Specifying the language in character and paragraph styles can be problematic unless you use a
particular style for a different language. Changing the Language on the Font tab of the Paragraph
Styles dialog will change the language for all paragraphs that use that paragraph style. You can set
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certain paragraphs to be checked in a language that is different from the language of the rest of the
document by putting the cursor in the paragraph and changing the language on the Task Bar. See
Chapter 7, Working with Styles, for information on how to manage the language settings of a style.

Using Tools > Language

You can also set the language for the whole document, for individual paragraphs, or even for
individual words and characters, from Tools > Language on the Menu bar.

For Selection
Applies a specified language to the selected text.

For Paragraph
Applies the specified language to the paragraph where the cursor is located.

For all Text
Applies the specified language to all of the document, including text inserted after making the
change.

Using language settings in Options

Another way to change the language of a whole document is to use Tools > Options > Language
Settings > Languages. In the Default languages for documents section (Figure 97), you can
choose a different language for all the text that is not explicitly marked as a different language.

Unlike the menu tool that applies to the individual document, a change in the

Caution default language from the Options dialog is a general change of settings of
LibreOffice and will therefore apply to all the documents created in the future. If
you want to change the language for the current document only, be sure to select

the For the current document only option.

Default languages for documents
Western *% English (UsA) L
[] Asian Default - Chinese (simplified]
[ ] complex text layout (CTL) Default - Hind
[ ] For the current document only

Enhanced language support
|:| Ignore system input language

Figure 97: Options available in the Languages settings

The spelling checker works only for those languages in the list which have the symbol £ next to
them. If you do not see this symbol next to your preferred language, you can install the dictionary
using Tools > Language > More dictionaries online.

Using the status bar

The language used for checking spelling is also shown in the status bar, next to the page style in
use. You can change the language for the paragraph or the entire document; click on the language
in the status bar to pop up a menu of choices.
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yn onthe men|  English (UK) stest way to
to the default | [« [Engi ane
| ® [English (USA) | Endlish (UK)
Mone (Do not chedk spelling) English (USA)
Reset to Default Language None (Do not check speling)
lesaurus | Mere. Reset to Default Language
Engiish (USA) Set Language for Paragraph  + More...

Figure 98: Language choices on the status bar

Notice the Reset to Default Language option on the menu and submenu. This is the fastest way to

return a paragraph or the entire document to the default language set in Tools > Options
(described above).

Using synonyms and the thesaurus

You can access a short list of synonyms from the context menu (Figure 99).

1) Select a word or phrase, right-click, and point to Synonyms on the context menu. A
submenu of alternative words and phrases is displayed.

2) Click on a word or phrase to select it and replace the highlighted word or phrase in the

document.
hDUS "‘L‘lﬂ "‘L‘lﬂc"ﬂllrl s I"I.HEF'C" C"E'I.Fﬂl'ﬂ! mEar‘”ﬂgS‘ |r-||:-|u[
diac, Clear Direct Formatting ent word from the
dwell Continue previous numbering e dﬂmmﬂe‘ abod
Fant 3
E' Size r
Style »
Alignment v
Line Spacing 3
s Character... dwelling
.i‘f’@[I Paragraph. .. home
domicile
Page...
abode
Bullets and Mumbering...
habitation
Ch C
LNange Lase ' dwelling house
Edit Paragraph Style. .. building
Synonyms r Thesaurus. ..
oo Cut
EhH  copy
D':j Paste
Figure 99: Synonyms on the context menu
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The thesaurus gives a more extensive list of alternative words and phrases. To use the thesaurus:

1) Select a word or phrase, and then choose Tools > Language > Thesaurus, or press
Ctrl+F7, or right-click and choose Thesaurus from the Synonyms submenu.

2) In the dialog, click on a word or phrase within the numbered list of meanings to select it.

3) Click Replace to make the substitution.

For example, when given the word house, the thesaurus offers several meanings, including
dwelling, legislature, sign of the zodiac, and others. Select a replacement word from the list
under the relevant meaning, so for dwelling, you will see dwelling, home, domicile, abode,
and other alternatives, as shown in Figure 100.

Not If the current language does not have a thesaurus installed, this feature is
LU= disabled.

L S

Thesaurus (English (USA))

Current ward
house v English (UsA) v

Alternatives

1. (moun) dwelling (generic term) e
dwelling {generic term) i
home (generic term)
domicile {generic term)
abode (generic term)
habitation (generic term)
dwelling house (generic term)
building {generic term)
edifice (generic term)

2. (noun) legislature {generic term)
legislature {generic term)
legislative assembly (generic term)
legislative (generic term)
general assembly (generic term)
law-makers (generic term) fal

Replace with

dwelling

Help ] [ Replace l I Cancel

Figure 100: The thesaurus offers alternatives to words

Hyphenating words

You have several choices regarding hyphenation: let Writer do it automatically (using its
hyphenation dictionaries), insert conditional hyphens manually where necessary, or don’'t
hyphenate at all. Each choice has its pros and cons.

Automatic hyphenation

To turn automatic hyphenation of words on or off:

1) Press F11 to open the Styles and Formatting window. On the Paragraph Styles page, right-
click on Default and select Modify.
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Styles and Formatting ]

in ] & D & Bn 7= -

Contents Heading e

fylei

Drawing Mew...
Modify...

Endnote
First Line Ij
Foater
Footer Left
Footer Right

Figure 101: Modifying a paragraph style
2) On the Paragraph Style dialog, select the Text Flow tab.

Fosition Cutline & Mumbering Tabs Drop Caps Background Borders
Crganizer Indents & Spacing Alignment Text Flow Font Font Effect
Hyphenation
2 %1 Characters at line end
2 %1 Characters atline begin
0 %1l Maximum number of consecutive hyphens

Figure 102: Turning on automatic hyphenation

3) Under Hyphenation, select or deselect the Automatically option.
4) Click OK to save.

Turning on hyphenation for the Default paragraph style affects all other paragraph
styles that are based on Default. You can individually change other styles so that

Note hyphenation is not active; for example, you might not want headings to be
hyphenated. Any styles that are not based on Default are not affected. For more
on paragraph styles, see Chapters 6 and 7 in this book.

You can also set hyphenation choices through Tools > Options > Language Settings > Writing
Aids. In Options, near the bottom of the dialog, scroll down to find the hyphenation settings.

Options

Minimal number of characters for hyphenation; 5 i Edit |
Characters before line break: 2 =

Characters after line break: 2
H Hyphenate without inguiry
v Hvohenate special reqions

Figure 103: Setting hyphenation options

To change the minimum number of characters for hyphenation, or the minimum number of
characters before or after a line break, select the item, and then click the Edit button in the Options

section.

Hyphenate without inquiry
Specifies that you will never be asked to manually hyphenate words that the hyphenation
dictionary does not recognize. If this box is not selected, when a word is not recognized, a

dialog will open where you can manually enter hyphens.
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Hyphenate special regions
Specifies that hyphenation will also be carried out in footnotes, headers, and footers.

Hyphenation options set in the Writing Aids dialog are effective only if hyphenation is turned on
through paragraph styles.

Manual hyphenation

To manually hyphenate words, do not use a normal hyphen, which will remain visible even if the
word is no longer at the end of a line when you add or delete text or change margins or font size.
Instead, use a conditional hyphen, which is visible only when required.

To insert a conditional hyphen inside a word, click where you want the hyphen to appear and press
Ctrl+hyphen or use Insert > Formatting Mark > Optional hyphen. The word will be hyphenated
at this position when it is at the end of the line, even if automatic hyphenation for this paragraph is
switched off.

Using AutoCorrect

Writer’s AutoCorrect function has a long list of common misspellings and typing errors, which it
corrects automatically. For example, “hte” will be changed to “the”.

AutoCorrect is turned on when Writer is installed. To turn it off, uncheck Format > AutoCorrect >
While Typing.

Select Tools > AutoCorrect Options to open the AutoCorrect dialog. There you can define what
strings of text are corrected and how. In most cases, the defaults are fine.

L o

AutoCorrect
Replacements and exceptions for language:  |English (USA) v
Replace Exceptions |Options |Localized Options |Waord Completion

Replace With: Text only

(c) © Ney
-— - A

. B ]

{C) ]

(R &

(tm) "

- -

- —_

] -

- -

12 1

1/4 e

3/4 3%

abotu about

abouta about a

aboutit aboutit

abscence absence

accesories accessories

accidant accident -
rrrrrr Azta arcamrnadate I~

Figure 104: Replace tab of AutoCorrect dialog
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To stop Writer replacing a specific spelling, go to the Replace tab, highlight the word pair, and click
Delete.

To add a new spelling to the list, type it into the Replace and With boxes on the Replace tab, and
click New.

See the different pages of the dialog for the wide variety of other options available to fine-tune
AutoCorrect.

AutoCorrect can be used as a quick way to insert special characters. For example,

Tip (c) will be automatically corrected to ©. You can add your own special characters.

Using word completion

If Word Completion is enabled, Writer tries to guess which word you are typing and offers to
complete the word for you. To accept the suggestion, press Enter. Otherwise, continue typing.

To turn off Word Completion, select Tools > AutoCorrect Options > Word Completion and
deselect Enable word completion.

s w1

AutoCorrect
Replacements and exceptions for language:  |English (USA]
Replace |[Exceptions ||Options |Localized Options |Word Completion
Enable word completion abbreviations PN
acceleration =]
D Append space acceptance
[ ] show as tip Accessibility
accessible
Collect words acridental
n When dosing a document, remove the accnmpllsh
words collected from it from the list accordingly
Adnowledgments
activating
additional
Accent with addressing
: =t —— |administrator
Enter iv| |afterwards
o alphabetical
M. "l"':'r'_j I?ngm alphabetically
10 = alteration
i alternative w
Max. entries —
500 (8 [ Delete Entry

Figure 105: Customizing word completion

You can customize word completion from the Word Completion page of the AutoCorrect dialog
(Figure 105).

* Add (append) a space automatically after an accepted word.

e Show the suggested word as a tip (hovering over the word) rather than completing the text
as you type.
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Note

Collect words when working on a document, and then either save them for later use in
other documents or select the option to remove them from the list when closing the
document.

Change the maximum number of words remembered for word completion and the length of
the smallest words to be remembered.

Delete specific entries from the word completion list.

Change the key that accepts a suggested entry—the options are right arrow, End key,
Enter (Return), Space bar, and Tab.

Automatic word completion only occurs after you type a word for the second time
in a document.

Using AutoText

Use AutoText to store text, tables, fields, and other items for reuse and assign them to a key
combination for easy retrieval. For example, rather than typing “Senior Management” every time
you use that phrase, you can set up an AutoText entry to insert those words when you type “sm”
and press F3.

AutoText is especially powerful when assigned to fields. See Chapter 14, Working with Fields, for
more information.

Creating AutoText

To store some text as AutoText:

1)
2)
3)
4)
5)

6)

7

Type the text into your document.
Select the text.
Go to Edit > AutoText (or press Ctrl+F3).
In the AutoText dialog (Figure 106), type a name for the AutoText in the Name box. Writer
will suggest a one-letter shortcut, which you can change.
In the large box to the left, choose the category for the AutoText entry, for example My
AutoText.
Click the AutoText button on the right of the dialog and select from the menu either New
(to have the AutoText retain specific formatting, no matter where it is inserted) or New (text
only) (to have the AutoText take on the existing formatting around the insertion point..
Click Close to return to your document.

Tip If the only option under the AutoText button is Import, either you have not entered

a name for your AutoText or there is no text selected in the document.
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AutoText

-,

[ ] Display remainder of name as suggestion while typing

Mame

+
+

+
+

Chapter

Business Cards, Work (3 V2 x 2)
LD

My AutoText

Only for Templates

Standard

Save links relative to
[ ] File system [ ] internet

s

Shortcut |C

>

Help

Mew

-

Mew (text gnlﬂ%

Impart...

Figure 106: Defining a new AutoText entry

To save a table as AutoText:

1)
2)
3)
4)

5)

6)

Create a table and format it the way you want.

Select the table.
Go to Edit > AutoText (or press Ctrl+F3).

Type a name for the AutoText, optionally amend the suggested shortcut, and choose the
category for the AutoText entry.

Click the AutoText button and select New (because you want the formatting of the table
preserved).

Click Close to return to your document.

Inserting AutoText
To insert AutoText, type the shortcut and press F3.

Printing a list of AutoText entries

To print a list of AutoText entries:
Choose Tools > Macros > Organize Macros > LibreOffice Basic.
In the Macro from list, expand LibreOffice Macros > Gimmicks.

Select AutoText and then click Run. A list of the current AutoText entries is generated in a
separate text document. You can then print this document.

1)
2)
3)
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LibreOffice Basic Macros
Macro name
Main
Macro from Existing macros in: AutoText
=1 =3 My Macros - Main
= @ Standard InsertStringToCell
<> Module1 :
= =3 LibreOffice Macros A
[z5] Access2Base T
e
(=] Euro
(=] Form\Wizard Delete
= < Gimmicks
i I . c/)‘:\_n.n.An:_ |V|

Line numbering

Line numbering puts line numbers in the margin. The line numbers are displayed on screen and
are also printed. Figure 107 shows an example with numbering on every line.

Line humbering

Line numbering puts line numbers in the ma
also printed. Figure 1 shows an example wit

Click Toels > Line Numbering and select it
Line Numbering dialog (Figure 2). Then click

You can choose how many lines are number
numbering type, and whether numbers resta
choose) can be set on a different numbering

CoO~ICh Nd LIRS =

Figure 107: Line numbering example

Click Tools > Line Numbering and select the Show numbering option in the top left corner of the
Line Numbering dialog (Figure 108). Then click OK.

You can choose how many lines are numbered (for example, every line or every tenth line), the
numbering type, and whether numbers restart on each page. In addition, a text separator (any text
you choose) can be set on a different numbering scheme (one every 12 lines, for example).
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Line Numbering

Show numbering;

View
Character Style  |Line Mumbering v
Format 1, 2, 3 ... |
Position Left .
Spacing 0, 50cm £
Interval 5 ¥ lines

Separator Count
Text Blank lines
- [] Lines in text frames
CEVE Lines
- [ Restart every new page

QK l I Cancel l I Help

Figure 108: The Line Numbering dialog

Tracking changes to a document

You can use several methods to keep track of changes made to a document.

* Make your changes to a copy of the document (stored in a different folder, under a different
name, or both), then use Writer to combine the two files and show the changes you made.
Click Edit > Compare Document. This technique is particularly useful if you are the only
person working on the document, as it avoids the increase in file size and complexity
caused by the other methods.

* Save versions that are stored as part of the original file. However, this method can cause
problems with documents of nontrivial size or complexity, especially if you save a lot of
versions. Avoid this method if you can.

* Use Writer's change marks (often called “redlines” or “revision marks”) to show where you
have added or deleted material or changed formatting. Later, you or another person can
review and accept or reject each change.

N Not all changes are recorded. For example, changing a tab stop from align left to
ote align right and changes in formulas (equations) or linked graphics are not recorded.

Preparing a document for review

When you send a document to someone else to review or edit, you may want to prepare it first so
that the editor or reviewer does not have to remember to turn on the revision marks. After you have
protected the document, any user must enter the correct password in order to turn off the function
or accept or reject changes.
1) Open the document. To check whether it contains multiple versions, click File > Versions.
If multiple versions are listed, save the current version as a separate document with a
different name and use this new document as the review copy.
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2) With the review copy open, make sure that change recording is turned on. The Edit >
Changes > Record menu item has a check mark next to it when recording is turned on.

3) Click Edit > Changes > Protect Records. On the Enter Password dialog, type a password
(twice) and click OK.

An alternative to steps 2 and 3 above is to choose File > Properties > Security tab,

Tip select the Record changes option, then click Protect and enter the password.

Recording changes

See Chapter 2, Setting up Writer, for instructions on setting up how your changes will be displayed.

1) To begin tracking (recording) changes, choose Edit > Changes > Record. To show or hide
the display of changes, click Edit > Changes > Show.

Hold the mouse pointer over a marked change; you will see a Help Tip showing
Tip the type of change, the author, date, and time of day for the change. If Extended
Tips are enabled, you will also see any comments recorded for this change.

2) To enter a comment on a marked change, place the cursor in the area of the change and
then click Edit > Changes > Comment.

In addition to being displayed as an extended tip, the comment is also displayed in the list
in the Accept or Reject Changes dialog (Figure 110).

To move from one marked change to the next, use the arrow buttons. If no comment has
been recorded for a change, the Text field is blank.

3) To stop recording changes, click Edit > Changes > Record again.

See also “Adding other comments” on page 113 for a way to annotate text that is

Tip not associated with a recorded change.

-

Comment: Insertion

Contents
Author  John Smith, 02212014 20:22
Text

Cancel

A comment on the inserted text, e

Help

Figure 109: Inserting a comment during change recording
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Accepting or rejecting changes

To accept or reject recorded changes, use either of these methods:
* Right-click (context) menu
* Accept or Reject Changes dialog

The results of accepting or rejecting a change are as follows:
* Accepting a change incorporates the alteration into the document and removes the change
indication marking.

* Rejecting a change reverts the document to its original state and removes the change
indication marking.

Right-click (context) menu

1) If recorded changes are not showing, click Edit > Changes > Show.

2) Hover the mouse pointer over a recorded change. A box appears with information about the
type of change, who made it, and the date and time.

3) Right-click on the changed text. In the context menu, choose Accept Change or Reject
Change.

Accept or Reject Changes dialog

1) Click Edit > Changes > Accept or Reject. The Accept or Reject Changes dialog (Figure
110) opens, showing changes that have not yet been accepted or rejected.

2) When you select a change in the dialog, the actual change is highlighted in the document,
S0 you can see what the editor changed.

3) Click Accept or Reject to accept or reject the selected change. You can also click Accept
All or Reject All if you do not want to review the changes individually.

To show only the changes of certain people or only the changes on specific days or various other
restrictions, use the Filter page (Figure 111) on the Accept or Reject Changes dialog. After
specifying the filter criteria, return to the List page to see those changes that meet your criteria.

e 1
Accept or Reject Changes
List Filter
|.-5.n:ti|:|n |.-5.uﬂ'u:|r |Date Comment |

Deletion John Smith 02/21/2014 20:22

Insertion John Smith 02212014 20:22 A comment on the inserted text.
Insertion John Smith 02/21/2014 20:55

Deletion John Smith 02212014 21:03

Insertion John Smith 02/21/2014 21:03  Another comment,

Deletion John Smith 02/21/2014 21:23

Insertion John Smith 02212014 21:23

ﬁccept l ’ Reject ] ’ Accept all ] [ Reject all ] ’ Close

Figure 110: The List tab of the Accept or Reject Changes dialog
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Accept or Reject Changes

List |Filter

[+] Date between w| [02/21/2014 ::: 19:59 :::
.A.
| O

and |02/20/2014 (o |22:58

Author John Smith v
Action Insertion v
Comment

I Accept ] [ Reject ] I Accept all ] I Reject Al l [ Close

Figure 111: The Filter page of the Accept or Reject Changes dialog

Merging modified documents

The processes discussed to this point are effective when you have one reviewer at a time.
Sometimes, however, multiple reviewers all return edited versions of a document at the same time.
In this case, it may be quicker to review all of these changes at once, rather than one review at a
time. For this purpose, you can merge documents in Writer.
To merge documents, all of the edited documents need to have recorded changes in them.

1) Open one copy.

2) Click Edit > Changes > Merge Document and select and insert another copy of the
document to be merged with the first.

3) After the documents merge, the Accept or Reject Changes dialog opens, as in Figure 110,
showing changes by more than one reviewer. If you want to merge more documents, close
the dialog and then repeat step 2.

4) Repeat until all copies are merged.
All recorded changes are now included in the open copy. Save this file under another name.

Comparing documents

Sometimes reviewers may forget to record the changes they make. This is not a problem with
Writer because you can find the changes if you compare documents.

In order to compare documents, you need to have the original document and the one that is edited.
To compare them:

1) Open the edited document. Select Edit > Compare Document.

2) The Insert dialog appears. Select the original document and click Insert.

Writer finds and marks the changes and displays the Accept or Reject Changes dialog. From this
point, you can go through and accept or reject changes procedure as described earlier.
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Adding other comments

Writer provides another type of comments (formerly called “notes”), which authors and reviewers
often use to exchange ideas, ask for suggestions, or brainstorm during the review process.

You can select a block of text, including multiple paragraphs, to be highlighted for a comment, or
insert a comment at a single point. To insert a comment, select the text, or place the cursor in the
place the comment refers to, and choose Insert > Comment or press Ctrl+Alt+C.

The anchor point of the comment is connected by a dotted line to a box on the right-hand side of
the page where you can type the text of the comment. Writer automatically adds at the bottom of
the comment the author’'s name and a time stamp indicating when the comment was created.
Select Tools > Options > LibreOffice > User Data to configure the name you want to appear in
the Author field of the comment, or to change it.

Click somewhere on the page to finish your comment. Otherwise, you will not be able to move
away from this location.

This comment is nested due to
overlapping text selection.

multiple paragraphs, or a single point may be selected
‘a comment select the text, or place ffie cursor in the Comment on selected text.
> Comment or press Cirl+Aff+C. The anchor point of
box on the right-hand side of the page where you can
ly adds at the bottom of the comment the author's Joe Soap -

nment was created. Today, 20:27

-

A single point comment.

Figure 112: Comments in LibreOffice

If more than one person edits the document, each author is automatically allocated a different
background color. Figure 112 shows an example of text with comments from two different authors.
If an author selects text that overlaps another author’s comments, then the comments from the
second author are nested with those of the first author.

Right-clicking on a comment pops up a menu where you can delete the current comment, all the
comments from the same author, or all the comments in the document. This part of the menu is
also available by clicking the down-arrow in the comment. From this menu, you can also apply
some basic formatting to the text of the comment. You can also change font type, size, and
alignment from the Menu bar.

To navigate from one comment to another, open the Navigator (F5), expand the Comments
section, and click on the comment text to move the cursor to the anchor point of the comment in
the document. Right-click on the comment to quickly edit or delete it.

You can also navigate the comments using the keyboard. Use Ctrl+Alt+Page Down to move to the
next comment and Ctrl+Alt+Page Up to move to the previous comment.

Inserting a comment causes the Comments button to appear on the right-hand end of the ruler
(see Figure 112). Toggling the button hides or shows all the comments.
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Linking to another part of a document

If you type in cross-references to other parts of the document, those references can easily get out
of date if you reorganize the order of topics, add or remove material, or reword a heading, Writer
provides two ways to ensure that your references are up to date, by inserting links to other parts of
the same document or to a different document:

* Hyperlinks
* Cross-references

The two methods have the same result if you Ctrl+click the link when the document is open in
Writer: you are taken directly to the cross-referenced item. However, they also have major
differences:

* The text in a hyperlink does not automatically update if you change the text of the linked
item (although you can change it manually), but changed text does automatically update in
a cross-reference.

* When using a hyperlink, you do not have a choice of the content of the link (for example
text or page number), but when using a cross-reference, you have several choices,
including bookmarks.

* To hyperlink to an object such as a graphic, and have the hyperlink show useful text such
as Figure 6, you need to either give such an object a useful name instead of leaving it as
the default name (“Graphics6”), or you need to use the Hyperlink dialog to modify the
visible text. In contrast, cross-references to figures with captions automatically show useful
text, and you have a choice of several variations of the name.

* |f you save a Writer document to HTML, hyperlinks remain active but cross-references do
not. (Both remain active when the document is exported to PDF.)

Using cross-references

To ensure that references update if you reword a heading, caption, or other linked item, use
automatic cross-references. See “Using automatic cross-references” in Chapter 14, Working with
Fields, for details.

Using bookmarks

Bookmarks are listed in the Navigator and can be accessed directly from there with a single mouse
click. In HTML documents, bookmarks are converted to anchors that you can jump to by hyperlink.
For more about bookmarks, see “Using bookmarks” in Chapter 14, Working with Fields.

Using hyperlinks

When you type text (such as website addresses or URL) that can be used as a hyperlink, and then
press the spacebar or the Enter key, Writer automatically creates the hyperlink and applies
formatting to the text (usually a color and underlining).

If this does not happen, you can enable this feature using Tools > AutoCorrect Options >
Options and selecting the URL Recognition option.

If you do not want Writer to convert a specific URL to a hyperlink, choose Edit > Undo Insert from
the Menu bar or press Ctrl+Z immediately after the formatting has been applied.

You can also insert hyperlinks using the Navigator and the Hyperlink dialog, and you can modify all
hyperlinks using the Hyperlink dialog, as described in this section.
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Hyperlinks between documents can be set as relative or absolute, using the Save

URLSs relative to option in Tools > Options > Load/Save > General.

Relative linking is only possible when the document you are working on and the link

Note

destination are on the same drive, and you need to create the same directory
structure on your hard disk as will apply on the destination website.

LibreOffice uses absolute path names internally, so when you move your mouse

cursor over a hyperlink, the tooltip displays the absolute reference even when it is

set to be a relative link.

Inserting hyperlinks using the Navigator

The easiest way to insert a hyperlink to another part of the same document is by using the

Navigator:

1) Open the document containing the items you want to cross-reference.
2) Open the Navigator (by clicking its icon, choosing View > Navigator, pressing F5, or

selecting the Navigator Tab on the open Sidebar).

3) Click the arrow next to the Drag Mode icon, and select Insert as Hyperlink.

4) In the list at the bottom of the Navigator, select the document containing the item that you

want to cross-reference.

5) In the Navigator list, select the item that you want to insert as a hyperlink.

6) Drag the item to where you want to insert the hyperlink in the document. The name of the

item is inserted in the document as an active hyperlink.

Navigator ]
®@-& T s 7@
= | @ ﬁ |EEE |EEE || [nsertas Hyperlink

...................... Insert as Link

+  Copyright
Mote for Mac users
Introduction
+  Selecting text
Cutting, copying, and pasting text
+  Finding and repladng text and formatting |
< »

Insert as Copy

g

WE4003-WorkingWithText (active) el

Figure 113: Inserting a hyperlink using the Navigator

Inserting hyperlinks using a dialog

To display the Hyperlink dialog (Figure 114), click the Hyperlink icon (Ea) on the Standard Toolbar

or choose Insert > Hyperlink from the Menu bar. To turn existing text into a link, select it before

opening the dialog.

On the left hand side, select one of the four types of hyperlink:
* Internet: a web address, normally starting with http://
* Mail & News: for example an email address.

* Document: the hyperlink points to another document or to another place in the

presentation.
* New document: the hyperlink creates a new document.
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Hyperlink
oy Hyperlink type
k@ {(*) web QOemr
Internet Target http: /v libreoffice.org/f A E'_}
Mail & Mews

Further settings
Frarme | Form Text w
Document

Text www. libreoffice.orgf

= Mame

Mew Document

[ Apply l [ Close ] [ Help ] [ Back

Figure 114: Hyperlink dialog showing details for Internet links

The top right part of the dialog changes according to your choice for the hyperlink type. A full
description of all the choices, and their interactions, is beyond the scope of this chapter. Here is a
summary of the most common choices used in presentations.

For an Internet type hyperlink, choose the type of hyperlink (choose between Web, FTP or Telnet),
and enter the required web address (URL).

For a Mail and News type hyperlink, specify whether it is a mail or news link, the receiver address
and for email, also the subject.

For a Document type hyperlink, specify the document path (the Open File button opens a file
browser); leave this blank if you want to link to a target in the same presentation. Optionally specify
the target in the document (for example a specific slide). Click on the Target icon to open the
Navigator where you can select the target, or if you know the name of the target, you can type it
into the box.

For a New Document type hyperlink, specify whether to edit the newly created document
immediately or just create it (Edit later) and the type of document to create (text, spreadsheet, and
so on). For a text document, Edit now is the more likely choice. The Select Path button opens a
directory picker.

The Further settings section in the bottom right part of the dialog is common to all the hyperlink
types, although some choices are more relevant to some types of links.

* Set the value of Frame to determine how the hyperlink will open. This applies to documents
that open in a Web browser.

* Form specifies if the link is to be presented as text or as a button.
* Text specifies the text that will be visible to the user.

* Name is applicable to HTML documents. It specifies text that will be added as a NAME
attribute in the HTML code behind the hyperlink.

¢ Event button: this button will be activated to allow LibreOffice to react to events for which
the user has written some code (macro). This function is not covered in this book.
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Editing hyperlinks

To edit a hyperlink, click anywhere in the link text and then open the Hyperlink dialog by clicking
the Hyperlink icon on the Standard Toolbar or choosing Edit > Hyperlink from the Menu bar.
Make your changes and click Apply. If you need to edit several hyperlinks, you can leave the
Hyperlink dialog open until you have edited all of them. Be sure to click Apply after each one.
When you are finished, click Close.

The standard (default) behavior for activating hyperlinks within LibreOffice is to use Ctrl+click. This
behavior can be changed in Tools > Options > LibreOffice > Security > Options, by deselecting
the option Ctrl-click required to follow hyperlinks. If clicking in your links activates them, check
that page to see if the option has been deselected.

To change the color of hyperlinks, go to Tools > Options > LibreOffice > Appearance, scroll to
Unvisited links and/or Visited links, select those options, pick the new colors and click OK. Caution:
this will change the color for all hyperlinks in all components of LibreOffice—this may not be what
you want.

In Writer and Calc (but not Draw or Impress), you can also change the Internet link character style
or define and apply new styles to selected links.

Switching between insert and overwrite mode

In insert mode, any text after the cursor position moves forward to make room for the text you type;
in overwrite mode, text after the cursor position is replaced by the text you type. Only the Overwrite
mode is displayed on the Status Bar. The shape of the cursor does not change.

English (USA) m | [

&

English (USA&) Overwrite | = | [

Insert mode

Overwrite mode

With the keyboard, press Insert to toggle between overwrite mode and insert mode. With the
mouse, click in the area on the Status Bar that indicates the current mode in order to switch to the
other mode. Overwrite mode cannot be used with Edit > Changes > Record enabled.

Counting the words in a selection

Word and character count for the document, or for any selected text, is displayed on the Status
bar. Word count and character count can be viewed by choosing Tools > Word Count or double-
clicking on the word count field in the Status bar; this information updates as you edit the
document. See Chapter 2, Setting up Writer, for information on setting word counting boundaries.

What now?

What now?
Docking a Hoat.

Doclang a boat.

11 words, 50 characters 3 words, 8 characters selected

You can also see the number of words and characters (and other information including the number
of pages, tables, and graphics) in the entire document in File > Properties > Statistics.
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Changing the case of selected text

To quickly change the case of text, select it, choose Format > Change Case from the Menu bar,
and then choose one of the following:

Sentence case, where only the first word is capitalized (together with any proper nouns)
lower case, where no words (except proper nouns) are capitalized

UPPER CASE, where all letters are capitalized

Capitalize Every Word, where every word is capitalized

tOGGLE cASE, which changes every letter to the opposite case

There are also several options that are used with Asian text. These are not strictly “Case” changes,
but are lumped together in the broader sense of replacing characters with different forms of the
same letter. These options are hidden when Asian language support is not enabled.

Writer does not have an automated way to do Title Case, where all words are capitalized except for
certain subsets defined by rules that are not universally standardized. To achieve this affect, you
can use Capitalize Every Word and then restore those words that were incorrectly capitalized.
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Introduction

Writer provides several ways for you to control page layouts:
* Page styles

* Columns
* Frames
* Tables

* Sections

This chapter describes these methods and some associated functions:
* Headers and footers
* Numbering pages
* Changing page margins

Page layout is usually easier if you select the options to show text, object, table,
and section boundaries in Tools > Options > LibreOffice > Appearance and the
options for paragraph ends, tabs, breaks, and other items in Tools > Options >
LibreOffice Writer > Formatting Aids.

Tip

Choosing a layout method

The best layout method depends on what the final document should look like and what sort of
information will be in the document. Here are some examples. Do not worry if all this does not
mean much to you now. The techniques mentioned are all described in this chapter.

For a book similar to this user guide with one
column of text, some figures without text beside
them, and some other figures with descriptive text,
use page styles for basic layout, and use tables to
place figures beside descriptive text, where
necessary.

tems
formatted as
a table
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Use page styles (with two columns) for an index or
other document with two columns of text where the
text continues from the left-hand column to the

right-hand column and then to the next page, all in

sequence (also known as snaking columns of text).

If the title of the document (on the first page) is full-
page width, put it in a single-column section.

For a newsletter with a complex layout, two or
three columns on the page, and some articles that
continue from one page to some place several
pages later, use page styles for basic layout. Place
articles in linked frames and anchor graphics to
fixed positions on the page, if necessary.

For a document with terms and translations to
appear side-by-side in what appear to be columns,
use a table to keep items lined up so you can type
in both “columns”.

Titleisin a

single
column
section

Basic layout
isintwo

T
. =

i -y s e

columns

Thisis a
header on

the first page
only

This fame is
linked to a

frame on
another page

These frames
are not linked

to other
frames

Thisis a
borderless
table. Each
pair of words
i5 in a separate
row, and each
wordis in a
cell of the
table.

3

T

e

EE{EE{{E[{E[

R
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Setting up basic page layout using styles

In Writer, page styles define the basic layout of all pages, including page size, margins, the
placement of headers and footers, borders and backgrounds, number of columns, and so on.

Writer comes with several page styles, which you can build on or modify, and you can define new
(custom) page styles. You can have one or many page styles in a single document.

All pages in a Writer document are based on styles. If you do not specify a page

Note style, Writer uses the Default page style.

To change the layout of individual pages, either define a new page style or use one of the
techniques (sections, frames, or tables) described later in this chapter.

This chapter describes some uses of page styles. Some other uses are discussed in Chapter 6,
Introduction to Styles. The Page Style dialog is covered in detail in Chapter 7, Working with Styles.

Any modifications of page styles, including the Default page style, apply only to the
document you are working on. If you want the changes to be the default for all
documents, you need to put the changes into a template and make that template
the default template. See Chapter 10, Working with Templates, for details.

Tip

Inserting a page break without switching the style

In many documents (for example, a multi-page report), you may want the text to flow from one
page to the next as you add or delete information. Writer does this automatically, unless you
override the text flow using one of the techniques described earlier.

If you do want a page break in a particular place, for example, to put a heading at the top of a new
page, here is how to do it:

1) Position the cursor at the point you want to start the next page. Select Insert > Manual
Break.

2) Inthe Type section, Page break is preselected, and Style is set at [None].
3) Click OK to position the paragraph at the start of the next page.

Insert Break

Type
() Line break

Ok

Style Help

[Mone] V

i hann n=n it mir r
Lhange page numpe

Figure 115: Inserting a manual page break
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You can also insert a page break as follows;

1) Position the cursor in the paragraph you want to be at the start of the next page.
Right-click and choose Paragraph in the pop-up menu.

2) On the Text Flow page of the Paragraph dialog, in the Breaks section, select
Insert. Do not select With Page Style.

Tip 3) Click OK to position the paragraph at the start of the next page.
Breaks
nsert Type Fage w Position |Before w
[ ] with Page Style

Defining a different first page for a document

Many documents, such as letters and reports, have a first page that is different from the other
pages in the document. For example, the first page of a letterhead typically has a different header,

as shown in Figure 116, or the first page of a report might have no header or footer, while the other
pages do. This is simple to achieve with Writer.

Using the Default (or any other) page style for your document, you can add a header/footer as you
wish to the first page by deselecting the Same content on first page option on the header/footer

pages in the Page Style dialog, and then adding the header/footer. You can then add a different
header/footer to the other pages of the document.

A | : LibreOffice
[ LibreOffice [ FlbreOffice
The Dacument Feundation
Integer non dul magna Duls fells nibh, adipiscing in dictum In, vehicula quis

Name Hame Name amte. Allquam teils felis, suctor s amet comma do sed, gravida vel dolor.
Address Vestibulum lacus

Reciplent
Address

City, State

Sollnugin lsoreet ris ue aaipisa lestie ultrices. Nullam ac
Jarem lectus. Suspend Joes sodales s amet fempor
4 quisarcl. Nullam

ko eu urna
aquet commoas

m purus.
lorem, aliquam id bibendum a, oursus ut vell A u Regards,

Vivamusorcl quam, volutpatin semper ac, wariu:

neque placeral SUISMO. CurabItur S0 oal

vulp utat e vestibulim e s Vivamus euls: cerat. Integer quis Sengers name
aime

VoI TpaL PrOIn ACCUMSAN Sem quis VeI SagRiis Son

Froin vitas porttitor leo.

Page lat2 Page 2otz

Figure 116: Letterhead with different headers for first and following pages

Changing page orientation within a document

A document can contain pages in more than one orientation. A common scenario is to have a

landscape page in the middle of a document, whereas the other pages are in a portrait orientation.
Here are the steps to achieve it.
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Setting up a landscape page style

1) If you wish to keep the margins the same as on other pages, then note the margin settings
of the current page style. (You can find the margin settings on the Page Style dialog, by

selecting the Page tab as shown in Figure 118.)

2) In the Styles and Formatting window, right-click on Landscape in the list of page styles and
choose Madify from the pop-up menu (Styles and Formatting can also be accessed from

the Sidebar, View > Sidebar).

3) On the Organizer page of the Page Style dialog (Figure 117), make sure the Next Style
property is set to Landscape (to allow for having more than one sequential landscape

-,

page).
7~
Page Style: Landscape
Organizer |Page | Background || Header |Footer || Borders | Columns | Footnote
MHame Landscape
Mext Style { andscape
Category Custom Styles

Figure 117: Name the new style and set the next page style to Landscape

4) On the Page page of the Page Style dialog (Figure 118), make sure the Orientation is set to
Landscape. Change the margins so that they correspond with the margins of the portrait
page. That is, the portrait top margin becomes the landscape left margin, and so on.

Crganizer |Page | Background || Header ||Footer || Borders | Columns | Footnote

Paper format

Farmat A4 W

Width 11,69 -

Height .27 4

Orientation {:}' Portrait

(%) Landscape Paper tray [From printer settings]

Maragins Layout settings

Left 0.75" i Fage layout Right and left

Right 0.75" Format 1,2, 3 ...

Top 1,00 |:| Register-true

Bottom 0.757 —

Figure 118: Set orientation and margins for a landscape page

5) Click OK to save the changes.
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Inserting a landscape page into a portrait document
Now that you have defined the Landscape page style, here is how to apply it.

1) Position the cursor in the paragraph or table at the start of the page that is to be set to
landscape. Right-click and choose Paragraph or Table, respectively, in the pop-up menu.

2) On the Text Flow page of the Paragraph dialog (Figure 119) or the Table Format dialog
(Figure 120), select Insert (or Break for a table) and With Page Style. Set the Page Style
property to Landscape. Click OK to close the dialog and to apply the new page style.

=~

-
Paragraph
Indents & Spacing |Alignment | Text Flow Outine & Mumbering [Tabs |Drop Caps |Borders ||Background

Hyphenation
Breaks
Insert Type Fage v Position Befaore v
With Page Style Landscape v Page number |0 $
Options

Figure 119: Specifying a page break before a paragraph

- -,
Table Format

Table |Text Flow | Columns | Borders || Background
Text Flow
Break (%) Page ) Column
(%) Before () After
With Page Style Default Page number ] >
Allow table to split across pages atfifs:“ha
Allow row to break adross pagdFirst Fage
[ ] Keep with next paragraph ;?;Eggze -

Figure 120: Specifying a page break before a table

3) Paosition the cursor in the paragraph or table where the page is to return to portrait
orientation and change the paragraph properties or table properties so that With Page
Style is the portrait page style that was used before the Landscape page style.

4) Click OK to return to the previous portrait page style.

Ti If you need the headers or footers on the landscape pages to be in portrait
P orientation, see “Portrait headers on landscape pages” on page 147.

Adding title pages

Writer provides a fast and convenient way to add one or more title pages to a document and
optionally to restart the page number at 1 for the body of the document.

To begin, choose Format > Title Page from the Menu Bar. On the Title Page dialog (Figure 121),
you can make a variety of choices:
* Convert existing pages to title pages, or insert new title pages

* How many pages to convert or insert
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* Where those pages are located
* |If and where to restart page numbering, and what number to start with
* What page style to use for the title page

Using this technique, you can insert several “title pages” at different points in your document, for

example to add decorative pages between chapters as well as title, copyright, and other pages at
the beginning of a book.

-

.
Title Page
Make Title Pages
(¥} Converting existing pages to title pages!
{:} Insert new tite pages

Mumber of tile pages |1 ¥ pages
Flace title pages at  (*) Document Start
OpPage |4

Page Numbering
[ ] Reset Page Mumbering after title pages
Page number | 1
[ ] set Page Mumber for first tite page
Page number | 1

Edit Page Properties )
First Page W

ok || concel || e |

Figure 121: Adding title pages to a document

Changing page margins

You can change page margins in three ways:
* Using the page rulers—quick and easy, but does not have fine control.

* Using the Page Style dialog—can specify margins to two (fractional) decimal places.
* Using the Page panel of the Properties deck in the Sidebar.

Not If you change the margins using the rulers or the Sidebar, the new margins affect
Lz the page style and will be shown in the Page Style dialog the next time you open it.

To change margins using the rulers:

1) The shaded sections of the rulers are the margins (see Figure 122). Put the mouse cursor
over the line between the gray and white sections. The pointer turns into a double-headed
arrow and displays the current setting in a tool-tip.

2) Hold down the left mouse button and drag the mouse to move the margin.

Caution The small arrows on the ruler are .used for indenting paragraphs. They are often ir_l
the same place as the page margins, so you need to be careful to move the margin
A marker, not the arrows. The double-headed arrows shown in Figure 122 are actual
mouse cursors placed in the correct position.
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Figure 122: Moving the
margins
To change margins using the Page Style dialog (Figure 118):
1) Right-click anywhere on the page and select Page from the context menu.
2) On the Page page of the dialog, type the required distances in the Margins boxes.

To change margins using the Page panel of the Properties deck of the Sidebar:
1) On the open Sidebar (View > Sidebar) select the Properties tab.
2) Open the Page panel if is not open by clicking the plus (+) symbol in the panel title

3) Click the Margin button to open the sub-panel and enter the required dimensions in the
Custom size boxes (clicking the More Options button will open the Page Style dialog).

Using columns to define the page layout

You can use columns for page layout in the following ways:
* By defining the number of columns and their layout on a page, using page styles.
* By changing the number of columns for existing text.

Defining the columns on a page

It is a good idea to define your basic page style (such as Default) with the most common layout to
be used in your document, either single-column or multiple-column. You can then either define
extra page styles for pages with different numbers of columns or use sections (described in “Using
sections for page layout” starting on page 138) for pages or parts of pages with different numbers
of columns.

To define the number of columns on a page:

1) Choose Format > Columns to go to the Columns dialog (see Figure 123), or go to the
Columns page of the Page Style dialog, or click the More Options button on the Page
panel of the Properties deck of the Sidebar.

2) In the Settings section, choose the number of columns and specify any spacing between
the columns and whether you want a vertical separator line to appear between the
columns. You can use one of Writer’s predefined column layouts, or you can create a
customized column layout. The preview pane, located to the right of the Settings section,
shows how the column layout will look.

Notice the Apply to box in the dialog of Figure 123. In this instance, the changes are being
applied to the Default page style.

3) Click OK to save the changes.
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Figure 123: Defining the number of columns on a page

Specifying the number of columns

In the Settings section, enter the number of columns into the Columns selection box, or select one
of the column layout icons.

Formatting column width and spacing
Select the AutoWidth option in the Width and spacing section to create columns of equal width.

To customize the width and spacing of the columns:
1) Inthe Width and spacing section, deselect the AutoWidth option.
2) In the Width selection boxes, enter a width for each column.
3) On the Spacing line, enter the amount of space that you want between each pair of
columns.

If you specify more than three columns, use the arrow keys on the Column line to scroll among the
columns.

Formatting separator lines
To display separator lines between the columns:
1) Using the Style drop-down list, select the line style from the three styles available.

2) Using the Width control, select the width of line to use, settable from 0.25pt to 9.0pt. (1 pt =
1 point = 1/12 pica = 1/72 inch = 127/360 mm = 0.3527 mm.)

3) Using the Height control, select the height of line required, as a percentage of the column
height. Variable from 25% to 100%.

4) If you entered a height of less than 100%, use the Position drop-down list to select a
vertical alignment for the separator lines. The vertical-positioning options are: Top,
Centered, or Bottom.

4) The line color can be selected from the Color drop-down list's palette of colors.
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To quickly input the maximum or minimum allowed value in an input box, click the
current value and press Page Up or Page Down respectively.

Tip
Reverting to a single-column layout

To revert to a single-column layout for the page style, go to the Settings section and either reset
the number in the Columns box to 1 or click the single-column layout icon.

Changing the number of columns for existing text

You might want some parts of a page to have one column and other parts of the page to have two
or more columns. For example, you might have a page-width headline over a three-column news
story.

You can create columns and then type or paste text into them, or you can select some existing text
and change the number of columns for displaying it.

When you select text and change the number of columns for that text (Format > Columns), Writer
turns the selected text into a section, as described in “Using sections for page layout” on page 138.

Figure 124 shows the Columns dialog for a selection. The Apply to box has Selection highlighted
and an extra option (Evenly distribute contents to all columns) appears in the Settings section.

e Sy
Columns
Columns
Apply to  |Selection |

Evenly distribute contents to all columns

Width and Spacing
Colurmn 1 2 3
Width 3496 346
Spacing 0.00% 5
AutoWidth
Separator line
Style  |-none - v Height 100%; Color | Elack

Figure 124: Specifying columns for a selection

You cannot select text on a two-column formatted page and change it to a single
Tip column using this method. Instead, you need to define a single-column page and
then select the text you want to be in a two-column section on that page.
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Distributing text across columns

As you add text to the section, you will see that the text flows from one column to the next. You can
distribute text across the columns in one of two ways:

Evenly—Writer adjusts the length of the columns to the amount of text, so that all the columns
are approximately the same height. As you add or delete text, the columns readjust.

Newspaper-style—Writer fills the columns one at a time, beginning with the first column. The
last column may be shorter than the others.

To distribute text evenly, select the Evenly distribute contents to all columns option in the
Settings area. Deselect this option if you want to distribute text newspaper-style.

Choose View > Nonprinting Characters (or press Ctrl+F10) to display end of
Tip paragraph markers (). Often, unexpected behavior of columns is due to extra
paragraphs that are normally invisible to the user but are taking up space.

Example of evenly distributed columns Example of “snaking” or “newspaper” columns1{
Lorem ipsum dolor sit amet, clit. Donec fermentum lacinia quam, ac Lorem ipsum dolor sit amet, Vivamus pretium dui in arcu porttitor
consectetur adipiscing elit. Proin vitae egestas erat accumsan et. consectetur adipiscing elit. Proin vite sagittis. Vestibulum non magna elit.
odio quis ori placerat faucibus. Cras luctus horeet turpis, sit amet odio quis orci placerat faucibus. Cras hendrerit nisi a arcu pharetra
IAencan in urna massa. Nam fougiat posucre leo cursus ac. Phasellus ultrices Acnean in uma massa. Nam feugiat accumsan. Proin euismod iaculis sem id
tincidunt massa nec mollis. Morbinon o mmodo quam auctor dicum. Cras tincidunt massa nec mollis. Morbi non | fringilla. Maccenas vitac ligula et nulla
diam id lorem posucre placerat uma ligula, fringilla id ultricics diam id lorem posuere placerat. scelerisque cuismod. Etiam maitis
Suspendisse potenti. In consectetur thoneus, venenatis consectetur quam Suspendisse potenti. In consectetur fringilla pharera. Aliquam purus nulk,
aliquam libero at laoreet. Pellentesque | Aliquam diam nisi, aliquam sed iaculis aliquam libero at laoreet. Pellentesque | malesuada quis tincidunt id, scelerisque
mattis lobortis consequat. Ut tincidunt in, fempus eu tortor. Donec eleifend mattis lobortis consequat. Ut tincidunt at ipsum. Maecenas urna odio, cursus
nunc leo, at tincidunt quam. Donec phicerat ipsum in suscipit. Etiam at nunc leo, at tincidunt quam. Donec eu faucibus vehicula, fringilla id metus.§
augue massa, vehicula et elementum a, | 1l mi, at tincidunt sem. Aenean mi augue massa, vehicula et clementum a, ]
facilisis vel odio. Pellentesque habitant | erat, adipiscing ac vestibulum id, facilisis vel odio. Pellentesque habiant
‘morbi tristique senectus et netus et porttitor ac ante. morbi tristique senectus et nefus et

‘malesuada fames ac turpis egestas malesuada fames ac tumis eges@s §

Vivamus pretium dui in arcu portti tor

Pracsent eu turpis et nunc scelerisque  sagittis, Vestbulum non magna clit Pracsent eu trpis et nunc scelerisque

fringilla id sit amet arcu. Nunc omare | Cras hendrerit nisi a arcu pharetra fringilla id sit amet arcu. Nunc omare
faucibus risus, eget congue ipsum accumsan. Proin cuismod iaculis sem id fm‘l]mbuilnsus. et congue psun
sollicitudin ac. Curabitur mauris fortor,  fringilla, Maecenas vitae ligula et nulla sollicitudin :lcrkCllm "Hrm:m}s fortor,
consequat eu clementum non, feugial | scelerisque euismod. Etiam mattis consequat e ementum non fougiat
imperdiet lacus. Aliquam felis diam, fringilla pharctra. Aliquam purus nulla, fropendict lacus. Aliquam £1% dom,
placerata laorect in, vulputate viae malesuada quis tincidunt id, scelerisque D e D e
velit. Morbi rhoncus aliquet nisl, eget | gt ipsum. Maccenas urna odio, cursus et Mara rhoncus 2 kquct mis , °8°

Sagitts dolor tristique at. Lorem ipsum
sagittis dolor tristique at. Lorem ipsum o, faycibus vehicula, fringilla id metus § “ N "

lolor sitamet, consectenr adipiscing dolor sit amet, consectetr adipiscing

1 elit. Donec fermentum lacinia quam, ac
egesas erat accumsan et. §

Cras luctus laoreet rpis, sit amet
posuere leo cursus ac. Phasellus ultrices
commodo quam auctor dictum. Cras
uma ligula, fringilla id ultricies
rhoncus, venenatis consectetur quam.
Aliquam diam nisi, aliquam sed iaculis
in, tempus eu toror. Donec eleifend
placerat ipsum in suscipit. Etiam at
nulla mi, at tincidunt sem. Aenean mi
erat, adipiscing ac vestibulum id,
porttitor ac ante. §

Figure 125: (Left) Evenly distributed columns; (Right) Newspaper-style columns.

Using frames for page layout

Frames can be very useful when producing a newsletter or other layout-intensive documents.
Frames can contain text, tables, multiple columns, pictures, and other objects.

Use frames when you need to:

* Position something in a particular place on a page, for example, a logo or a “stop press”
news box in one corner of a page.

* Allow text on one page to continue on another page, somewhere more distant than the next
one, by linking the content of one frame to another so the contents flow between them as
you edit the text.

* Wrap text around an object, such as a photograph.
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Because LibreOffice does not allow you to define page styles with recurring frames, consider doing
some quick sketches of the basic page layouts you need, indicating the approximate positions of
different frames and their purposes. Try to keep the number of different page layouts as low as
possible in order to avoid chaos in your design.

Pay special attention to the positioning of frames. Many of the predefined styles default to a center
alignment. Although centering all frames looks reasonably good in most cases, it is rarely the best
choice.

One of the most visually effective ways to position a frame is to align its left margin with that of the
paragraph above it. To achieve this effect, the frame is inserted in a blank paragraph of the same
style as the paragraph above. Select Insert > Frame; in the Position section of the Type page,
select From Left in the Horizontal selection box to position the frame exactly where you want it.

You also should think about the type of wrap and the spacing between the frame and text. Instead
of cramming a frame close to the text, use the Wrap tab to place some white space between them.

You can format frames individually or define and apply frame styles; see Chapter 7, Working with
Styles.

Example: Using a frame to center text on a page

Although you can center text horizontally as part of a paragraph style or by using manual
formatting, those methods do not work for vertical centering. To center text vertically, you need to
place the text in a frame, anchor the frame to a page or a paragraph, and then center the frame
vertically on the page. See “Anchoring frames” on page 133.

Creating frames

You can create a frame in several ways, depending on your needs.

* Choose Insert > Frame to create an empty frame. The Frame dialog (Figure 127) appears.
You can click OK and come back to customize it later, or you can set the frame’s
characteristics at this stage.

* Select text or a graphic, choose Insert > Frame, and click OK to create a frame containing
the selection. The selected text is automatically deleted from the normal text flow and
inserted into the frame, and the Frame dialog appears.

* Insert a picture or other object by selecting Insert > Image > From file or Insert > Object
> [type of object] to start the process to insert a picture or object. The item inserted
automatically appears in a frame, but the Frame dialog does not appear.

* Select the Insert Frame Manually button on the Insert toolbar (go to View > Toolbars >
Insert to display it), select the number of frames in the drop-down menu, the mouse cursor
changes to a plus (+) symbol, click and drag the mouse to draw the frame.

BE-B-0-B¢HM0|k - - 2BHEe

Insert Frame Manually

W2

Figure 126: Using a button on the Insert toolbar to create a frame
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Releasing the mouse button creates the frame: an area isolated from the =,
main document. T

To add content to a frame, first deselect the frame by clicking somewhere

else on the page. Then, click inside the frame to place the text cursor o

there. Now add content just like you would on the main page. When you are done, deselect the
frame.

Moving, resizing, and changing frame attributes

When an object is added to Writer, it is automatically enclosed in a frame of a predetermined type.
The frame sets how the object is placed on the page, as well as how it interacts with other
elements in the document. You can edit the frame by modifying the frame style it uses or by using
a manual override when a frame is added to the document. Frame styles are discussed in Chapter
7, Working with Styles.

To change the size or location of a frame, first select the frame, then use either the mouse or the
Frame dialog (Figure 127). Using the mouse is quicker but less accurate. You might want to use
the mouse for gross layout and the dialog for fine-tuning.

o+ = 1

Frame
Type |Options || Wrap || Hyperlink || Borders | Background || Columns || Macro
Size Anchar
Width 151" /& (O To page
[ ] Relative {(¥) To paragraph
[] Automatic ) To character =
Height (at least) 071" = () As character
[] relative
AutoSize
|:| kKeep ratio
Position
Haorizontal From left »| by |0.107 i to Faragraph area w
|:| Mirror on even pages
Vertical From top | by |0.327 34| to |Margin V

[ ] Follow text flow

Figure 127: Frame dialog

You can re-size the frame manually by clicking on the green squares (sizing handles) and dragging
to the appropriate size, or start adding content to it (the frame will re-size automatically if, for
example, you add a large picture to it) or go back to the Frame dialog and set the size and other
characteristics.

To change the location of the frame using the mouse, drag and drop one of the edges or put the
cursor anywhere within the frame. (The I-bar cursor changes to a four-headed arrow when properly
positioned for a drag-and-drop move.)

To change the size of the frame, drag one of the sizing handles. Drag a handle on one of the sides
to enlarge or reduce the text frame in one dimension only; drag a corner handle to enlarge or
reduce it in both dimensions.
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These resizing actions distort the proportions of the frame. Holding down the Shift key while
dragging one of the handles makes the frame keep the same proportions.

You can open the Frame dialog at any time by selecting the frame, right-clicking, and choosing
Frame from the context menu.

To remove the default border on a newly created frame, open the Frame dialog, go to the Borders
page, and in the Style box under Line, select None. Alternatively, you can assign a borderless
style to the frame; see Chapter 7, Working with Styles, for information on frame styles.

Do not confuse a frame’s border with the text boundaries that are made visible using

Note the View menu (by selecting View > Text Boundaries).
[ Sy
Frame
Type | Options | Wrap |[Hyperlink |[Borders Background |Columns |Macra
Line arrangement Line Spacing to contents

Default Style Le 1,06

[0 50} - none - > Right |0.08

Lt -defined Width Ton 5

Set No Borders 0.05pt = -
Color - :
I Elack ~| e

Figure 128: Removing the border from a frame

Anchoring frames

Using the Frame dialog (or by right-clicking and pointing to Anchor), you can anchor a frame to a
page, paragraph, or character, or you can anchor it as a character.

To Page
The frame keeps the same position in relation to the page margins. It does not move as you
add or delete text. This method is useful when the frame does not need to be visually
associated with a particular piece of text. It is often used when producing newsletters or other
documents that are very layout-intensive. This method is also used to center text on a page.

To Paragraph
The frame is associated with a paragraph and moves with the paragraph. It may be placed in
the margin or another location. This method is useful as an alternative to a table for placing
icons beside paragraphs. It is also used to center text on a page in documents which will be
used in a master document (frames anchored to pages will disappear from the master
document).

To Character
The frame is associated with a character but is not in the text sequence. It moves with the
paragraph but may be placed in the margin or another location. This method is similar to
anchoring to a paragraph.
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As Character
The frame is placed in the document like any other character and, therefore, affects the height
of the text line and the line break. The frame moves with the paragraph as you add or delete
text before the paragraph. This method is useful for adding a small icon in sequence in a
sentence. It is also the best method for anchoring a graphic to an empty paragraph so it does
not move around the page in unexpected ways.

Linking frames

You can link frames to each other even when they are on different pages of a document. The
contents will automatically flow from one to the next. This technique is very useful when designing
newsletters, where articles may need to be continued on a different page.

Note You cannot link from a frame to more than one other frame.

To link one frame to another:
1) Select the frame to be linked from.

2) Click the Link Frames button ( # ) on the Frames toolbar.
3) Click the next frame in the series (which must be empty).

When a linked frame is selected, any existing links are indicated by a faint connecting line, as

shown in Figure 129. Frames can be unlinked by selecting the Unlink Frames button ( Ba ) on the
Frames toolbar.

=]

o

Figure 129: Linked frames

The height of a frame that is being linked from is fixed; you can change this height manually or by
using the Frame dialog, but it does not automatically adjust to the size of the contents (that is, the
AutoHeight attribute is disabled). Only the last frame of a chain can adapt its height to the content.

The Options page of the Frame dialog (Figure 130) shows the names of the selected frame and
any frames it is linked to or from. You can change this information here. On this page, you can also
select options to protect the contents, position, and size of the frame.
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Frame

Type |Options |\Wrap | Hyperlink | Borders | Background | Columns || Macro

Mame Frame1

Brevious link “Mone

Mext link Frame2

Protect
|:| Contents

|:| Pasition
|:| Size
Properties
[ ] Editable in read-only document
Print

Text direction |z superordinate object settings

Figure 130: Options page of the Frame dialog

On the Hyperlink page (Figure 131), you can specify the file for the hyperlink to open. This file can

be on your machine, a network, or the Internet.

Type ||Options | Wrap |Hyperlink Borders |Background ||Columns |Macrao
Link to

Mame HyperTest
Frame | v

Image map

|:| Server-side image map

ent-side image map

I3

Figure 131: Hyperlink page of the Frame dialog

To open this file, you must Ctrl+click in the area between the border and the text boundary. Note
that as the mouse cursor moves over any area within the frame boundary the hyperlink tooltip will

be displayed, but it will only be active at the edges.

by

The Wrap, Borders, Background, Columns, and Macro pages of the Frame dialog are the same as

those for frame styles. Refer to the Chapter 7, Working with Styles, for details.

LIRL file:/{{C: [Documents and Settings/Pat and John/DesktopHy
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Using tables for page layout

Writer’s tables can serve several purposes, such as holding data as you might see itin a
spreadsheet, lining up material, and creating more complex page layouts. For information about
using tables of data, see Chapter 9, Working with Tables.

This topic describes how to achieve some common layouts by using tables.

Example: Creating sideheads using tables

Sideheads and marginal notes are commonly used in documents from resumes to computer user
guides. The main body of the text is offset to leave white space (usually on the left-hand side) in
which the sideheads or notes are placed. The first paragraph is aligned beside the sidehead, as in

Figure 132.

Example of a
sidehead

In some cases you may want to put only one or two paragraphs in the table itself
and the rest of the text and graphics in ordinary paragraphs (formatted to line up
with the paragraphs in the table) so that text and graphics will flow more easily from
one page to another when you add or delete material.

In other cases, you might put each paragraph in a separate row of the table and
allow the table to break between pages.

Figure 132: Example of a sidehead

Note

Sideheads can also be created by placing text in a frame using the Marginalia
frame style, as described in Chapter 7, Working with Styles.

To create a table for use with a sidehead:
1) Place the cursor where you want the table to appear and choose Insert > Table (Cirl+F12).

2) In the Insert Table dialog, define a one-row, two-column table with no border and no
heading. Click Insert to create the table.

Insert Table

General

MName: Sidehead1

Columns: |2 £

Options
[]Heading
Heading Rows:

[] pon't split table over pages
Border

Repeat Heading Rows on new pa

rJ
[4»

AutoFormat

Help ] I Insert

[=m

Figure 133: Defining a two-column borderless

table with no header
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3) Right-click on the table and choose Table from the context menu. On the Columns page of
the Table Format dialog, make the columns the required width.

Table Format

Table [ Text Flow | Columns  Borders |Background

-

A

=t tahle wid A

Remaining space  |0.00"

Column width
1

5]
I
I

|

1207 % |5.73 %

Figure 134: Defining a two-column table to line up with text offset at 1.2 inches

4) On the Table page of the Table Format dialog (Figure 135), in the Spacing section, make
the Above and Below values the same as the Top and Bottom spacing you have defined for
ordinary paragraphs of text. Click OK to save your settings.

To check the top and bottom spacing for ordinary paragraphs:

1) Position the cursor in a paragraph and press F11 (unless the Styles and
Formatting window is already open). Check that the Styles and Formatting
window shows paragraph styles (top left button).

Tip 2) The current style should be highlighted. If no paragraph style is highlighted,

select All Styles in the bottom drop-down list. Right-click on it and select
Modify from the pop-up list.

3) Go to the Indents & Spacing page and look in the Spacing area for the values
in Above paragraph and Below paragraph.

- "y
Table Format
Table Text Flow |Columns |[Borders |[Background

Properties Alignment

Mame | Sideheadl ) Automatic

dth e e O Left
- B ) From left

Spacing " Right

Left  |g.00 ) Center

Rigl ) Manual

Above 0,10 =

Below |0.107 £

Figure 135: Defining the space above and below a table

You may also want to turn off number recognition so that Writer will not try to format numbers if you
want them to be plain text. To turn number recognition off:

1) Right-click in the table and then click Number Format on the context menu.
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2) On the Format Number dialog, make sure the Category is set to Text. Click OK.

If you use this table format often, you may want to save it as AutoText, as
Tip described in Chapter 3, Working with Text. Select the table (not just the contents)
to assign the shortcut.

P S

Format Mumber

Category Format Language

Percent ~ 2 Default - English (USA) hd
Currency o
Date
Time
Scientific
Fraction
Boolean Value | 0
Text el

Figure 136: Setting number format to Text

Using sections for page layout

A section is a block of text that has special attributes and formatting. You can use sections to:
* Write-protect text
* Hide text
* Dynamically insert the contents of another document

* Add columns, margin indents, a background color, or a background graphic to a portion of
your document

* Customize the footnotes and endnotes for a portion of your document

Creating sections

To create a section:

1) Place the cursor at the point in your document where you want to insert the new section.
Or, select the text that you want to place in the new section.

2) From the Menu Bar, choose Insert > Section. The Insert Section dialog opens.
3) Choose settings for each page of the dialog as required.
4) Click Insert.
The Insert Section dialog has five tabbed pages.
* Use the Section page to set the section’s attributes.
* Use the Columns page to format the section into columns.
* Use the Indents page to set indents from the right and left margins of the section.
* Use the Background page to add color or a graphic to the section’s background.

* Use the Footnotes/Endnotes page to customize the section’s footnotes and endnotes.
At any time before closing the dialog, you can reset a tabbed page to its default settings by clicking

the Reset button. (Note, however, that you cannot reset the Section page. If you wish to undo
changes to the Section page, you must do so manually).

138 LibreOffice 4.2 Writer Guide



L oy

Insert Section

Section | Columns | Indents || Background | Footnotes/Endnotes

Mew section Link
Section [ Link

Write protection
[ ] Protect

Hide

[ ] Hide

Properties
[ ] Editable in read-only document

[ Insert H Cancel H Help ][ Reset

Figure 137: Inserting a section using the Insert Section dialog

Naming sections

Writer automatically enters a hame for the section in the name box of the New section list box. To
change the name, select it and type over it. The name is displayed in the Sections category of the
Navigator window. If you give your sections meaningful names, you can navigate to them more
easily.

Linking sections
You can insert the contents of another document into the section and then have Writer update it
whenever the other document is updated. This is called linking the section to the other document.
To link the section to another document, follow these steps:

1) Inthe Link section of the dialog, select the Link option.

Link
Link
(] oog
File name file:/{/C: fDocuments and Setting E
Section Section1 V

Figure 138: Linking sections

2) Click the (...) button to the right of the File name field. The Insert dialog opens.

3) Find and select the document you want to insert and then click the Insert button. The Insert
dialog closes and the name of the selected document appears in the File name field.

4) If you want to insert only a section of the selected document, select the desired section
from the Section drop-down list.
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The section must already exist in the selected document. You cannot create a

Note section in the selected document at this point.

You can update links automatically or manually. See “Updating links” on page 144.

Write-protecting sections

To write-protect the section so that its contents cannot be edited, select the Protect option in the
Write protection area.

Write protection

[ ] with password E

Figure 139: Write-protecting sections

Note Write-protection protects only the section’s contents, not its attributes or format.

Password-protecting sections

To prevent others from editing the section’s attributes or format, additionally protect the section with
a password, as follows:

1) Select the With password option. The Enter Password dialog opens.

2) Type a password in the Password field and then confirm the password by typing it again in
the Confirm field.

3) Click OK. The Enter Password dialog closes. Anyone who tries to edit the section’s
attributes or format will be prompted to enter the password.

-

Enter Password

Password

xxxxxxx

Password:

Confirm:

(Mirimum 5 characters)

wp || ok | concel

Figure 140: Password-protecting a section

Hiding sections

You can hide the section so that it will not be displayed on the screen or printed. You can also
specify conditions for hiding the section. For example, you can hide the section only from certain
users.

You cannot hide a section if it is the only content on the page or if the section is in

Note a header, footer, footnote, endnote, frame, or table cell.

To hide a section, select the Hide option in the Hide section of the dialog.
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Hide

With Condition

Figure 141: Hiding sections

To hide the section only under certain conditions, enter the desired conditions in the With Condition
field. The syntax and operators that you use to enter conditions are the same ones that you use to
enter formulas. For syntax and a list of operators, see Writer’'s online help under conditions.

If the section is write-protected with a password, the password must be entered to hide or reveal
the text.

Hiding text can be useful for printed documents, if for example you have an instruction manual for
two widgets, Model A and Model B which are very similar. By setting a condition for, say, Model A
widget, you can hide that text which only applies to Model B, before printing it.

Hiding text is not a secure way to stop someone else reading it. It will stop the
Note casual reader but will not prevent someone who actively wants to find out what you
have hidden—even if it is password protected.

Formatting a section into columns

Use the Columns page of the Insert Section dialog to format the section into columns. This page is
very similar to the Columns dialog shown in Figure 124 on page 129. Please refer to that topic for
details.

Indenting the section from margins
Use the Indents page (Figure 142), to set indents from the right and left margins of the section.

[ Ty
Insert Section
Section | Columns |Indents | Background | Footnotes/Endnotes
Indent
Before section 0.60" s
After section 1.20° i

Figure 142: Indenting sections

Enter the desired left-margin indent in the Before section box. Enter the desired right-margin indent
in the After section box. The preview box on the right-hand side of the page shows you how the
section will look with the indents applied.

Changing the background of the section

Use the Background page to add color or a graphic to the background of the current section. This
page is similar to the Background pages for paragraphs, frames, tables, and other objects in
LibreOffice. For more information, refer to Chapter 7, Working with Styles.

Chapter 4 Formatting Pages 141



Customizing footnotes and endnotes in a section
Use the Footnotes/Endnotes page to customize the current section’s footnotes and endnotes.

-

Insert Section

Section ||Columns [Indents |Background |Footnotes Endnotes

Footnotes
Collect at end of text
Restart numbering

Startat: |1 e
Custom format
Before: |Mote 1,2, 3 ... V After:

Endnotes
Collect at end of section
Restart numbering

Startat: |1 £
Custom format
Before: | Note i, i, i, ... v| After:

Figure 143: Setting footnotes and endnotes for sections

Customizing footnotes

If you want the section’s footnotes to appear separately from the other footnotes in the document,
select the Collect at end of text option in the Footnotes area.

To number the section’s footnotes separately from the other footnotes in the document, and format
the numbering, follow these steps:

1) Inthe Footnotes section of the page, make sure that the Collect at end of text option is
selected.

2) Select the Restart numbering option.

3) If you want the section’s footnotes to start at a number other than 1, enter the desired
starting number in the Start at number box.

4) Select the Custom format option.
5) From the drop-down list of the Custom format option, select a numbering format for the
footnotes.

To add text to the selected numbering format, use the Before and After text input boxes. For
example, if you want the footnote numbers to be preceded by the word “Note” and followed by a
colon, fill the Before and After fields as shown in Figure 143.

Customizing endnotes
If you want the section’s endnotes to appear at the end of the section rather than at the end of the
document, select the Collect at end of section option in the Endnotes area.

To number the current section’s endnotes separately from the other endnotes in the document, and
format the numbering, apply the procedures described above to the Endnotes settings.
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Saving a hew section

To save a new section so that it appears in your document, click the Insert button. The Insert
Section dialog closes and the new section appears in your document.

Editing and deleting sections

To edit a section, follow these steps:

1) From the Menu Bar, choose Format > Sections. The Edit Sections dialog (Figure 144)
opens.

2) Select the section you want to edit by clicking its name in the list box.

Editing section attributes
To rename the selected section, simply type over its name in the Section name box.
From the Edit Sections dialog, you can also edit the selected section’s link, write-protect, and hide
attributes. To learn how to edit these attributes, see:
“Linking sections” on page 139.
“Write-protecting sections” on page 140.
“Hiding sections” on page 140.

-~

.
Edit Sections
Section Link
. [ ok |
Section2 Link
., Section2 :
Fil le: ff{C: (Documents and 5 Options. ..
. Section3 E=r=rE Fle:/f(C:/D s E]
Write tecti
[ ] Protected
Nith password
Hide
[ Hide
Properties

[ ] Editable in read-only document

Figure 144: Edit Sections dialog

Editing the format of a section
To edit the format of the selected section, click the Options button.

The Options dialog has four tabbed pages: Columns, Indents, Background, and
Footnotes/Endnotes. The use of these pages is described earlier in this topic.

To reset a page to the conditions in place when the dialog opened, click the Reset button.

To save your Options settings and return to the Edit Sections dialog, click OK.

~
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Width and spacing
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AutoWidth
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Separator line
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Figure 145: Options dialog for sections

Deleting sections

To delete the selected section, click the Remove button.

Note Cancel button.

Writer will not prompt you to confirm the deletion. To undo a deletion, click the

Updating links

You can set Writer to update linked sections automatically, and you can also update links manually.

Updating links automatically

To set Writer to update links without prompting you, or to turn off automatic updating, follow these

steps:

1) Choose Tools > Options > LibreOffice Writer > General. The dialog displays general text

document settings.

2) In the Update section of the dialog, under Update links when loading, select one of the

following three options:

Update
Update links when loading
) Always
{f} On request

{:} Mewver

Automatically
Fields
Charts
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* Select Always if you want Writer to update links automatically, without prompting you,
whenever you open a document that contains links.

* Select On request if you want Writer to prompt you before updating links.
* Select Never if you do not want Writer to update links.

3) Click OK to save your settings. The Options dialog closes.

Updating links manually

A protected section cannot be updated manually. It must first be unprotected.
To update a link manually:

1) Open the document that contains the link.

2) Choose Edit > Links. The Edit Links dialog opens.

3) The list in the Edit Links dialog displays the names of all the files that are linked to the
current document. Click the file that corresponds to the link that you want to update.

4) Click the Update button. The most recently saved contents of the linked file appear in the
current document.

5) To close the Edit Links dialog, click Close.

Edit Links
Source file Element: Type Status [ Close ]
file: f{CLOheader. png <Al formats > Image Manual [ I ]

Help
[ Update |
| wodify... |
[ Break Link ]
Source file file: f{{C: LOheader.png
Element: <Al formats >
Type: Image
Update: Automatic Manua

Figure 146: Edit Links dialog

Creating headers and footers

Headers are portions of a document that always appear at the top of a page; footers appear at the
bottom of a page. Typically, headers display the title or chapter name of a document.

In LibreOffice, headers are specified by page styles; therefore, when inserted, all the pages with
the same page style will display the same header. The option to make the header/footer on the first
page of a document different is available (see “Defining a different first page for a document” on
page 123). Chapter 7 describes how to format a header as part of the page style formatting. For
the purpose of this example, we will insert a header in the Default pages using manual formatting.

There are two ways to insert a header. The simplest method is to click above the top of the text
area, then when the Header marker appears (Figure 135), click on the +. (To insert a footer, click
below the bottom of the text area to display the Footer marker, and then click on the +.)
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What is Write I'”TI [Header (0OcPagestyle) ]

Wiriter is the word processor component of LibreOffice. In addition to the usual features of a word
processor (spelling check, thesaurus, hyphenation, autocorrect, find and replace, automatic
generation of tables of contents and indexes, mail merge and others), Writer provides these

Figure 147: Header marker at top of text area

Headers can also be inserted from the Menu Bar by selecting Insert > Header > [Page Style]. The
submenu lists the page styles used in your document. In addition, the submenu includes the entry
All, which activates headers on all the pages of the document regardless of their page style.

For our example, select the Default menu item to activate the headers only on the pages that use
the Default page style. Similarly, to insert a footer, choose Insert > Footer > [Page Style].

The Insert menu can also be used for deleting a preexisting header or footer for a
page style. If that page style has a check mark in front of it, it contains a

header/footer, and clicking on it opens a message box warning about deletion and
asks whether you want to delete the header or footer for that particular page style.

Note

Depending on which option you choose, an area will appear at the top or bottom of the page. In
this area you can enter text and graphics that will appear on every page unless Same content on
first page has been deselected..

L 1 &

Fun
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Page Header

The Old Salt

[ was walking through the Dockyard in a panic,
When I met a matelot old and grey.

Figure 148: A page with a page header

Items such as document titles, chapter titles, and page numbers, which often go into headers and
footers, are best added as fields. That way, if something changes, the headers and footers are all
updated automatically.

Fields are covered in Chapter 14, Working with Fields, but one example here may be useful. To
insert the document title into the header on a Default page style:

1) Select File > Properties > Description, enter a title for your document in the Title area,
and click OK to close the dialog.

2) Add a header (Insert > Header > Default).
3) Place the cursor in the header part of the page.

4) Select Insert > Fields > Title. The title should appear on a gray background (which does
not show when printed and can be turned off).

5) To change the title of the document, reselect File > Properties > Description and edit.
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Formatting headers and footers

In Writer headers and footers are considered paragraphs and therefore you can format the header
or footer text using the same techniques you use for formatting text in the main body of the
document.

You can define styles for headers and footers so that you can quickly obtain a
. consistent formatting in case you use several page styles. Writer includes three
Tip named header and footer styles: header/footer, left header/footer styles, and right
header/footer styles. All six are identical and are available for the user to modify.

You can format the layout of headers and footers using two different methods. The first method is
to use the Header or Footer markers that appear within headers and footers.

For example, to use the Header marker:

1) Click the top of the page. The blue Header marker will appear.

2) Click the plus sign in the Header marker. The plus sign will change to a down arrow.

3) Click the down arrow.

4) Select Format Header. This opens the Page Style dialog where you can change the
margins, spacing, and height.

5) Click More to open the Border/Background dialog where you can add borders, background
colors, and background images to the header.

You can also format headers and footers by modifying the page style at Format > Page > Header.

Caution Do not use the Background and Borders tabs on the Page Style dialog to format
headers. Style choices selected from those tabs will apply to the entire page rather
than to the header.

Portrait headers on landscape pages

When you define a header and footer on a landscape page, they will be aligned with the long side
of the page. If your landscape pages are going to be inserted between portrait pages, you might
want the headers and footers to be on the short sides of the landscape pages, so the final printed
product looks like the contents of the landscape pages have been rotated 90 degrees on portrait
pages.

You can set up portrait headers and footers on landscape pages by using a trick involving frames.
These are a bit tedious to set up, but once you have done so, you can copy and paste them to
other landscape pages. This cannot be made part of the landscape page style. In the following
example we want to insert a landscape page into our printed document, to have the same header
and footer, and margins, as our portrait pages. We will use an A4 page size here.

To set up portrait headers and footers on landscape pages:

1) Note the margin settings for the portrait page which is the same as the landscape page will
be, that is to say, for a right landscape page, the settings from a right portrait page (see the
table)

We now need to make the landscape right and left margins 1 cm larger than the portrait top
and bottom margins, respectively. This difference allows for the extra space used by the
portrait header and footer (0.5 cm for the height of the header or footer and a 0.5 cm gap
between the header or footer and the main text).
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Portrait page (right page) Landscape page (right page)

Top margin 1.5cm Right margin 2.5cm
Bottom margin 1.5cm Left margin 2.5cm
Left (inner) margin 2.8cm Top margin 2.8cm
Right (outer) margin 1.8cm Bottom margin 1.8 cm

2) We will continue this example setting the frame for the footer. The procedure is the same
for doing the header. Apply these margin settings in the Landscape page style.

3) Copy and paste the footer from the portrait page into a blank paragraph in the text. Paste
or move it into the landscape page. This text will then have the Footer style so the typeface,
font size, and tab settings will match.

Instructions on how to set up a footer. Page 1 of 2

Instructions on how to set up a footer. Page 1 of 2

Figure 149: Copy the footer, paste, and select it.

4) Select the text (including the fields) you just entered. Choose Format > Character. On the
Character dialog, choose the Position tab and set Rotation / scaling to 270 degrees
(counterclockwise). Note in the preview pane that the tabs are removed in this process.
Click OK.

Character

Font || Font Effects |Position | Hyperlink | Background

Position
'f:} Superscript
(%) Mormal
() Subscript

Rotation [ scaling

() 0 degrees ) 90 degrees () 270 degrees! [ Fit to line
Scale width 100% &

Figure 150: Rotating the footer text 270 degrees

5) With the text still selected, choose Insert > Frame. In the Frame dialog, select the Type tab
and enter the width, height, and horizontal and vertical position for the footer. Deselect the
Automatic options in Width and Height if they are selected.

* The width is the footer height taken from the Footer page of the portrait page style
dialog.

* The frame height is obtained by simple arithmetic. The A4 page-width is 21cm, minus
the sum of the top and bottom margins of 2.8cm and 1.8cm resulting in a frame height
of 16.4cm.

* The horizontal position is the portrait page bottom margin.
* The vertical position is the landscape page top margin.

148 LibreOffice 4.2 Writer Guide



-

Frame

Type bpﬁuns Wrap |Hyperlink |[Borders | Background |Columns |Macro

Size

[]Rrelative
|:| Automatic

] relative
[] autosize
|:| Keep ratio

Width 0.50cm| (4

Height 16.40cm (4]

Anchar
) To page
{%) To paragraph
) To character
) As character

Pasition

Horizontal |Fr|:|m left

|:| Mirror on even pages

Vertical |Fr|:|m top

[ ] Follow text flow

1.50em (3] to

2.80am 2] to

|LEﬂ: page border

|

|En1jre page

]

Figure 151: Defining the size and position of the footer frame

6) If your footer has a line above the text, as in this book, on the Borders page, select a right
border and specify the line width and spacing to the frame’s contents.

7) Click OK to save these settings. The footer will now appear in the required position and
orientation. Any fields will update.

Because tabs have been removed, insert the cursor in the frame, at the end of the text where the
tab was, and insert as many spaces using the keyboard space bar, as you require for the layout to

match that on the portrait page.

Repeat these steps (using appropriate settings) to set up a portrait header on the landscape page.

Caution

Make sure to return to the paragraph in the document from which you rotated the
text, and return it to 0 degrees, or any text typed in this location will rotate.
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Figure 152: Footers in place for both page styles

Numbering pages

This section describes techniques to insert page numbers and related information in a document.
Some basic knowledge of page styles, which are fully described in chapters 6 and 7, may be
needed to follow some of the examples given.

Preliminaries: fields

LibreOffice uses fields to manage page numbers. To insert a page number field, position the cursor
where you want to insert the number and choose Insert > Fields > Page Number. The page
number appears with a gray background. The gray background denotes a field; although it is
visible on screen, it is not printed.

Ti If you wish to turn off the gray background, choose View > Field Shadings (or
Ip press Ctrl+F8).

The page number field always displays the page number for the page where it is placed. If you see
the words “Page number” instead of a number, press Ctr/+F9. This shortcut key toggles LibreOffice
between displaying the Field Name (the variable) and the field’s result (the data in the variable).

Note For a full introduction to fields, see Chapter 14, Working with Fields.
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Preliminaries: insert and format a header

For the purpose of this example, we will insert a header in the Default page style pages using

manual formatting. See “Creating headers and footers” on page 145.

Simple page numbering

The simplest case is to have the page number at the top of every page and nothing more. To do

this, put the cursor on the header and select Insert > Fields > Page Number.

L 12 D203 .4.005 6.0 -7-:-8 1.9 1
The Old Salt

I was walking through the Dockyard in a panic,
When I met a matelot old and grey.

Upon his back he had his kitbag and his hammock,
And this is what [ heard him say.

-

Figure 153: Page number inserted in the header

Now the correct page number appears on every page.

Combining header text and page number

There are a lot of interesting variations that you can apply without further knowledge of page

styles. Here are some suggestions:
* Right-align the header to make the page number appear on the top-right.

Type the word page before the page number field so the header reads page 1, page 2,
and so on. This also requires using the Page Number field, discussed earlier (page 150).

Add the document title so the header reads, for example: Peter's Favourite Poems, left
justified, and page x with right justification, where x is the value of the Page Number field.
Consider using a (right-aligned) tab to separate the title from the page number.

LibreOffice also has a Page Count field (Insert > Fields > Page Count). Using it, you
could, for example, have a header that reads page 2 of 12.

These variations are all illustrated in Figure 154.

5 1 g L 2 L - L N E = L _ L : £ g J! dl 12
Peter's Favourite Poems Page 1 of 4
The Old Salt

[ was walking through the Dockyard in a panic,

When I met a matelot old and grey.

Upon his back he had his kitbag and his hammock,
- And this is what I heard him say.

Figure 154: Variations on the simple page numbering method
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Changing the number format

Many more variations are possible. For example, you can set the page number to display in
Roman numerals. To do that, you can double-click on the page humber and select the desired
format; however, a better choice is to specify the format of numbers in the page style as explained
here.

Right-click in the text area of the page and select Page from the context menu.

On the Page page of the Page Style dialog, in the Layout settings section, select i, i, iii, .... from
the Format drop-down list to use lowercase numerals.

Layout settings

Page layout Right and l=ft w
Format 51: 2,3, ...
[ ] Register-true A B, C, ..

a b, c ..

I, II, 111, ...

iy iy iy .

1I 2| 3| T

Mone

Figure 155: Changing format of page numbers

Numbering the first page something other than 1

Sometimes you may want to start a document with a page number greater than 1. For example,
you may be writing a book, with each chapter in a separate file. Chapter 1 may start with page 1,
but Chapter 2 could begin with page 25 and Chapter 3 with page 51.

Follow these instructions to start the page numbering in a document at a number greater than 1.
(These instructions are for a page number in a footer, but you could use a header instead.)

Ti Do not set a starting page number that is an even number because you will end up
P with a blank page before the first page when you print the file or export it as a PDF.

1) Choose Insert > Footer > [page style] to activate the footer. If the page style already has
footers active, there will be a check mark against its name. In which case click in the footer
area of the page without clicking on the page style. If you do click the checked page style
name, select No in the warning dialog if you do not want to remove any footer text already
in place, or Yes if you do. Click in the footer area.

2) The cursor is now in the footer. To insert the page number, choose Insert > Fields > Page
Number. The page number will be 1.

3) Click in the first paragraph in the text area.

4) Choose Format > Paragraph (or right-click and choose Paragraph from the context
menu), to display the Paragraph dialog.

5) On the Text Flow page, in the Breaks section, select Insert and select Page in the Type
drop-down list. Select With Page Style and the page style you are using for the first page
of the document. Note that you are not inserting a page break, but a break in the page
numbering.

6) The Page number field is now active. Type the page number you want to start with. Click
OK to close the Paragraph dialog.
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Numbering pages by chapter

Technical documents often include the chapter number with the page number in the header or

footer. For example, 1-1, 1-2, 1-3, ...; 2-1, 2-2, 2-3, ...

To set up this type of page numbering in LibreOffice, you need to do three things:
1) Ensure that your chapter titles are all identified by the same paragraph style, for example,

the Heading1l style.

2) Use Tools > Outline Numbering to tell LibreOffice what paragraph style you are using for
Level 1 in your outline, and specify “1,2,3” in the Number box.

Outline Numbering
Numbering | Position
Lewvel Mumbering
1 Paragraph Style
% Heading 1
4 Mumber 1,2, 3 ..
5
6 Character Style Mone
7
8
° 5 tol
10 eparator
1-10 Before
After
Start at 1

FY
>

1 Heading 1
Heading 2
Heading 3
Heading 4
Heading 5
Heading 6
Heading 7
Heading &
Heading &
Heading 10

Figure 156: Specifying paragraph style and numbering for chapter titles

3) Insert the chapter number in your document. To do this:
a) Place the cursor in the header or footer just before the page number you inserted
earlier, and choose Insert > Fields > Other from the Menu Bar.

b) On the Fields dialog (Figure 157), go to the Document page. Select Chapter in the
Type list, Chapter humber in the Format list, and 1 in the Level box. Click Insert.

Fields

Type
Author
Chapter
Date
File name
Fage
Sender
Statistics
Templates
Time

Document | Cross-references | Functions | DocInformation

Variables | Database

Format

Chapter name

‘Chapter number

Chapter number and name
Chapter number without separa

I

<] >
Level

1 =
Insert l ’ Close l [ Help

Figure 157: Inserting a chapter number field
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c) Type a hyphen or other punctuation between the chapter number and the page
number.

For more information, see “Choosing paragraph styles for outline levels” and “Including chapter or
section information in page headers” in Chapter 7, Working with Styles.

Restarting page numbering

Often you will want to restart the page numbering at 1, for example, on the page following a title
page or a table of contents. In addition, many documents have the front matter (such as the table
of contents) numbered with Roman numerals and the main body of the document numbered in
Arabic numerals, starting with 1.

You can restart page numbering in two ways.
Method 1:

1)

2)
3)

4)
5)

6)
7

Place the cursor in the first paragraph of the new page (be aware a heading is a
paragraph).
Choose Format > Paragraph.

On the Text Flow page of the Paragraph dialog (Figure 119 on page 125), select Insert in
the Breaks area.

In the Type drop-down list, select Page.

In the Position drop-down list, select Before or After to position where you want to insert
the page numbering break.

Select With Page Style and specify the page style to use.
Specify the page number to start from and then click OK. This does not insert a new page.

Method 2:

1)
2)
3)

Place the cursor in the first paragraph of the new page.
Choose Insert > Manual break.
Page break is the default selected on the Insert Break dialog.

L y
Insert Break
") Line break
(¥} Page break
St
Default Style el

1 €2

Figure 158: Restarting page numbering after a manual page break

4) Choose the required page in the Style drop-down list.
5) Select Change page number.
6) Specify the page number to start from and then click OK. This does insert a new page.
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Example: Restart page numbering: a preface
A standard preface has the following properties:

Page numbers are displayed in Roman numerals (i, ii, iii, iv, ...).
After the preface, the document starts on a Default page.
The page number resets to 1, and the number format becomes Arabic (1, 2, 3, 4, ...).

Resetting the page number requires page breaks.

First, do the preliminary work for the Preface style:

1)
2)
3)
4)

5)

Create a new page style and name it Preface.

Set its Next Style to Preface because a preface could span multiple pages.

Add a header to Preface and insert the Page Number field. Make the page numbers
display as Roman numerals (i, ii, iii, iv, ...):

Open the page style window for Preface (if not already open) and click the Header tab.
Select Header on under Header.

Click the Page tab (Figure 159). Under Layout settings, in the Format drop-down list, set
the format to i, ii, iii, .... Click OK to close the dialog.

After the preface is written, we are ready to restart the page numbering in the main body of the
document to Arabic numerals. Follow these steps:

1)
2)
3)
4)
5)

Make an empty paragraph at the very end of the preface.
Put the cursor on the blank line.

Choose Insert > Manual Break.

Select Page break and choose the Default Style.

Select the Change page number option and set the new value to 1. Click OK to close the
dialog.

These settings are shown in Figure 158.

You cannot assign an odd page number to a left page or an even page number to

Note a right page. LibreOffice strongly adheres to the convention that odd page

numbers go on right-hand pages and even page numbers on left-hand pages.

Page Style: Preface

Organizer |Page | Background | Header |Footer | Borders | Columns | Footnote

Paper format

Format  [Ag v

Width 8,27 i

Height 11.69" e

Orientation {?} Portrait

() Landscape Paper tray [From printer settings] w

Margins Layout settings

Left 079" it Page layout Right and left »

Right 0.79" e Format iy iy il o0 w

Figure 159: Set page number format to Roman numerals.
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This change is also reflected on the Status Bar. The Page section of the status bar now shows the
page number, the sequence number and the total page count (the graphic shows the cursor
location is in Page 1, and that it is the forty-third page of forty-seven in the document).

Page 1 43/47 11697 words, 65507 characters

Figure 160: Page number in the status bar

Problems with restarting page numbering

Restarting page numbering may lead to two problems.

* The Statistics page in the document’s properties (File > Properties) always displays the
total number of pages in the document, which may not be what you want to appear in the
Page Count field.

* When page numbering is restarted, LibreOffice always makes odd-numbered pages to be
on the right and even-numbered pages to be on the left. It does this by inserting a blank
page, if necessary. Sometimes this blank page is not desired, particularly when creating
PDFs or when printing single sided.

Solving the page count problem
Suppose you know exactly how many pages are not to be included in the page count. (You want
one page to be excluded in the page count for the following example.)
Instead of inserting a Page Count field, you can do the following:
1) Position the cursor where you want the page count to appeatr.

2) Press F2 to open the formula bar, just above the horizontal ruler in the main Writer window
(see Figure 161).

3) After the equal sign, type page-1. If you want to exclude several pages, substitute the
number of excluded pages for 1 in the formula.

4) Press Enter to close the formula bar and insert the resulting field into the document.

Text formula o - # ¥ |=page-t

L u

Figure 161: Formula bar

If you do not know the total number of pages in advance, then one approach is to create a
bookmark on the last page and then insert a cross reference to it.
To create a bookmark on the last page:
1) Go to the last page (Ctrl+End).
2) Choose Insert > Bookmark.
3) Inthe Insert Bookmark dialog, type a name for the bookmark, for example LastPage.
4) Click OK.
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Insert Bookmark

Bookmarks

La stPagel

| cancel |

Figure 162: Inserting a bookmark
To insert a cross-reference to the last page in the header or footer where you want to refer to the
total number of pages:

1) Position the cursor at the desired location—for example after the space added after of in
the header or footer, as in page xx of yy.

2) Choose Insert > Cross-reference.

3) On the Cross-references page of the Fields dialog (Figure 163), select Bookmarks in the

Type column and LastPage in the Selection column. LastPage now appears in the Name
box.

4) In the Insert Reference to box, select As page style. Click Insert.

Do not delete the bookmark at the end of the document. If you do, the cross-
Note reference will not work.

If a field, such as a cross-reference, does not automatically update, press F9.

-

Fields
Document |Cross-references |Functions | DocInformation | Variables | Database
Type Selection
Set Reference LastPage
Insert Reference
Headings
Numbered Paragraphs
Bookmarks
Insert reference to Name
Page LastFage
Chapter
Reference
Above/Below
iAs Page Style

Figure 163: Inserting a cross-reference to a bookmark on the last page of a document
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Defining borders and backgrounds

You can apply borders and backgrounds to many elements in Writer. Paragraphs, pages, frames,
sections, page styles, paragraph styles, character styles, and frame styles can include both
borders and backgrounds; tables of contents, and indexes can include backgrounds only. Text can
have a border applied, either to individual characters or to selected text.

The dialog pages for borders and backgrounds are similar in each case. To illustrate their use, we
will define a border and background for a text frame.

Page backgrounds fill only the area within the margins, including the header or
footer (if any). To extend the background color or graphic into the margins, you

Tip need to define a frame of appropriate size and position, anchor it to the page or a
paragraph, and send it to the background. For more about anchoring frames, see
Chapter 8, Working with Graphics.

Adding a border

To begin, select the frame, right-click, and choose Frame from the context menu. Select the
Borders tab.

-

..
Frame
Type | Options |Wrap |Hyperlink |Borders Background | Columns |[Macra
Line arrangement Lime Spacing to contents
Default Style Left 008" %
[0 i Right |0.08" [&]
Width
User-defined ul Top 0.06" %
* * 1.00pt £
- - Bottom |0.06" |4
Color = —
v ¥ | Synchronize
I cack ¥
+ -
+ +
Shadow style
Position Distance Colar
[ LT 0.04" [ I Gray v

Figure 164: Frame dialog: Borders page

Borders have three components: where they go, what they look like, and how much space is left
around them.

e Line arrangement specifies where the borders go. Writer provides five default
arrangements but you can just as easily click on the line you want to customize in the User-
defined area to get exactly what you want. Each line can be individually formatted.

* Line specifies what the border looks like: the style, width and color. There are a number of
different styles and colors to choose from. The Line Style, Width and Color will apply to
those borders highlighted by a pair of black arrows in the User-defined thumbnail on the left
hand side of the dialog.
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* Spacing to contents specifies how much space to leave between the border and the
contents of the element. Spaces can be specified to the left, right, above, and below. Check
Synchronize to have the same spacing for all four sides. This spacing is like a padding and
it is not factored in when calculating the text measurements.

* Shadow style properties always apply to the whole element. A shadow has three
components: where it is, how far from the element it is cast, and what color it is.

Adding color to the background

In the Frame dialog, choose the Background page (Figure 167). Here you can add color, a gradient
or a graphic.

To add color to the background, select from the color grid. You can adjust the transparency of the
color to make any text easier to read.

Adding a gradient to the background
To add a gradient to the background:

1) From the As drop-down list on the Background page, select Gradient. The page now
displays the gradient options (Figure 165), with an example in the preview pane to the right.

2) Select the required gradient from the list.
3) Click OK.

Type |Options |Wrap [[Hyperlink Eurders|Bad<grDund k:ulumns Macro

e

Background gradient

Gradient 1

I Grodient 2

Il Gradient 3

[ Gradient 4

I Gradient S

™ Gradient &

I Linear blue/white
I Fadial green/black
I Rectangular redfwhite
[ Square yellow fwhite
I Linear magentafgreen
[ Linear yellow brown
I Radial red/yellow
S Elipsoid blue graylight blue
== Axial light redjwhite

Figure 165: Frame dialog: Background page showing Gradient choices

Adding a graphic to the background

To add a graphic to the background:

1) From the As drop-down list on the Background page, select Graphic. The page now
displays the graphics options, as shown in Figure 166.

2) Click the Browse button. The Find Graphics dialog opens.
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3)

4)

5)

6)

Find the file you want and then click the Open button. The Find Graphics dialog closes and
the selected graphic appears in the preview box on the right-hand side of the Background
page. (If you do not see the graphic, select the Preview option.)

To embed the graphic in your document, deselect Link. To link the graphic to the document
but not embed it, select Link. For more about linking graphics, see Chapter 8, Working with
Graphics.

In the Type area, choose how you want the background graphic to appear:

a) To position the graphic in a specific location, select Position and then click the
desired location in the position grid.

b) To stretch the graphic to fill the entire background area, select Area.
c) To repeat the graphic across the entire background area, select Tile.

In the Transparency area, you can adjust the transparency of the graphic. This adjustment
is often necessary to make any text easier to read.

I'I'ype]leﬁons“Wrap||J-Jyperlink]|Elorders]Ead<grﬂur1d k:oh..lmr'ls'."Macml

File

Unlinked graphic
Type

Position |~ £~ £
Area
Tile

Transparency

Prewview

Figure 166: Graphic options on the Background page of the Frame dialog

I'I'y'pe ||Dpﬁons||Wrap||Hyperlink||Borders|Badigr0ur1d k:olwnns"Macro |

Background color

Mo Fill

L
EEEEEESN = SO
] lmwimm] 1 1 1T
AEEEEEEEEEEN
)
deEEeEeEEEEEEsS

EEEEJJUJO0O0EEE
L1 L 1 1 | ISeiwei] jeeiee
ElEEEEEE TE.
0 .-

Light cyan Transparency

Figure 167: Frame dialog: Background page showing color choices
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Deleting color, gradient or graphics from the background

To delete color, gradient or graphics from the background:
1) From the As drop-down list, select Color.
2) Click No Fill on the color grid.
3) Click OK.
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Quick printing

Click the Print File Directly icon & to send the entire document to the default printer defined for
your computer.

You can change the action of the Print File Directly icon to send the document to
the printer defined for the document instead of the default printer for the computer.
Go to Tools > Options > Load/Save > General and select the Load printer
settings with the document option.

Controlling printing

For more control over printing, use the Print dialog (File > Print or Ctrl+P).

Print =)

8.2An(A4) ——— |General LibreDFﬁ::e Writer |Page Layout |Options |

Printer

Libreoﬂ-'ice Auto Microsoft XPS Document Writer on LAFTOPNO4
D The Decument Foursdation EPSCOM Stylus COLOR 8580

EPSOM Stylus DX8400 Series

Fax

witer Guide HP DeskJet 395Cxi

Microsoft XPS Document Writer

prniry —
Printing, Exporting, Faxing, Properties...

and E-Mailing

11.69in

Range and copies

) all pages Murnber of copies m

) Pages | 7 |
Collate
Selection

|:| Print in reverse page order

Print

Comments |Nune (document only) M

(= D)

Figure 168: The Print dialog

The options selected on the Print dialog apply to this printing of this document
only.

To specify default printing settings for LibreOffice, go to Tools > Options >
LibreOffice > Print and Tools > Options > LibreOffice Writer > Print. See
Chapter 2, Setting Up Writer, for more detalils.

The Print dialog has four tabs, from which you can choose a range of options, as described in the
following sections.
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Selecting general printing options for a document
On the General tab of the Print dialog, you can choose:
* The printer (from the printers available)

* Which pages to print (the current page number is displayed here), the number of copies to

print, and whether to collate multiple copies (Range and copies section)

* Whether to print any comments that are in the document, and where to print the
comments.

Some selections may not be available all the time. For example, if the document contains no

comments, the Print — Comments drop-down list does not work.

Print

Comments  fone (document only) m

Mone (document only)
Comments only
Place at end of document

Place at end Dflpage - _] Cancel

Figure 169: Choosing whether and where to print comments

Click the Properties button to display a dialog where you can choose portrait or landscape
orientation, which paper tray to use, and the paper size to print on.

On the Options tab of the Print dialog, you can choose various other options for printing.

General |LibreOffice Writer |Page Layout | Options

Options

[ ] Create single print jobs for collated output
[ ] use only paper tray from printer preferences
[ ] Use only paper size from printer preferences

Figure 170: General print options

Printing multiple pages on a single sheet of paper

You can print multiple pages of a document on one sheet of paper. To do this:
1) Inthe Print dialog, select the Page Layout tab (Figure 171).
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General |LibreQffice Writer |Page Layout Options

Layout
@' Pages per sheet |2 W

11.69in (A4) Order left to right, then down | » 1 2

[] oraw a border around each page

D L_u:;-ran'f_ug_e
(") Brochure
F:i T Page sides
[ e Indude Al pages 17]
g All pages

Back sides [ left pages
Front sides [ right pages

1| f12 I]

Figure 171: Printing multiple page per sheet of paper

2) In the Layout section, select from the drop-down list the number of pages to print per sheet.
The preview panel on the left of the Print dialog shows how the printed document will look.
When printing more than 2 pages per sheet, you can choose the order in which they are
printed across and down the paper. The two pictures below show the difference.

Layout
& Pages per sheet |4 ¥ 1 2
Order left to right, then down 12 3 4

- top to bottom, then right

Layout
® Pages per sheet 4 11 3
Order top to bottom, then right 2 p

- top to bottom, then right

3) In the Page sides section, select whether to print all pages or only some pages.
4) Click the OK button.

Ti To print two pages per sheet in “facing pages” (book layout) style, print from Print
P Preview instead. See page 169.
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Selecting what to print

In addition to printing a full document, you can choose to print individual pages, ranges of pages,
or a selection of a document, as described in this section.

Printing an individual page:

1)
2)
3)
4)

5)

Choose File > Print from the Menu bar.
On the Print dialog, select the page to print.
In the Range and copies section of the General page, select the Pages option.

Enter the sequence number of the page you want to print. This may differ from the page
number if you have restarted page numbering within the document. The preview box
changes to show the selected page.

Click the OK button.

Printing a range of pages:

1)
2)
3)
4)
5)

Choose File > Print from the Menu bar.

On the Print dialog, select the range of pages to print.

In the Ranges and copies section of the General page, select the Pages option.
Enter the sequence numbers of the pages to print (for example, 1-4 or 1,3,7,11).
Click the OK button.

Printing a selection of text:

1)
2)
3)

4)

In the document, select the material (text and graphics) to print.
Choose File > Print from the menu bar.

The Ranges and copies section of the Print dialog now includes a Selection option and the
preview box shows the selected material. See Figure 172.

Click the OK button.

Printing a brochure

In Writer, Impress, and Draw, you can print a document with two pages on each side of a sheet of
paper, arranged so that when the printed pages are folded in half, the pages are in the correct
order to form a booklet or brochure.

Tip

Plan your document so it will look good when printed half size; choose appropriate
margins, font sizes, and so on. You may need to experiment.

To print a brochure on a single-sided printer:

1)
2)
3)

4)
5)
6)

7)

Choose File > Print.
On the General page of the Print dialog, click Properties.

Check the printer is set to the same orientation (portrait or landscape) as specified in the
page setup for your document. Usually the orientation does not matter, but it does for
brochures. Click OK to return to the Print dialog.

Select the Page layout tab in the Print dialog.
Select the Brochure option.

In the Page sides section, select Back sides / left pages option from the Include drop-down
list. (See Figure 173.)

Click the OK button.
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Selecting what to print

In addition to printing & full document, you can choose to print individual pag es, ranges of pages,

or a selection of a document, as descnbed in ths section.
Pnnting an individual page:
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Figure 172: Printing a selection of text

\General |LibreOffice Writer |F‘EQE Layout Epﬁuns|

Layout
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Order
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1
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Front sides / right pages
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{3 Brochure
Page sides
Include all pages iv
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Figure 173: Selecting which pages to print

8) Take the printed pages out of the printer, turn the pages over, and put them back into the
printer in the correct orientation to print on the blank side. You may need to experiment a bit

to find out what the correct arrangement is for your printer.

9) On the Print dialog, in the Page sides section, select Front sides / right pages option from

the Include drop-down box.
10) Click the OK button.

Tip

If your printer can print double-sided automatically, choose All pages.
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Printing in black and white (on a color printer)

You may wish to print documents in black and white on a color printer. Several choices are
available. Please note that some color printers may print in color regardless of the settings you
choose.
Change the printer settings to print in black and white or grayscale:

1) Choose File > Print to open the Print dialog.

2) Click Properties to open the Properties dialog for the printer. The available choices vary
from one printer to another, but you should find options for the Color settings. See your
printer’s help or user manual for more information.

3) The choices for color might include black and white or grayscale. Choose the required
setting.

4) Click OK to confirm your choice and return to the Print dialog,

5) Click the OK button to print the document.

Tip Grayscale is best if you have any graphics in the document.

Change the LibreOffice settings to print all color text and graphics as grayscale:
1) Choose Tools > Options > LibreOffice > Print.
2) Select the Convert colors to grayscale option. Click OK to save the change.
3) Open the Print dialog (File > Print).
4) Click the OK button to print the document.
Change the LibreOffice Writer settings to print all color text as black, and all graphics as grayscale:
1) Choose Tools > Options > LibreOffice [Component] > Print.
2) Under Contents, select the Print text in black option. Click OK to save the change.
3) Open the Print dialog (File > Print).
4) Click the OK button to print the document.

Previewing pages before printing

The normal page view in Writer shows you what each page will look like when printed and you can
edit the pages in that view. If you are designing a document to be printed double-sided, you may
want to see what facing pages look like. Writer provides two ways to do this:

* View Layout (editable view): use the Facing Pages (Book Preview) button on the status bar.

O GO|IEDE] (& a @ |B5%

* Page Preview (read-only view).
To use Page Preview:

1) Choose File > Page Preview (or click the Page Preview button on the Standard
toolbar). Writer now displays the Page Preview toolbar instead of the Formatting toolbar.

P& D | € D B - 8B | & s (v € 2 B | ClosePreview

Figure 174: Page Preview toolbar
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2)

3)

4)

Select the required preview button: Two Pages B& , Multiple Pages 35 - or Book
Preview b .

To print the document from this view, click the Print document button & to open the
Print dialog.

Choose the print options and click the OK button.

Printing envelopes

Printing envelopes involves two steps: setup and printing.

To set up an envelope to be printed by itself or with your document:
1) Click Insert > Envelope from the Menu bar.
2) In the Envelope dialog, start with the Envelope tab. Verify, add, or edit the information in the

3)

Addressee and Sender (the “from” on the envelope) boxes.

-~

Envelope W

Envelope Fnrmat Printer

Addressee Database

- |.-5.|:||:Iresses [v]

m IIEHE ]

Database field

[( ] ! [}] | [V]

John Smith ~
12 Anystreet

Anytown
it [
LInited Fﬁngdnm -

W

2 ——

[ Mew Document l I Insert ] ’ Cancel ] I Help ] [ Reset

Figure 175: Choosing addressee and sender information for an envelope

You can type information directly into the Addressee and Sender boxes, or use the right-
hand drop-down lists to select the database or table from which you can draw the envelope
information, if desired. See Chapter 11, Using Mail Merge, for details on how to print
envelopes from a database.

On the Format page, verify or edit the positioning of the addressee and the sender
information. The preview area on the lower right shows the effect of your positioning
choices.
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Figure 176: Choosing positioning and size of elements for an envelope

4) To format the text of these blocks, click the Edit buttons to the right. In the drop-down list
you have two choices for each button: Character and Paragraph.
* Selecting Character opens a Character dialog, similar to the standard Character dialog,
but omitting Borders, allowing you to set the formatting of the text's attributes.

* Selecting Paragraph opens a Paragraph dialog, similar to the standard Paragraph
dialog, but omitting Outline & Numbering, allowing you to set the paragraph's attributes.

5) In the lower left of this page, the Size section, choose the envelope format from the drop-
down list. The width and height of the selected envelope then show in the boxes below the
selected format. If you chose a pre-existing format, just verify these sizes. If you chose
User defined in the Format list, then you can edit the sizes.

6) After formatting, go to the Printer page to choose printer options such as envelope
orientation and shifting. You may need to experiment a bit to see what works best for your
printer.

You can also choose a different printer or alter printer setup (for example, specify the tray
that holds envelopes) for this print job by clicking the Setup button and making selections
on the Printer Setup dialog.

7) When you have finished formatting and are ready to print, click either the New Document
or Insert button to finish. New Document makes only an envelope or starts a new
document with the envelope. Insert puts the envelope into your existing document as
page 1.

To not proceed with this envelope, click Cancel or press the Esc key. You can also click
Reset to remove your changes and return to the original settings when the dialog opened.
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When the Envelope dialog closes, you are returned to your document, which now has the envelope
in the same file as the document. Save this file before you do anything else.

Envelope |[Format |Printer

Envelope orientation

== I I
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) Print from bottom

Shift right 0.00"

[4»
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4>
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~ y
Printer Setup
Printer
Mame FPSOM Stylus DX3400 Series F ’ Properties... ]

Auto Microsoft ¥PS Document Writer on LAPTOPNO4
EPSOM Stylus COLOR. 830

Type EPSON Stylus DX8400 Series

Location  [Fax

HF Desklet 895Cx

Microsaft ¥XPS Dacument Writer

Status

Comment

ok || concel || heb

Figure 177: Choosing printer options for an envelope

To print the envelope:
1) Choose File > Print from the menu bar.

2) On the Print dialog, under Print range, choose Pages and type 1 in the box. Click OK to
print.

Printing labels

Labels are commonly used for printing address lists (where each label shows a different address),
but they can also be used for making multiple copies of one label only, for example return-address
stickers. To print labels:

1) Choose File > New > Labels on the Menu bar. The Labels dialog opens.

2) On the Labels page, fill in your own label text in the Inscription box, or use the Database
and Table drop-down lists to choose the required information, as described in Chapter 11,
Using Mail Merge.
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Figure 178: Labels dialog, Labels page

3) Select the label stock in the Brand drop-down list. The types for that brand then appear in
the Type drop-down list. Select the size and type of labels required. You can also select
User in the Type drop-down list and then make specific selections on the Format page.

4) On the Format page, choose the pitch, sizes, margins, columns and rows for user-defined
labels, or just verify with a brand of label stock you have loaded into the printer.

Labels |[Format Cptions

Horizontal pitch | 004 [&] Avery A4 18163 Address

Vertical pitch 1.50"

Width 3.90° % Left margip H. F;itch
Height 1.50" T
Top margin

Left margin 0.18"

. P th
Top margin 0.60 el

Rows

Columns 2 -~ V. Pitch
Raws 7 Height
Page Width 8.27" (% h M
Page Height 11.69" [% Columns

Save...

Figure 179: Labels dialog, Format page

5) Click Save to save your new format.

6) On the Options page, choose to print the entire page of labels or one single label, then
select which one by the column and row. You can also change printer setup.
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Figure 180: Labels dialog, Options page

7) When you have finished formatting, click New Document to create your sheet of labels or
click Cancel (or press the Esc key). You can also click Reset to remove your changes and
return to the original settings when the dialog opened.

8) You can print using the Print File Directly icon on the toolbar or by choosing File > Print
from the Menu bar, or you can save the file to print later.

Sending a fax

To send a fax directly from LibreOffice, you need a fax modem and a fax driver that allows
applications to communicate with the fax modem.

1) Open the Print dialog (Figure 168) by choosing File > Print and select the fax driver in the
Printer list.

2) Click OK to open the dialog for your fax driver, where you can select the fax recipient.

You can set up a toolbar button so that a single click sends the current document as a fax. To add
a button for this purpose to a toolbar, see Chapter 16, Customizing Writer.

Exporting to PDF

LibreOffice can export documents to PDF (Portable Document Format). This industry-standard file
format for file viewing is ideal for sending the file to someone else to view using Acrobat Reader or
other PDF viewer.

Quick export to PDF

Click the Export Directly as PDF button to export the entire document using the PDF settings

you most recently selected in the PDF Options dialog. You are asked to enter the file name and
location for the PDF file, but you do not get a chance to choose a page range, the image
compression, or other options.

Controlling PDF content and quality

For more control over the content and quality of the resulting PDF, use File > Export as PDF. The
PDF Options dialog opens. This dialog has five pages (General, Initial View, User Interface, Links,
and Security). Select the appropriate settings, and then click Export. On the Export dialog, enter
the location and file name of the PDF to be created, then click Export to export the file.
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General page of PDF Options dialog

On the General page (Figure 181), you can choose which pages to include in the PDF, the type of
compression to use for images (which affects the quality of images in the PDF), and other options.

Range section

All: Exports the entire document.

Pages: To export a range of pages, use the format 3-6 (pages 3 to 6). To export single
pages, use the format 7;9;11 (pages 7, 9, and 11). You can also export a combination of
page ranges and single pages, by using a format like 3-6;8;12.

Selection: Exports whatever material is selected.

Images section

Lossless compression: Images are stored without any loss of quality. Tends to make
large files when used with photographs. Recommended for other kinds of images or
graphics.

JPEG compression: Allows for varying degrees of quality. A setting of 90% works well with
photographs (small file size, little perceptible loss of quality).

Reduce image resolution: Lower-DPI (dots per inch) images have lower quality. For
viewing on a computer screen generally a resolution of 72dpi (for Windows) or 96dpi
(GNU/Linux) is sufficient, while for printing it is generally preferable to use at least 300 or
600 dpi, depending on the capability of the printer. Higher dpi settings greatly increase the
size of the exported file.

EPS (Encapsulated PostScript) images with embedded previews are exported only

Note as previews. EPS images without embedded previews are exported as empty

placeholders.

-

-

PDF Options
General [nitial View |[User Interface |Links | Security
Range General
Al £mbed OnenDacument file!
i [] PoF/a-12
calactin - []Taoged POF

[¥4]

|r|
IT
[

] create POF form

Images
{:} Lossless compression
(%) JPEG compression

Watermark
[ ] sign with Watermark

termark Text

Quality 0% |

[+] Reduce image resolution | 75DPI |

Allow duplicate

Export bookmarks

|:| Export comments

[ ] Export automatically inserted blank pages
[] view POF after Export

Figure 181: General page of PDF Options dialog

Chapter 5 Printing, Exporting, Faxing, and E-Mailing

175



Watermark section
* Sign with Watermark: When this option is selected, a transparent overlay of the text you
enter into the Watermark Text box will appear on each page of the PDF.

General section
* Embed OpenDocument file: Use this setting to export the document as a PDF file
containing two file formats: PDF and ODF. In PDF viewers it behaves like a normal PDF
file, and it remains fully editable in LibreOffice.

* PDF/A-1a: PDF/A-1a is an ISO standard for long-term preservation of documents, by
embedding all the information necessary for faithful reproduction (such as fonts) while
forbidding other elements (including forms, security, and encryption). PDF tags are written.
If you select PDF/A-1a, the forbidden elements are grayed-out (not available).

* Tagged PDF: Tagged PDF contains information about the structure of the document’s
contents. This can help to display the document on devices with different screens, and
when using screen reader software. Some tags that are exported are table of contents,
hyperlinks, and controls. This option can increase file sizes significantly.

* Create PDF form - Submit format: Choose the format of submitting forms from within the
PDF file. This setting overrides the control’'s URL property that you set in the document.
There is only one common setting valid for the whole PDF document: PDF (sends the
whole document), FDF (sends the control contents), HTML, and XML. Most often you will
choose the PDF format.

* Export bookmarks: Creates PDF bookmarks (a table of contents list displayed by most
PDF viewers, including Adobe Reader) for all headings in the document.

* Export comments: Exports comments as PDF notes. You may not want this!

e Export automatically inserted blank pages: If selected, automatically inserted blank
pages are exported to the PDF. This is best if you are printing the PDF double-sided. For
example, books usually have chapters set to always start on an odd-numbered (right-hand)
page. When the previous chapter ends on an odd page, LibreOffice inserts a blank page
between the two odd pages. This option controls whether to export that blank page.

Earlier versions of LibreOffice had the option:

* Embed standard fonts: Normally the 14 standard PostScript fonts were not embedded in
a PDF file, because PDF reader software already contained these fonts. However, you
could choose to embed these fonts in all PDF documents created by LibreOffice to
enhance display accuracy in PDF viewers.

The PostScript fonts are now embedded by default.

Initial View page of PDF Options dialog

On the Initial View page, you can choose how the PDF opens by default in a PDF viewer. The
selections should be self-explanatory.

If you have Complex Text Layout enabled (in Tools > Options > Language settings >
Languages), an additional selection is available under Continuous facing: First page is left
(normally, the first page is on the right when using the Continuous facing option).
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PDF Options

General |Initial View User Interface |Links |Security

Page layout
{(*) Default
) Bookmarks and page () Single page
() Thumbnails and page () Continuous
Open on page |1 ¢ () Continuous fading

Maagnification
() Default
{3 Fitin window
) Fit width
) Fit visible
(O Zoom factor | 100

Figure 182: Initial View page of PDF Options dialog

User Interface page of PDF Options dialog

On the User Interface page, you can choose more settings to control how a PDF viewer displays
the file. Some of these choices are particularly useful when you are creating a PDF to be used as a
presentation or a kiosk-type display.

Window options section

* Resize window to initial page. Causes the PDF viewer window to resize to fit the first
page of the PDF.

* Center window on screen. Causes the PDF viewer window to be centered on the
computer screen.

* Open in full screen mode. Causes the PDF viewer to open full-screen instead of in a
smaller window.

¢ Display document title. Causes the PDF viewer to display the document’s title in the title

bar.
i Ty
PDF Options
General |Initial View |User Interface Links |Security
Window options User interface options

Resize window to initial pagei [ ] Hide menubar
[ ] center window on screen [ ] Hide toolbar
] open in full screen mode [] Hide window controls

Display document title
Transitions Bookmarks
transition effects () all bookmark levels
() Visible bookmark levels |1

-
Use

Figure 183: User Interface page of PDF Options dialog
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User interface options section
* Hide menu bar. Causes the PDF viewer to hide the menu bar.

¢ Hide toolbar. Causes the PDF viewer to hide the toolbar.
* Hide window controls. Causes the PDF viewer to hide other window controls.

Bookmarks
Select how many heading levels are displayed as bookmarks, if Export bookmarks is selected
on the General page.

Links page of PDF Options dialog
On the Links page, you can choose how links in documents are exported to PDF.

General |Initial View |User Interface |Links Security

General

[] convert document references to POF targets
[ ] Export URLs relative to file system

Cross-document links
{¥) Default mode
i) Open with POF reader application
) Open with Internet browser

Figure 184: Links page of PDF Options dialog

Export bookmarks as named destinations
If you have defined Writer bookmarks, this option exports them as “named destinations” to
which Web pages and PDF documents can link.

Convert document references to PDF targets
If you have defined links to other documents with OpenDocument extensions (such as .odt,
.0ds, and .odp), this option converts the files names to .pdf in the exported PDF document.

Export URLSs relative to the file system
If you have defined relative links in a document, this option exports those links to the PDF.

Cross-document links
Set up the behavior of the PDF links to other files. Select one among the following alternatives:
¢ Default mode: The PDF links will be handled as specified in your operating system.

* Open with PDF reader application: Use the same application used to display the PDF
document to open linked PDF documents.

¢ Open with Internet browser: Use the default Internet browser to display linked PDF
documents.

Security page of PDF Options dialog

PDF export includes options to encrypt the PDF (so it cannot be opened without a password) and
apply some digital rights management (DRM) features.

* With an open password set, the PDF can only be opened with the password. Once opened,
there are no restrictions on what the user can do with the document (for example, print,
copy, or change it).
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* With a permissions password set, the PDF can be opened by anyone, but its permissions
can be restricted. See Figure 185. After you set a password for permissions, the other
choices on the Security page become available.

* With both the open password and permission password set, the PDF can only be opened
with the correct password, and its permissions can be restricted.

Note Permissions settings are effective only if the user’'s PDF viewer respects the settings.

General [ Initial View |User Interface |Links | Security

File encryption and permission Printing
) Mot permitted
{3 Low resclution (150 dpi)

Set passwords. ..

Open password set
PDF document will be encrypted

Changes
Permission password set ) Not permitted
POF document will be restricted () Inserting, deleting, and rotating pages

) Eiling in form fields
) Commenting, filing in form fields
@ Any except extracting pages

Content
Enable copying of content
Enable text access for accessibility tools

Figure 185: Security page of PDF Options dialog with passwords set

Figure 186 shows the pop-up dialog displayed when you click the Set passwords button on the
Security page of the PDF Options dialog.

Once you have set all the options you require, click on Export to open the Export dialog, where
you can set the file name and the save location.

Set passwords

Set open password

-

S

Password:

S S

Confirm:

Set permission password
Password:

Confirm:

Help H oK H Cancel

Figure 186: Setting a password to encrypt a PDF
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Another choice is to use File > Export. This opens the Export dialog. Select the
PDF file format, file name and location and click Export. This then opens the PDF
Options dialog, as described above. Click Export when all the selections have been
made.

Note

Exporting to XHTML

LibreOffice uses the term “export” for some file operations involving a change of file type.
LibreOffice can export files to XHTML. Other formats may be made available through extensions.

To export to XHTML, choose File > Export. On the Export dialog, specify a file name for the
exported document, then select the XHTML in the File format list and click the Export button.

File name: Untitled 1 v

File format: PMG - Portable Metwork Graphic (.png)

KHTML (html; ,xchtml)
PDF - Portable Document Format (pdf)

Automatic file namMediaWiki (. tat)

L JPEG - Joint Photographic Experts Group (.jpa;.jpea;.jfif; jif; jpe)
- Wiriter Layout XML {.xml)

PMG - Portable Metwork Graphic {.png)

Figure 187: Export file formats

E-mailing Writer documents

LibreOffice provides several ways to quickly and easily send a Writer document as an e-mail
attachment in one of three formats: ODT (OpenDocument Text, Writer’s default format), DOC
(Microsoft Word format), or PDF.

Documents can only be sent from the LibreOffice mail merge wizard if a mail profile

Note has been set up in Tools > Option > LibreOffice Writer > Mail Merge E-mail.

To send the current document in ODT format, choose:

1) File > Send > Document as E-mail, or File > Send > E-mail as OpenDocument Text.
Writer opens your default e-mail program. The document is attached.

2) Inyour e-mail program, enter the recipient, subject, and any text you want to add, then
send the e-mail.

If you choose E-mail as Microsoft Word, Writer first creates a DOC file and then opens your
e-mail program with the DOC file attached. Similarly, if you choose E-mail as PDF, Writer opens
the PDF Options dialog where you can select the settings you want, then creates a PDF and then
opens your email program with the PDF file attached.

E-mailing a document to several recipients

To e-mail a document to several recipients, you can use the features in your e-mail program or you
can use LibreOffice’s mail merge facilities to extract email addresses from an address book.

You can use LibreOffice’s mail merge to send e-mail in two ways:

* Use the Mail Merge Wizard to create the document and send it. See Chapter 11, Using Mail
Merge, for details.
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* Create the document in Writer without using the Wizard, then use the Wizard to send it.
This method is described here.

To use the Mail Merge Wizard to send a previously-created Writer document:

1) Open the document in Writer. Click Tools > Mail Merge Wizard. On the first page of the
wizard, select Use the current document and click Next.

Mail Merge Wizard

-,

Steps

.iSelect starting document:

. Select document type

. Insert address blodk

Select starting document for the mail merge

() Uze the current document

() Create a new document

() start from existing document
. Adjust layout () Start from a template

. Edit document

Start from

[=]
5l
1]
]
1]
|
P
(U
17
[=1
(%]
o
|

L
2
3
4, Create salutation
5
=]
7. Personalize document
8

. Save, print or send

Mext =

1T
W

Figure 188: Select starting document

Cancel

2) On the second page, select E-mail message for the type of document to create and click
Next.

Steps What type of document do you want to create?

{:} Letter
1. Select starting document

2. Select document type
3. Select address list
4, Create salutation

Send e-mail messages to a group of redpients, The e-mail messages can contain a salutation, The
e-mail messages can be personalized for each redpient.

Figure 189: Select document type

3) On the third page, click the Select Address List button. Select the required address list
(even if only one is shown) and then click OK. (If the address list you need is not shown
here, you can click Add to find and add it to the list.)
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Skteps Insert address block

1. Select starting docurnent 1. Select the address lisk containing the address data

Select Add List. ..
wau wank ko use, This data is needed to create the LSS et ]
2. Select document type address block,
3. Select address lisk
4, Create salutation Select Address List
Select an address list. Click 'add..." to select recipients from a different list, IF vou do not have an
& Edit dacument address lisk ywou can create one by clicking 'Create. ..".
7. Personalize document Yaur recipients are currently selected From:
8. Save, print or send Marne Table add...
‘address-test address-test
Addresses|
(04 ] [ Cancel l [ Help

Figure 190: Selecting an address list

4) Back on the Select address list page, click Next. On the Create salutation page, deselect
the checkbox by This document should contain a salutation.

Mail Merge Wizard

Steps Create a salutation
1. Select starting document [ This document should contain a salutation:
2. Select document type Insert personalized salutaton

3. 5elect address list

4, Create salutation

o

m
[}
[}

Miss

ale

Figure 191: Deselecting a salutation
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5) In the left-hand list, click Step 8. Save, print or send. LibreOffice displays a “Creating
documents” message and then displays the Save, print or send page of the Wizard.

6) Select Send merged document as E-Mail. The lower part of the page changes to show
e-mail settings choices.

7) Type a subject for your email and click Send documents. LibreOffice sends the e-mails.
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Mail Merge Wizard

Steps Save, print or send the document
1. Select starting document Select one of the options below:
2. Selert document bype C' Save starting document

3. Select address lisk () save merged document

) print merged document
4, Create salutation

(%) Zend meraed document as E-Mail:

E-Mail settings

Ta E-mail Address v Copy to...

Subject

6, Edit documnent
7. Personalize document

8. Save, print or send
Send as HTML Message ¥

test-email-message, odk
(%3 Send all documents

O Fram |1 5

[ Send documents

Figure 192: Sending a document as an email message

Digital signing of documents

To sign a document digitally, you need a personal key, also known as a certificate. A personal key
is stored on your computer as a combination of a private key, which must be kept secret, and a
public key, which you add to your documents when you sign them. You can get a certificate from a
certification authority, which may be a private company or a governmental institution.

When you apply a digital signature to a document, a kind of checksum is computed from the
document’s content plus your personal key. The checksum and your public key are stored together
with the document.

When someone later opens the document on any computer with a recent version of LibreOffice,
the program will compute the checksum again and compare it with the stored checksum. If both
are the same, the program will signal that you see the original, unchanged document. In addition,
the program can show you the public key information from the certificate. You can compare the
public key with the public key that is published on the web site of the certificate authority.

Whenever someone changes something in the document, this change breaks the digital signature.

On Windows operating systems, the Windows features of validating a signature are used. On
Solaris and Linux systems, files that are supplied by Thunderbird, Mozilla or Firefox are used. For
a more detailed description of how to get and manage a certificate, and signature validation, see
“Digital Signatures” in the LibreOffice Help.

To sign a document:

1) Choose File > Digital Signatures.

2) If you have not saved the document since the last change, a message box appears. Click
Yes to save the file.

3) The Digital Signatures dialog opens. Click Sigh Document to add a public key to the
document.
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4) In the Select Certificate dialog, select your certificate and click OK to return to the Digital
Signatures dialog.

5) The certificate used is displayed in the dialog with an icon next to its name.
This icon indicates the status of the digital signature.

* Anicon with a red seal % indicates that the document was signed and the certificate
was validated.

* Anicon with a yellow caution triangle overlaying the red seal |i& indicates that the
document is signed but that the certificate could not be validated.

* Anicon of a yellow caution triangle ‘! indicates an invalid digital signature.
6) Click Close to apply the digital signature.

A signed document shows an icon in the status bar. You can double-click the icon to view the
certificate. More than one signature can be added to a document.

Removing personal data

You may wish to ensure that personal data, versions, comments, hidden information, or recorded
changes are removed from files before you send them to other people or create PDFs from them.

In Tools > Options > LibreOffice > Security > Options, you can set LibreOffice to remind (warn)
you when files contain certain information and remove personal information automatically on
saving.

To remove personal and some other data from a file, go to File > Properties. On the General tab,
uncheck Apply user data and then click the Reset button. This removes any names in the created
and modified fields, deletes the modification and printing dates, and resets the editing time to zero,
the creation date to the current date and time, and the version number to 1.

To remove version information, either (a) go to File > Versions, select the versions from the list
and click Delete, or (b) use Save As and save the file with a different name.
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What are styles?

Most people are used to writing documents according to physical attributes. For example, you
might specify the font family, font size, and weight (for example: Helvetica 12pt, bold).

Styles are logical attributes. We use styles every day. For example, there are different styles of
personal computer: desktop, tablet, netbook, laptop, and so on. Each has its own distinctive set of
properties. You never say “my computer is a low-weight, one-piece unit with an LCD screen
attached to a rectangular casing containing the computing components and the keyboard”. Instead,
you would probably say that you have a laptop.

LibreOffice styles are a way to do the same thing for your document. Using styles means that you
could stop saying “font size 14pt, Times New Roman, bold, centered” and start saying “title” for
describing that particular font usage. In other words, styles mean that you shift the emphasis from
what the text looks like to what the text is.

Why use styles?

Styles help improve consistency in a document. They also make major formatting changes easy.
For example, you might decide to change the indentation of all paragraphs or change the font of all
titles. For a long document, this simple task could be prohibitive. Styles make the task easy.

The time is 9:50 AM, and Jane is finishing the 30-page paper for school that is due at
10:00 AM. She looks over the assignment one more time, and suddenly she realizes that:

* The text must use Arial font instead of Times New Roman.
* The headings must be dark blue and indented.
* The title must appear at the top-right of every page except the first.

* Even-numbered pages must have a wider right margin, and odd-numbered pages
must have a wider left margin.

Thankfully, Jane used LibreOffice Writer and styles. She makes all the changes in only
two minutes and hands in the paper on time.

Style categories

LibreOffice Writer has five style categories:
* Paragraph styles affect entire paragraphs represented with those styles.
* Character styles affect a block of text inside a paragraph.
* Page styles affect page formatting (page size, margin, and the like).
* Frame styles affect frames and graphics.
* [Lijst styles affect outlines, numbered lists, and bulleted lists.

In the same way that characters are the building blocks for creating words, paragraphs are the
building blocks of every document. Headings (subheads) are paragraphs; headers, footers, and
numbered lists are also paragraphs. Paragraph styles are, therefore, the most frequently used
styles and are the ones treated in most detail in this and the next chapter.
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The Styles and Formatting window

Styles are available through a floating or dockable window called Styles and Formatting, shown in
Figure 193. This window is at the center of styles management. Do not worry if, at first, some
contents of this section seem obscure while progressing through this or the next chapter. This
guide describes how to use all these functions.

Styles and Fol thi

tylesa  — & Mew Style from Selection

Paragraph Styles |+ | fa] {1 0] &:{, M= ~H- Update Style
Complihentgry Clgss Load Styles. ..

Character Styles Deﬁauéjstﬂ

First Line Ingent

Frame Styles H rit IFiII Format Mode

Heading
Heading 1
Page Styles | [THeading 2
Heading 3
List Styles [rHeading-
Automatic v

Figure 193: The Styles and Formatting window showing paragraph styles
To open the Styles and Formatting window, do any one of the following:

* Click on the ([ ) icon located at the left-hand end of the Formatting toolbar.

* Select Format > Styles and Formatting.
* Press F11.

You can move the Styles and Formatting window to a convenient position on the

Tip screen or dock it to an edge.

Style selection basics

The first five buttons at the top of the Styles and Formatting window select the category of styles to
work on. Click on one of these buttons to display a list of styles in that category, such as paragraph
or character styles.

To apply a character style to existing text, select the text and then double-click on the name of the
style in the Character Styles list. To apply any other style, put the cursor in the paragraph, frame, or
page you want to modify and double-click on the name of the style in the corresponding section.
You can select more than one paragraph or frame and apply the same style to all of them at the
same time.

Using Fill Format mode

The sixth icon at the top of the Styles and Formatting window activates the Fill Format mode. You
can use Fill Format to apply a style to many different areas quickly without having to go back to the
Styles and Formatting window and double-click every time. This method is useful for formatting
many scattered paragraphs, words, or other items with the same style, and it may be easier to use
than making multiple selections first and then applying a style to all of them.

1) Open the Styles and Formatting window (Figure 193) and select a style.
2) Click the Fill Format Mode button ( 7 ).
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3) To apply a paragraph, page, or frame style, hover the mouse over the paragraph, page, or
frame and click. To apply a character style, hold down the mouse button while selecting the
characters. Clicking on a word applies the character style to that word.

4) Repeat step 3 until you have made all the changes for that style.
5) To quit the Fill Format mode, click the button again or press the Esc key.

Caution When this mode is active, a right-click anywhere in the document undoes the last
Fill Format action. Be careful not to accidentally right-click and mistakenly undo
actions you want to keep.

Using New Style from Selection, Update Style, and Load Styles

Styles are part of the document properties, therefore changes made to a style or new styles you
create are only available within the document they belong to. Styles always stay with a document.
So, for example, if you e-mail a document to another person, the styles go with it.

If you want to reuse modified or new styles in other documents, you need to either save the styles
in a template (see Chapter 10) or copy the styles into the document where you want to use them.

The last button in the toolbar of the Styles and Formatting window is a menu button that gives
access to three submenu functions: New Style from Selection, Update Style, and Load Styles.

New Style from Selection

Use the first function of the button to create a new style from the formatting of an object in the
current document. For instance, you can change the formatting of a paragraph or frame until it
appears as you like, and then you can turn that object’s formatting into a new style. This procedure
can save time because you do not have to remember all the formatting settings you want, as is
necessary when creating a new style with the Style dialog. In addition, unlike when setting the
formatting parameters in the pages of dialogs, which you will learn to do later, you can immediately
see how the objects will look when formatted with the style you are creating.

Follow these steps to create a new style from a selection:
1) Change the formatting of the object (paragraph, frame, etc.) to your liking.

2) From the buttons at the top of the window, choose the category of style to create
(paragraph, character, and so on).

3) In the document, select the item to save as a style.

4) Go back to the Styles and Formatting window and click the New Style from Selection
button, then select New Style from Selection from the menu.

In the Create Style dialog, type a name for the new style. The list shows the names of existing
custom styles of the selected type, if any. Click OK to save the new style.

Create Style

Style name

-

O0oChapterMumber ”
C0oDefault |
CiCoMenuPath
OCo5trongEmphasis
O0oComputerCode

C0oEmphasis

O0okeystroke
MiCinK ewvhnardTnm b

188 LibreOffice 4.2 Writer Guide



Update Style (from a selection)
Let's use paragraph styles as an example.

1) Create a new paragraph (or select an existing paragraph) and edit all the properties you
want to alter in the style (such as indentation, font properties, alignment, and others).

Caution Make sure that there are uniform properties in this paragraph. For example, if
there are two different font sizes in the paragraph which is selected to be used to
update the style, that particular property will not be updated.

2) Select the paragraph by clicking anywhere in the paragraph.

3) In the Styles and Formatting window, select the style you want to update (single-click, not
double-click) and then click on the New Style from Selection button and select Update

Style.
Styles and Formatting =
in|fa) £ O o ILER
Addressee Mew Style from Selection
E:E::ES;ZEE: Ifleading Update Style %
Caption Load Styles. ..
All Styles v

Figure 194: Updating a style from a selection

The procedure to update another category of style (character, page, or frame styles) is the same:

select the item in question, maodify it, select the style you want to update, and choose Update
Style.

Load Styles (from a template or document)

The last option under the New Style from Selection icon is used to copy styles into the current

document by loading them from a template or another document. Using this method, you can copy
all styles, or groups of styles, at one time.

1) Open the document to copy styles into.

2) In the Styles and Formatting window, click on the New Style from Selection icon and then
on Load Styles (see Figure 194).

3) Inthe Load Styles dialog (Figure 195), find and select the template to copy styles from.

7 Ty
Load Styles
Categories Templates [

l

My Templates | |Test
Drawing [ Cancel ]
)

Ok

HEB-Systems

phb

Presentation

Presentation Backarounds
Presentations

US-Sizes

——

Help

Text [] Erame [ ] Pages [ ] Numbering [ ] Qverwrite From File...

Figure 195: Loading styles from a template
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4) Click on the From File button if the styles you want are contained in a text document rather
than a template. In this case, a standard file selection dialog opens up, where you can
select the desired document.

5) Select the options for the types of styles to be copied: Text (Paragraph and Character
styles), Frame, Pages, Numbering (List styles). If you select Overwrite, the styles being
copied will replace any styles of the same names in the target document.

6) Click OK to copy the styles.

Using the visible styles filters

At the bottom of the Styles and Formatting window (Figure 196), use the drop-down menu to select
a filtering criterion for the contents of the main body of the window. Normally, you will find that only
a handful of styles are needed in any given document, and it makes sense to have only these
styles shown.

So, at the beginning of the writing process, you may want to have access to all the available styles
(by selecting All Styles), and to then exclude some of them from use (Ctrl+click to select each
style to be excluded and finally right-click one of these files and select Hide from the context
menu). However, as the document develops, it is useful to reduce the size of the list displayed to
only the styles already in use (by selecting Applied Styles). If you work on a document where you
want to apply special-purpose styles only (such as those styles used in writing this user guide),
select instead Custom Styles. The Hierarchical Styles view is most useful when modifying styles
as it reveals which styles are linked together. This topic is discussed in more detail in Chapter 7,
Working with Styles.

Styles and Formatting 2
fn] =] i O &y 1= -
OCoMum abc End -

OOoMum abc Start

OOoMum ii Cont.

OOoMum i End

OOoMurm i Start

O0oMumberedTMC Cont. o

[

Custom Styles
SHierarchical =
all Styles
Hidden Styles
Applied Styles
Custom Styles
Automatic
Text Styles
Chapter Styles
List Styles

Figure 196: Styles and Formatting filter

If you select the Paragraph Styles view in the Styles and Formatting window, the drop-down menu
contains many more filtering options so you can view, for example, only Text Styles, Special
Styles, and so on.

Drag-and-drop a selection to create a style

Another way to create a new style is to drag-and-drop a text selection into the Styles and
Formatting window.
1) Open the Styles and Formatting window.

2) Select the style category you are going to create (for example a character style) using one
of the five icons in the top left part of the window.
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3) Select the object on which you want to base the style and drag it to the Styles and
Formatting window. The cursor changes to indicate whether the operation is possible or

not.
4) In the Create Style dialog which opens, type a hame for the new style and click OK to save
the style.
Note You cannot use the drag-and-drop method to create a custom page style.

Applying styles

Styles can be applied easily by means of the Styles and Formatting window. However, alternative
ways exist to apply certain styles, as explained in this section.

Applying paragraph styles

When drafting a document, the most used style is the paragraph style. LibreOffice offers two quick
alternatives to the Styles and Formatting window to apply this category of style: the Apply Style list
and the Format Paintbrush button.

Using the Apply Style list

When a paragraph style is in use in a document, the style name appears on the Apply Style list
near the left end of the formatting bar, to the right of the Styles and Formatting button. You can
select styles from this menu, just as you can from the Styles and Formatting window.

B-E-EHA
|_|E| Default Style|

L Clear formatting

Default Style
Text Body

(Quotations

Title
Subtitle

Heading 1
Heading 2

Heading 3
Figure 197: Apply Style list

To apply a style from this menu, place the cursor in the paragraph to change, click on the desired
style or use the up or down arrow keys to move through the list, then press Enter to apply the
highlighted style.

Tip Select More at the bottom of the list to open the Styles and Formatting window.
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Using the Format Paintbrush

You can use the Format Paintbrush to apply a certain paragraph style to another paragraph or to a
group of paragraphs. Start by placing the cursor inside the paragraph you want to copy. Table 6
shows the formatting copied as a result of a particular cursor position. Table 7 shows the formatting
painted as a result of the format copied and the cursor position when painting. Cases A, B, and C
refer to the example shown in Figure 198.

Table 6: Cursor positioning

Case Type of selection Action
A No selection. Cursor in the Copies the formatting of the paragraph and the
space between two words. character formatting of the next character in the
text flow direction.
B No selection, cursor in any As above.
word.
C Text selected. Copies the formatting of the last selected

character and the paragraph.

Table 7: Format Paintbrush click position

Case Paint position Result

selection

A,orB,orC In a space between words. Paragraph formatting only.

A In a word or selection. As above.

B,orC In a word or a selection. Paragraph formatting applied.

Word or selection formatted with character
format from original paragraph.

Now do one of the following:
1) To format a single paragraph:

2)

a)

b)

c)

Click the Format Paintbrush icon ( & ) in the Standard Toolbar.

The cursor changes into an ink bottle ( e ). Now click the paragraph (see Table 7) to
which you want to apply the copied style.

If you press Shift+Ctrl while clicking, you exclude any character formatting wherever
you select to click.

The paragraph is formatted and the cursor then returns to normal

To format more than one paragraph:

a)
b)

Double-click the Format Paintbrush icon.

The cursor changes shape. Now click each of the paragraphs (see Table 7) to which
you want to apply the copied style.

If you press Shift+Ctrl while clicking, you exclude any character formatting wherever
you select to click.

The paragraphs are formatted. Click the Format Paintbrush icon once more, or press
the Esc key to revert to normal.

192

LibreOffice 4.2 Writer Guide



Quotations Y Liberation Sans v 12 V 8, A4 & || @ [

- g 1 2 3 4 5
L L L L L L L L L L L L L L L L L L L L L

EH

_| You can use the Format Paintbrush to apply a certain paragraph style to
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Figure 198: Showing the results of Table 6 and Table 7 on the unformatted paragraph

Example: Applying a paragraph style
Let's see the three methods described above in action with an example.
To use the Styles and Formatting method:
1) Create a new document (choose File > New > Text Document or press Ctrl+N).
2) Type the words Heading 1 in the new document, but do not press Enter so that the cursor
remains in that same line where you typed.
3) Click the Styles and Formatting button ( [ ) located on the Formatting Bar or press the
F11 key. This opens the Styles and Formatting window.
4) Make sure the window is showing the Paragraph Styles section: click on the top-left button
((3])) of the Styles and Formatting window if it's not.

|_|E| Default Style v Libers Styles and Formatting x
e _
- Koo —rliE O o B 1= ~
Current style Complimentary Close A
Default Style: w

|Paragraph St-,rlesl First Line Indent
Hanging Indent
|St',rles and F-}rmaﬂingl Heading
. Heading 1
Heading 1| Heading 2
Heading 3
Heading 4
Heading 5
Heading &
Heading 7
Heading & v

Automatic v

Figure 199: Click on the Styles and Formatting button to bring up the window
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Double-click the Heading 1 entry of Styles and Formatting (Figure 200). This does two things:
* Gives the line (actually, its entire paragraph) you typed the Heading 1 style.
* Adds Heading 1 to the Apply Style menu.

\FH | | Heading 1 v || | Giestream vera sandwe| 1.2 [v| (B A4 A ||E]|[
£

= E R . | Styles and Formatting

[Heacing 1 added to the Apply Style list i f2] £ O] 8a ¥

Complimentary Close
Default Style

First Line Indent
Hanging Indent

Headi
Heading 1 |Hesas—{sseceome]

1
4

| >

Heading 2
Heading 3
Heading 4
Heading 5
Heading &
Heading 7
Heading & "

|Te>.'t with Heading 1 s*t',.rlal

Automatic il

Figure 200: Applying paragraph styles
To use the Apply Styles list (Figure 200):
1) Repeat steps 1 and 2 from the previous example.
2) Select Heading 1 in the Apply Styles list.

The text acquires the properties of the Heading 1 style. If the paragraph style you want is not in the
Apply Style list, select More to bring up the Styles and Formatting window. If the Styles and
Formatting window is still open, you may notice that the Heading 1 style is also highlighted in the
main window, as shown in Figure 200.

Finally, try the Format Paintbrush.

Recreate the text in Figure 198 and add extra formatting to some of the text; bold and italic was
used in the example. Place the cursor at a point in the text and click the Format Paintbrush icon (

& ) to activate it. The cursor changes shape. Move the cursor to one of the new paragraphs and

left-click to apply formatting. Try the different selection points and the different paint points to see
the effects. To apply the formatting to multiple paragraphs, double-click the Format Paintbrush
icon before clicking at a paint point. Clicking back on the icon, or pressing the Esc key, cancels the
format painting.

The cursor shape changes back to the normal one on completion.

Applying character styles

You may have a document that contains character formatting applied directly using the Formatting
toolbar or shortcut keys, and you decide to replace this with character styles formatting. The direct
formatting should be removed before applying new character styles.

To remove the formatting manually, select the characters or words to be altered:
¢ Select Format > Clear Direct Formatting
e Alternatively, press Ctrl+M.

You can now proceed to apply character styles.
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Select all the formatting of one type at a time. Manually removing this formatting
leaves the text elements selected so you can then apply the new character style
immediately.

For example, to remove a number of manually italicized elements:

1) Select each instance (press Ctrl when selecting each subsequent element).

2) Use one of the methods above to remove the formatting (the text remains
selected after removal).

3) In this example, pressing Ctrl+/ will also toggle off italics.

4) Apply the character style (for example, Emphasis).

Repeat for each formatted style you wish to replace.

Tip

Using the Styles and Formatting window

Open the Styles and Formatting window (press F11) and click the second button in the top bar. The
list of available character styles is displayed. To apply a character style, follow these steps:

1) Select the block of text, or put the cursor into the single word, where you wish to apply the
style.

2) Double-click the appropriate character style in the Styles and Formatting window.

Some character styles supplied in LibreOffice include:

Emphasis character style.
Strong Emphasis character style.

Teletype character style.

One difference between character styles and paragraph styles is the need for
selecting text (highlighting). To apply a character style to more than a single word,

Note you need to select all of the text to be changed. To apply the style to a single word,
you only have to place the cursor in the word. Paragraph styles are applied to the
whole of the paragraph in which the cursor is placed.

Using the Format Paintbrush
The Format Paintbrush can be used to apply character styles in much the same way as for
paragraphs (see “Using the Format Paintbrush” on page 192).

The difference is that you must select a word that has the required formatting, and that to paint
only the character style, without the underlying paragraph style, you must hold down the Ctrl key
when applying the style.

Unset/undo character styles

Sometimes, you will want to remove the character style formatting from a block of text. You must
resist the temptation to do this manually using the Formatting toolbar. This will only cause trouble
down the road. To remove character style formatting from selected text:
1) Open the Styles and Formatting window (press F11) and click the second button (Character
Styles) in the top bar.

2) With the Styles and Formatting window open, double-click the Default character style.

Chapter 6 Introduction to Styles 195



Applying frame styles

Whenever you insert an object (such as a graphic) into a document, it will automatically have an
invisible frame around it. Some designers like to add frame styles to introduce variety. For
example, you could have one frame style for photographs and a different frame style for other
graphics such as line drawings. The one for photographs might have a border with a drop shadow,
while the one for drawings might have only a border.
To apply a style to a frame:

1) Select the frame.

2) Bring up the Styles and Formatting window (for example, by pressing F11).

3) Click the Frame Styles icon (the third one from the left).

4) Double-click the frame style you want.
Having applied a style to a frame, you can now modify the frame to be just how you want it. Most of
a frame’s design can be set in a style, but the following options must be set manually:

* Anchoring: how the frame is positioned in relation to the rest of the page’s contents
(Format > Anchor).

* Arrangement: the frame’s position in a stack of objects (Format > Arrange).

* Adding a hyperlink: so that a click on the frame opens a Web page or another document in
an HTML file (Insert > Hyperlink).

When a frame is selected, the Frame toolbar replaces the Formatting toolbar, allowing you to
modify the settings. The right-click (context) menu also has items for anchoring and arrangement,
as well as for wrap and alignment.

Applying page styles

To apply a page style, place the cursor anywhere on the page to which the style should be applied.
You can easily check which page style is applied because it is shown on the status bar.

| Page 1/ 10 | 1161 words, 6289 characters | Default Style | English (LUSA) m | &

Current page style
I I

Figure 201: The current page style is displayed on the status bar

If you want to apply a different style, you can either right-click on the style in the status bar and
select a new style from the context menu, or you can open the Styles and Formatting window
(press F11), select the page style icon at the top of the window (fourth icon), and then double-click
on the desired style.

CEEl Changing a page style may cause the style of subsequent pages to change as

well. The results may not be what you want. To change the style of only one page,
you may need to insert a manual page break, as described below.

As discussed in Chapter 7, Working with Styles, a correctly set up page style will, in most cases,
contain information on what the page style of the next page should be. For example, when you
apply a Left page style to a page, you can indicate in the style settings that the next page has to
apply a Right page style, a First page style could be followed by either a Left page style or a
Default page style, and so on.
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Another very useful mechanism to change the page style is to insert a manual page break and
specify the style of the subsequent page. The idea is simple: you break a sequence of page styles
and start a new sequence. To insert a page break, choose Insert > Manual Break and choose
Page break. This section illustrates two common scenarios where page breaks are useful.

Example: Chapters

A possible scenario: You are writing a book that is divided into chapters. Each chapter starts with a
page style called New Chapter. The following pages use the Default page style. At the end of each

(except the last) chapter, we return to the New Chapter page style for the first page of the next
chapter.

Figure 202 illustrates the flow of page styles when using page breaks.

First
Page

MNew
Chapter

Default Default

Y

Page
Break
¥

Figure 202: Page style flow using a page break

Writer doesn’t have a predefined New Chapter page style, so you must create a custom style (see
Chapter 7). (You could also use the First Page style for this purpose, but in our examples we use

that style for the title page of the book.) Let’s suppose that you already have the page styles with
the following properties:

Page style Next Style
New Chapter Default
Default Default

At some point, you will want to start a new chapter. Follow these steps:
1) Put the cursor at the end of the chapter, on a blank line (empty paragraph) of its own.
2) Choose Insert > Manual Break. The Insert Break dialog (Figure 203) appears.
3) Under Type, choose Page break and under Style, select New Chapter.

Insert Break

Type
() Line break

Ok

(%) Page break
Style

Mew Chapter
HTML -
[ndex

Left Page

Mew Chapter

NOnConvrinht b
Figure 203: Choose Page break and select the
New Chapter page style

Help
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Example: Page with special formatting

Sometimes you may need to insert a page with special formatting, for example a landscape page
or a page with more columns. This can also be done with page breaks. Suppose that the current
page has the Default Style page style.

1) Choose Insert > Manual Break.

2) Select the desired page style (say, Special Page) in the Insert Break dialog.

3) Fill in the contents for this page. Then insert another page break.

4) Then select Default Style again. The pagination continues on as normal, except that one
page has been replaced by a different page style.

This concept is illustrated in Figure 204.

| |
| |
| 2 | o
D )
» |Default D'JI ﬁ @m’i‘ cnl % Default .
Page )= = e ©|c | |Page

g s Im ? o |0

I I

Figure 204: Inserting a page with special formatting

Applying list styles

List styles define properties such as indentation, numbering style (for example, 1,2,3; a,b,c; or
bullets), and punctuation after the number, but they do not by themselves define properties such as
font, borders, text flow, and so on. The latter are properties of paragraph styles.

If you need your list to have specific paragraph-style properties, you should embed the list style
into paragraph styles, as explained in Chapter 7. You can then create a numbered list by applying
paragraph styles alone.

Writer has two series of predefined list styles, named List and Numbering. Each series contains
five list styles, intended for the different levels of a nested list. As with any style, you can redefine
the properties of these styles, for example the numbering or bullet symbol and the indentation. You
can also define other list styles in these series or create your own series.

Each of the list styles predefined in Writer has four associated paragraph styles. For example, the
Numbering 1 list style is associated with four paragraph styles:

*  Numbering 1

*  Numbering 1 Cont.

* Numbering 1 End

* Numbering 1 Start

Numbering 1 is a default paragraph style to which you can attach a list style. If you want to make
exclusive use of paragraph styles and never use the Formatting toolbar when creating a numbered
list, you could use the other three styles. All you need to do is to create a suitable list style and set
up the Next Style property in the Organizer page of the Paragraph Style dialog so that the
Numbering 1 Start paragraph is followed by the Numbering 1 Cont. style, while the Numbering 1
End paragraph style is followed by a default style paragraph.

If you only want to apply a list style (that is, the numbering or bullet symbol and the indentation)
then, when the cursor is on the paragraph, double-click on the desired list style.

When creating a list style, you can define up to ten levels of depth for nested lists. Switch from one

level to the other with either the Promote One Level ( <~ ) or the Demote One Level ( “ )
buttons on the Bullets and Numbering toolbar or by pressing the Tab key (one level down) or
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Shift+Tab key combination (one level up) or by right-clicking on the list element and select Up One
Level or Down One Level from the context menu.

Restarting or continuing the numbering

When creating more than one numbered list of the same type within the same chapter, Writer
applies sequential numbering to all the lists. Sometimes this is what you want (for example, when
placing illustrations between the numbered paragraphs), while at other times you want to restart
the numbering.

To restart numbering from 1, you can do any of the following:

* Click on the Restart numbering icon ( [:f] ) on the Bullets and Numbering toolbar.

* Right-click on the first element of the list and choose Restart numbering from the context
menu.
* Right-click on the first element of the list, choose Paragraph from the context menu, and

go to the Outline & Numbering tab of the Paragraph dialog. In the Numbering section,
select the options Restart at this paragraph and Start with, and set the number (see

Figure 205).
7 1
Paragraph
Indents & Spacing Alignment Text Flow

Cutline & Mumbering Tabs Drop Caps Borders Background
Outline

Outline level: Body text A4
Humbering

Mumbering style; Mumbering 1 A4

1 £

Figure 205: Restarting numbering

If you find that the numbering does not restart as intended using the first or second method, or if
you want to restart from a number greater than 1, use the third method.

When editing a document, you may want to change from restarting numbering to continuing the
numbering from a previous list. To do so, right-click on the list element and choose Continue
previous humbering from the context menu.

Modifying styles

Writer provides several predefined styles, but you may find that they do not fit your preferences.
You can build your own library of custom styles to use in place of the predefined ones, or you can
modify the existing styles. LibreOffice offers four mechanisms to modify both both predefined and
custom (user-created) styles:

* Update a style from a selection.

* Load or copy styles from another document or template.
* Change a style using the Style dialog.

* Use AutoUpdate (paragraph and frame styles only).
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The first two methods are discussed in “Update Style (from a selection)” and “Load Styles (from a
template or document)” on page 189, while Chapter 7, Working with Styles, discusses at length the
process of creating a new style.

This section shows how you can quickly make simple modifications to existing paragraph styles
using the same tools you would use for applying formatting manually.

Any changes made to a style are effective only in the current document. If you
want to reuse modified or new styles in other documents, you need to either save

Tip the styles in a template (see Chapter 10, Working with Templates) or copy the
styles into the other documents, as described in “Load Styles (from a template or
document)” on page 189.

Changing a style using the Style dialog

To change an existing style using the Style dialog, right-click on the style in the Styles and
Formatting window and select Modify from the pop-up menu.

The dialog displayed depends on the type of style selected. Figure 206 shows an example of the
dialog for a paragraph style. Each style’s dialog has several tabs. The various properties on these
dialogs are described in the next chapter.

Move to the page where the setting you want to modify is specified and input the new value. You
can click the Help button at any time to bring up the online help where all the options of the current
page are briefly described. When you are done, click OK to close the dialog.

ra "y
Paragraph Style: Default Style
Position Qutline & Mumbering Tabs Drop Caps Background Borders
Organizer Indents & Spacing Alignment Text Flow Font Font Effect
Indent
Before text: 0.00" %
After text: 0.00%  [%
First line: 0.00%  [%
_ |
[] automatic
|
Spacing I
Above paragraph: 0.00" e
Below paragraph: 0,00" ¢
[ ] Don't add space between paragraphs of the same style
Line spacing
Single V of
Register-true
|:| Activate

Figure 206: Example of the Paragraph Style dialog
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Examples: Modifying paragraph styles

For this example, we need five lines of text with three LibreOffice-supplied paragraph styles:
Heading 1, Heading 2, and Heading 3. These paragraph styles could be used in formatting
headings (subheads) in the framework for a document that will be “fleshed out” afterwards.

Open a new text document for this exercise and type Title on the first line, click the Paragraph

Styles icon on the Styles and Formatting window, and double-click Heading 1 in the drop-down

list. Press Enter to start a new line and type First section heading, applying the Heading 2 style.

Repeat this procedure for the other headings shown in Figure 207, using the proper paragraph

style for each: Heading 3 for Subsection heading, and so on.

Now, suppose you decide to make the following changes to these styles:

Titley
First section heading

Subsection heading

Another subsection headingf

Second selction heading

* Heading 1 should be centered.
* Heading 3 should be indented.

Center Heading 1

Figure 207: Headings 1-3 with default styles

On the Styles and Formatting window, select the Paragraph Styles icon (if it isn’t already chosen),
right-click on Heading 1, and choose Modify.

After the Paragraph Style window opens, choose the Alignment tab, select Center (as shown

below), and click OK.

Styles and Formatting

] & o E

Complimentary Close
Default Style

First Line Indent
Hanging Indent
Heading

Heading

Heading Mew...
Heading Modify
Heading - =
Heading Hide

Figure 208: Modifying a style
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Position Outline & Mumbering Tabs Drop Caps
Organizer Indents & Spacing Alignment Text f

Options

O Left

) Justified
Figure 209: Center Heading 1

Now, every paragraph marked as Heading 1 will be centered (as shown below). If you make
another Heading 1 entry, it will be centered as well.

Titlely
First section heading |
Subsection heading
Another subsection headingf

Second section heading

Figure 210: The text Title, which is formatted as a centered Heading 1 style

Indent Heading 3
On the Styles and Formatting window, right-click on the Heading 3 paragraph style and choose
Modify (as before). After the Paragraph Style dialog opens, follow the steps below:

1) Click the Indents & Spacing tab.

2) Under the Indent section, set the indentation before the text to .60", as shown below.

Your display might be different, depending upon what measurement unit was set in the
options (Tools > Options > LibreOffice Writer > General > Settings).

Position Cutline & Mumbering Tabs

Organizer Indents & Spacding Alignment
Indent

Before text: 0.60" -

After text: 0.00°

Eirst line: 0.00" =

[ ] automatic

Figure 211: Set indentation
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The result should resemble the illustration below.

TitleT
First section heading |
Subsection heading
Another subsection heading

Second section heading T

Figure 212: The text formatted as Heading 3 style is now indented

Using AutoUpdate

On the Organizer page of the Paragraph Style dialog is a check box named AutoUpdate. It is
present only for paragraph and frame styles. If this check box is selected, then LibreOffice itself will
apply to the style, any modification made manually to a paragraph formatted with that style.

Caution If you are in the habit of manually overriding styles in your document, be sure that
AutoUpdate is not enabled, or you will suddenly find whole sections of your
document reformatting unexpectedly.

Organiser Indents & Spacing Alignment || TextFlow || Font | FontEffects || Position

Hame Heading 1 ] autoUpdate
Mext Style Text body v
Linked with Heading V

Figure 213: The Organizer page of the Paragraph Style dialog

Creating custom paragraph styles: examples

You have seen that the Styles and Formatting window provides several predefined styles, such as
Heading 1 and Text body. But what if you need something different, like a poem style, that is not in
Styles and Formatting? With Writer you can make your own styles to suit your needs.

Chapter 7, Working with Styles, describes in detail the options on the various pages of the
Paragraph Style dialog. This section provides an example of a typical use of custom paragraph
styles.

We will create a Poem paragraph style and a Poem Header paragraph style, with the following
properties:

* Poem: Centered, with a font size of 10pt.
* PoemHeading: Centered, bold, with a 12pt font size.

In addition, a PoemHeading style is to be followed by a Poem style. In other words, when you
press Enter, the next paragraph style in the document changes to Poem.
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You may have noticed this behavior already. After you enter a heading using a

Note Heading paragraph style and press Enter, the next style switches to Text body.

Creating the Poem paragraph style

Our next example creates the Poem style. We will use the Default style as a starting point.
1) Click the Styles and Formatting button, or press F11.
2) Click the Paragraph Styles button.
3) Right-click Default Style and choose New.

The Paragraph Style dialog opens, with the Organizer page selected. To create a custom style,
you have to understand and configure the top three entries.

Style fields Description

Name This is the name of the style itself, like Heading 1 or Text body.
Set (type in the text box) the name to Poem.

Next Style This is the style of a paragraph that follows the paragraph that is in Poem
style. When you press Enter while typing text in the Poem style, this style
is applied to the new paragraph.

Set this value to Poem. When you press Enter, the text of the new
paragraph will remain in the Poem style.

Linked with If the Poem style is linked with another style, say Default Style, then any
change in Default will affect Poem, just as you saw with Heading in the
previous section.

For our example, this is not the behavior we want. Set this entry to
- None -. This means that Poem is not linked with any other style.

Select the Custom Styles category for new styles. After making these changes, your dialog should
look like Figure 217.

rParagraph Style W
Outline & Numbering Tabs Drop Caps Background Borders Condition
Organiser Indents & Spacing Alignment TextFlow | Font | FontEffects Position
Mame Poem [ ] AutoUpdate
Mext Style Poem hl
Linked with - Mone - w
Category Custom Styles v

Figure 214: Initial configuration for the Poem style. Set the first three entries as
shown.

The next step is to configure the alignment and font properties of this style.
* On the Alignment page, select the Center option.
* Onthe Font page, select the 12pt font size.

Click OK to save the new Poem style.
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Creating the PoemHeading style

Create a new PoemHeading style. Use the same procedure as before, using with these changes:
* Next Style: Select Poem, not PoemHeading.
* Linked with: Heading.

The dialog should look like Figure 215.

rParagraph Style -
Ciutline & Mumbering Tabs Drop Caps Background Borders Condition
Organiser | Indents & Spacing Alignment TextFlow | Font | FontEffects Position
Mame PoemHeading [] AutoUpdate
Mext Style |Pu:uem [v]l
Linked with |Heading [v]l
Category |Custom Styles v

Figure 215: Settings for the PoemHeading style

Now set the settings of the new style:
1) On the Alignment page, select Center.
2) On the Font page, choose Bold and size 14pt.

Click OK to save the new PoemHeading style.

Sample poem

It is a good idea to test out your new styles and see if you are happy with them. Typing a poem
using the styles we have just defined should produce the results in Figure 216.
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THE OLD SALT

I was walking through the Dockyard in a panie,

When I met a matelot old and grey.

Upon his back he had his kithag and hammock,

And this is what I heard him say.

I wonder, ves ] wonder,

Has= the Jaunty made a blunder,
When he served this draft-chit out for me,
For vears I've heen a stanchion,

['m the pride of Jago's mansion.

It's a shame to send me off to sea.

Page 1/ 1| Words: 77| Default Style | English (USA) | wl | | |

Figure 216: Sample poem
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Changing the formatting of your styles

One of the main advantages of styles is that they allow the document formatting to be changed
after the content has been written. For example, suppose you have written a 100-page book of
poetry. Then you decide you don't like the way the poems look after all. Or, perhaps, your publisher
doesn't like it.

To learn about reconfiguring styles, we add an indentation to the Poem style instead of centering it.

Indent Poem
First, set the Poem style to left alignment:
1) Inthe Styles and Formatting window, select Poem and right-click and select Modify.
2) On the Alignment page, select Left.
Set the indentation:
1) Click the Indents & Spacing tab.
2) Under Indent, set the indentation before the text to @.5in.

Done! Click OK, and you should see the text change.

Final result

After all these changes, the poem should look similar to Figure 217. Note in the figure that a third
style has been created for the author of the poem.
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THE OLD SALT

Iwas walking through the Dockyard in a panic,

When I met a matelot old and grey.

Upon his back he had his kithag and hammock,
- And thisis what [ heard him say.

I wonder, ves I wonder,

Has the Jaunty made a blunder,

When he served this draft-chit out for me
For vears ['ve been a stanchion,

I'm the pride of Jago's mansion.

W

It's a shame to z=end me off to sea. (2]

John Bush

n &
.‘ A - > -

Page 1/ 1| Words: 79 | Default Style | English (USA) ml | [* 0O G0

Figure 217: Final result, using three custom styles
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Deleting styles

It is not possible to delete LibreOffice’s predefined styles from a document or template, even if they
are not in use. However, custom styles can be deleted.

To delete any unwanted styles, in the Styles and Formatting window select each one to be deleted
(hold Ctrl while selecting multiple styles), and then right-click on a selected style and select Delete
in the context menu. If the style is in use, a message appears, warning you that the style is in use
and asking you to verify that you really want to delete the style.

If the style is not in use it is deleted immediately without confirmation.

Caution If you delete a style that is in use, all objects with that style will return to the style it
was based on (linked with) but retain some of the deleted style’s formatting as
manual formatting.

If an unwanted paragraph style is in use, you can use Find & Replace to replace it
Tip with a substitute style before deleting it. See Chapter 3, Working with Text, for
more information.

Assigning styles to shortcut keys

You can configure shortcut keys to quickly assign styles in your document. Some shortcuts are
predefined, such as Ctrl+1 for the Heading 1 paragraph style and Ctr/+2 for Heading 2. You can
modify these shortcuts and create your own. See Chapter 16, Customizing Writer, for details.

Defining a hierarchy of headings

Tools > Outline Numbering defines the hierarchy of headings in a document. Headings can be
numbered or not; typically the first-level headings in a book-length document are the next level of
headings after the chapter titles, which may be numbered, but lower-level headings are not
numbered. Some chapter title and heading styles (such as those commonly used in engineering
documents) number each chapter and heading level, for example 1, 1.1, 1.2, 2, 2.1, and so on.
When chapters or sections are added or deleted, the numbering is automatically changed.

Paragraph styles are the key to LibreOffice’s outline numbering feature. The default paragraph
styles assigned to outline levels are the heading styles supplied with LibreOffice: Heading 1,
Heading 2, and so on. However, you can substitute any styles you wish, including custom (user-
defined) styles.

The headings defined using the outline numbering feature can be used for more than the table of
contents (described in Chapter 12). For example, fields are commonly used to display headings in
headers and footers of pages (see Chapter 14, Working with Fields), and Writer can send the
outline to Impress to use as the basis for a presentation (see the Impress Guide for details).

Choosing paragraph styles for outline levels

If you are using the default heading styles for the headings in your outline, and you do not want to
use heading numbering, you do not need to do anything on the Outline Numbering dialog. The
default outline numbering scheme uses the default heading styles (Heading 1, Heading 2, and so
on).
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To use custom styles in place of one or more of the default heading styles:
1) Choose Tools > Outline Numbering to open the Outline Numbering dialog.

2) Click the number in the Level box corresponding to the heading for which you want to
change the paragraph style.

[§ Outline Numbering X
Numbering Position
Level Numbering
1 Paragraph Style My Heading 1
g Heading 2 v Heading 2
Heading 9 B .
é51 Index Heading 3
6 List Heading 4
My Heading 1 .
g My Heading 2 Heading 5
9 My Heading 3 N Heading 6
My Heading 4 Heading 7
iﬁ 10 Text body ® g
—pere T Heading 8
After ‘ Heading 9
Start at ‘1 m Heading 10

Figure 218: Choosing paragraph styles for outline levels

3) Inthe Numbering: Paragraph Style section, choose from the drop-down list the paragraph
style you want to assign to that heading level. In this example, you might choose
My Heading 1 to replace Heading 1 and for Level 2, My Heading 2 to replace Heading 2.

4) Repeat for each outline level that you want to change. Click OK when done.

Assigning outline levels to other styles

In Writer, you can assign an outline level to any paragraph style. This feature enables you to create
a table of contents that includes those headings along with the headings using styles listed in the
Outline Numbering dialog. For example, you might use a different sequence of styles for annexes
(appendixes), but you want the annex headings and subheadings to appear in the TOC at the
same levels as the chapter headings and subheadings.

To assign an outline level to a paragraph style, go to the Outline & Numbering page for the style,
and select the required outline level. Click OK to save this change.

Organizer Indents & Spacing Alignment Text Flow Font Font Effect

Paosition Outline & Mumbering Tabs Crop Caps Background Borders
Outline

Qutline level: Level 1 kel

Figure 219: Specifying an outline level for a paragraph style
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Setting up heading numbering

If you want one or more heading levels to be numbered, many choices are available; this example

defines a scheme to create headings that look like those in the illustration below.

1 This is a Heading 1

around to the next line.
1.2 Another Heading 2
1.2.1 This is a Heading 3
1.2.2 Another Heading 3
2 Another Heading 1
2.1 Another Heading 2
2.1.1  Another Heading 3

2.2 Another Heading 2

3 Another Heading 1

1.1 This is a Heading 2. It has far too many words in it, so it wraps

Figure 220: The numbering scheme to be set up

Use the Numbering page of the Outline Numbering dialog to define the numbering scheme and its

appearance. Figure 221 shows the default settings.

Mumbering | Position

Level Mumbering
il Paragraph Style
g Heading 1
4 Mumber Mone
5
& Character Style Maone
7
3
¢ 5 to
10 eparator
1-10 Before

After
Start at 1

Figure 221: Default settings on the Outline Numbering dialog

-
|

Heading 1
Heading 2
Heading 3
Heading 4
Heading 5
Heading &
Heading 7
Heading 8
Heading 9
Heading 10

1) Inthe Level list, choose 1. In the Number list, choose 1, 2, 3, .... The result is shown in the

preview box on the right in Figure 222.
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Numbering | Position
Level Mumbering
i Faragraph Style 1 Heading 1
% Heading 1 W Heading 2
: Mumber 1,2, 3 .. L Heading 3
] Character Style Maone v Heading 4
7 Heading 5
E Heading &

Figure 222: Specifying numbering of Level 1 headings

2) Inthe Level list, choose 2. In the Number list, choose 1, 2, 3, .... The Show sublevels list is
now active; it should show 2 (if not, choose 2). The result is shown in Figure 223.

Numbering | Position
Lewvel Mumbering

1 Paragraph Style 1 Heading 1
i Heading 2 %) 1.1 Heading 2
: Mumber 1,2, 3, ... v Heading 3

6 Character Style Mone w Heading 4

7 Heading 5

E Show sublevels 2 i Heading 6

Figure 223: Specifying numbering of Level 2 headings

3) Inthe Level list, choose 3. In the Number list, choose 1, 2, 3, .... The Show sublevels list
should show 3 (if not, choose 3). The result is shown in Figure 224.

Numbering | Position
Level Mumbering

1 Faragraph Style 1 Heading 1
- Heading 3 ¥ |1.1 Heading 2
; Number 1,2, 3 .. v 1.1.1 Heading 2
= Character Style Maorne " Heading 4
7 Heading 5
E Show sublevels 3 it Heading 6

Figure 224: Specifying numbering of Level 3 headings

These choices produce the layout shown in Figure 225.
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1 This-is-a-Heading-19
-I'l'

1.1 This-is-a‘Heading-2.-It-has-far-too-many-words-in-it,"so-it-wraps
around-to-the-nextline.y

1'|'
1.1.1 This-is-a-Heading-3Y
Figure 225: Results of numbering choices for headings

Setting up the indentation of headings

Whether or not the headings are numbered, you may want to change some of their formatting. For
example, you may want the second-level and third-level headings to be indented from the margin.
For numbered headings, you may also want the second line of long headings to line up with the
first word of the heading, not the number. For these changes, use the Position page of the Outline
Numbering dialog.

The Position page for documents created in LibreOffice is slightly different from the
Position page for documents created in earlier versions of similar programs that
Note are opened in LibreOffice. This difference is provided for backwards compatibility.
For more information, refer to “Position page for older documents opened in
LibreOffice” (under “Creating a new list style”) in Chapter 7, Working with Styles.

Positioning in new LibreOffice documents
Figure 226 shows the Position page as it appears for documents created in LibreOffice.

Mumbering |Paosition
Level Position and spacing
1 ..................... Mumbering followed by Tab stop v
5 Il
3 . -
t 0,30

" = E3
5 _ - 7
5 Mumbering alignment Left e
7

a Aligned at 0.00% 3
9

10 Indent at 0.30"  E
1-10

Figure 226: Setting up the position of level 1 headings

1) Inthe Level list on the left, choose 2. Change the values for Numbering followed by, at and
Aligned at, as shown in Figure 227. You may want to use a different value. This indents the
entire heading but does not affect the way long headings wrap around (see Figure 228).
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Mumbering | Position
Level Position and spacing

ER—
4 at 0.80" |3
5 2
6 Mumbering alignment Left b
. =
8 Aligned at 0.30" =
9
10 Indent at 0.30" 2
1-10

Figure 227: Indenting Level 2 headings

1 This-is-a-Heading-11
|'|'

1.1 This-is-a-Heading-2.-It-has far-too-many-words-in-it-so-itwraps
around-to-the-next-line.y

Figure 228: Result of changes to indentation of Level 2 headings

2) To change the wrapping behavior of long headings, change Indent at to a larger value, as
shown in Figure 229. The result is shown in Figure 230.

Numbering | Position
Level Position and spacing

R
4 at 080" |3
5 ]
& Mumbering alignment Left b
5 =
8 Aligned at 0.30" =
9
10 Indent at 0.80" -
1-10

Figure 229: Wrapping long headings

1 This-is-a-Heading-1
\I'l'

1.1 This-is-a-Heading-2.lIt-has-far-too-many-words-in-it,"so-it-wraps
around-to-the-next-line.y

Figure 230: Result of changing Indent at value
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3) Inthe Level list, choose 3. Change the values for Numbering followed by, at, Aligned at,
and Indent at, as shown in Figure 231. The final result is shown in Figure 232.

Mumbering | Position
Level Position and spacing

1

; : Humbering followed by Tab stop V
4 Qt 1.20" :
5 =
& Mumbering alignment Left b
. [l
8 Aligned at 0.60" Ge)
9

10 Indent at 1.20" =
1-10

Figure 231: Indenting level 3 headings

1 This-is-a-Heading-11
il

1.1 This-is-a-Heading-2.-It-has-far-too-many-words-in-it,-so-it-wraps
around-to-the-next-line y

1.1.1 This-is-a-Heading-3Y

Figure 232: The results of Level 3 settings
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Introduction

Chapter 6, Introduction to Styles, describes the basics of how to use, apply, and manage styles.
This chapter gives a more detailed description of how to create or modify a style, using the many
options available on the various pages of the Style dialog. You will learn how these options affect
the appearance of the style and how to use them efficiently. Examples and hints are also provided.

The Style dialogs share many of the same pages as the manual formatting dialogs, so you can
also use this chapter to help you apply manual formatting (though you do not need that if you use

styles).

Creating custom (new) styles

In addition to using the predefined styles provided by LibreOffice, you can add new custom (user-
defined) styles. In Chapter 6, two methods are given for creating a new style: the drag-and-drop
approach and the New Style from Selection icon in the Styles and Formatting window.

These methods are very convenient because it is possible to immediately check the visual effects
that the style produces before creating it. However, they may require you to access several
different menus, and you have a somewhat reduced amount of control on style (particularly when it
comes to organizing them). The method described in this chapter, therefore, concerns only the use
of the Style dialog.

The Style dialog

Open the Styles and Formatting window. Select the category of style you want to create by clicking
on the appropriate button in the top part of the Styles and Formatting window. For example, select
the third button from the left if you want to create a new frame style.

Right-click in the window and select New from the context menu. Except for the Page and List
styles, the style dialog which opens will be linked to one of the existing styles. You can choose a
different style from the Linked with drop-down list, or choose None.

The dialog that is displayed depends on the type of style you selected. Many of the pages are the
same as those that are displayed when manual formatting is applied. Therefore, if you are familiar
with manual formatting, you will find that you already know how to use most of the options.

The dialogs used to create a new style and to modify an existing style are mostly
Tip the same, but with one exception: conditional styles have a different dialog. See
“Working with conditional paragraph styles” on page 228.

The Organizer page

When creating a new style, the first page you need to set up is the Organizer, which is shown in
Figure 233. This page is common to all style categories, with only small differences between them.
Therefore, it is described only once.

Depending on the style you are creating, you will find the following information on this page:

* Name: present on all the categories. Use this field to give a name to the style you are
creating.

* AutoUpdate: only present for paragraph and frame styles. If it is checked, then Writer will
apply any modification made manually to a paragraph formatted with that style to the style
itself.
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Caution If you are in the habit of manually overriding styles in your document, be sure that
AutoUpdate is not enabled, or you will suddenly find whole sections of your
document reformatted unexpectedly.

P Sy

Paragraph Style
Cutline & Mumbering Tabs Drop Caps Background Borders Condition
Organizer Indents & Spacing Alignment Text Flow Font Font Effect Position

Style
Mame Hazzard [] AutoUpdate
Mext Style  [Default Style w
Linked with |- Mone - W
Category Custom Styles L
Contains

Figure 233: The Organizer page displayed when a new Paragraph style is created.

* Next Style: only available for paragraph and page styles. Use it to specify which style will
be applied to the next element. It is customary, for example, to have a left page style
followed by a right page, a first page followed by a left page, a heading followed by body
text, and so on. You will see in the example later how this property is used. Predefined
paragraph styles for lists or bullets also make large use of the Next Style property.

* Linked with: available for paragraph, character, and frame styles; it determines the
position of the style in the hierarchy. When creating a new style and linking it to an existing
style, all the starting properties of the style are copied from the linked style.

e Category: available for all styles; use it to associate the new style with one of the
categories. Note that you cannot change the category of the predefined styles. Setting this
field is useful when filtering the contents of the Styles and Formatting window.

* Contains: shows a summary of the properties of the style.

Understanding linked styles Heading

When creating a new paragraph or a new character style, you Heading 1
may use an existing style as a starting point for its settings. In this

sense, LibreOffice links the styles together. Heading 2

When styles are linked, a change in the parent style affects every

style linked to it. You can easily visualize the connections between Heading 3
styles by switching to the Hierarchical view in the Styles and Head
. . ) ) ng 4
Formatting window filter. For example, every Heading style (such
as Heading 1, Heading 2) is linked with a style called Heading. . . .
This relationship is illustrated in Figure 234. Figure 234: Hierarchical
view of linked styles.

Linking styles is a very powerful method to create “families” of styles and allows you to change
their properties simultaneously. For example, if you decide that all the headings should be green
(such as in this guide), you only need to change the font color of the parent style to achieve the
desired result. Note however, that changes made to a parameter of the parent style do not override
changes previously made to the same parameter in the child styles. For example, if you changed
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the Heading 2 font color to green, a change of the font color of the Heading style (the parent style)

to red will not affect the Heading 2 font color.

You can easily check which properties are specific to a style by looking at the Contains section of
the Organizer page. In case you want to reset the properties of a child style to that of the parent
style, click the Standard button located at the bottom of each Paragraph and Character style

dialog page.

Note

Creating a linked style

You cannot define a hierarchical style structure for Page, Frame and List styles.

To create a linked style, you can either specify the parent style (the “linked with” style) in the
Organizer page of the Style dialog, or you can start creating a new style by right-clicking in the
Styles and Formatting window on the style to be linked with and selecting New from the drop-down

menu.

Example: Changing a property of a parent style

Suppose that you want to change the font of not only
Heading 1 or Heading 2, but all headings. The easiest
way to do that is to take advantage of linking.

Open the Styles and Formatting window (press F11),
select the Paragraph Styles category, right-click on
Heading, then select Modify to open the Paragraph
Style dialog for the Heading style.

Select the Font tab, then select a font and click OK.

Styles and Formatting =

v {a] & @ 5

Frame Contents ~
Hanging Indent B |
Header

Header Left

r?ﬁl ﬂ; -

HEEIE'II'I Mew. ..
Heading -

Heading  Modify...
Headind  Hide
Headin —

Figure 235: Select Heading style.

-

Figure 236: Select the Heading font.

y
Paragraph Style: Heading
Position QOutline & Mumbering Tabs Drop Caps Background Borders
Qrganizer Indents & Spacing Alignment Text Flow Font Font Effect
Font Style Size
Bitstream Vera Sans Regular 14pt
Accent SF ~| |Regular 10, 5pt A
Accord Heavy SF =1 [Italic 11pt b |
Accord Light SF | |Bold 12pt
Accord SF Bold Italic 13pt
Adamsky CQutline SF 14pt
Adamsky 5F 15pt
Adventurer Black SF 16pt
Agency FB 13pt
Aharoni 20pt
Alhany ] 22nt ]

Now, the fonts of all the heading styles (Heading 1 through Heading 10) are changed in a single
operation. Figure 237 shows on the left a document using the headings 1, 2 and 3 and on the right
the same document after changes have been made to the Heading style.
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B o234 56 w1 4 1 2 3 f 5 8
- Title (Heading 1) : Title (Heading 1)
5 Subtitle 1 (Heading 2) ~ Subtitle 1 (Heading 2)
"-‘ Section 1.1 (Heading 3) # Section 1.1 (Heading 3)
Section 1.2 (Heading 3) . Section 1.2 (Heading 3)
" Subtitle 2 (Heading 2) ﬂ Subtitle 2 (Heading 2)

Figure 237: Effects of changing the Heading style font.

Working with paragraph styles

Although this section describes most of the parameters scattered over the twelve tabbed pages
shown in Figure 236, you do not need to configure them all. In fact, in the vast majority of cases it
is sufficient to modify only a few attributes, particularly if you make use of the linking properties of
styles or when basing the new style on one which is already similar.

Settings on the Indents & Spacing page

On the Indents & Spacing page, you can set up the parameters that affect the position of the
paragraph on the page and the spacing between lines and between this paragraph and the
paragraphs nearby. The right hand side of the page shows a preview of the applied settings.

Use the Indent section of the page to set up the indentation, using these parameters:

¢ Before text: controls the space in the selected unit of measurement between the left
margin of the page and the leftmost part of the paragraph area. Entering a negative value
results in the text starting on the left of the margin. This may be useful in situations where
your left margin is quite wide, but you want the headings to be centered in the page.

* After text: controls the space in the selected unit of measurement between the right
margin of the page and the rightmost part of the paragraph area. Entering a negative value
results in the text extending into the right margin of the page.

* First line: enter the offset in this box (either positive or negative) of the first line of the
paragraph relative to the paragraph area. A positive value increases the indentation of the
first line, while a negative value makes the first line start to the left of the paragraph area.

¢ Automatic: check this box to allow Writer to automatically control the indentation of the first
line. The value is calculated by Writer on the basis of the font size and other parameters.

Use the Spacing section of the page to determine the amount of vertical space above and below
the paragraph. It is customary to include some “space above” in heading styles so that they are
separated from the text body of the previous section without the need to insert empty paragraphs.
Spacing between paragraphs is also normal in certain types of documents. The body text style of
this guide is configured to leave some space between consecutive paragraphs.
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Position Cutline & Mumbering Tabs Drop Caps Background Borders

Organizer Indents & Spacing Alignment Text Flow Font Font Effect
Indent

Before text: b.o0" 3

After text: 0.00" E=

First line: 0.00" [
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|

Spacing [ ]

Above paragraph: 0.08" [
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[ ] Don't add space between paragraphs of the same style
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Single s | of

Register-true
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Figure 238: Settings on the Indents and Spacing page of a paragraph style dialog

The option to remove space between paragraphs of the same style is available by selecting the
check box.

The spacing between paragraphs does not affect the spacing between lines, which is controlled
using the drop-down box in the Line spacing section. You can select one of the following values:

* Single: the default setting—applies a single line spacing to the paragraph. This is
calculated automatically based on the font size.

* 1.5 lines: sets the line spacing to 1.5 lines.
* Double: sets the line spacing to 2 lines.

* Proportional: this value activates the edit box next to the drop-down list where you can
enter a percentage value. 100% means a single line spacing, 200% double line spacing
and so on.

e At least: this choice activates the edit box next to the drop-down list, where you can enter
the minimum value (in your selected unit of measurement) to be used for the line spacing.

* Leading: if this is selected, you can control the height of the vertical space between the
base lines of two successive lines of text, by entering a value, which is summed with the
value of single line spacing, into the edit box.

* Fixed: this choice activates the edit box next to the drop-down list, where you can enter the
exact value of the line spacing.

When using different font sizes in the same paragraph, the line spacing will be
uneven, as Writer automatically calculates the optimal value. To obtain evenly

Tip spaced lines, select Fixed or At least in the drop-down list and a value that is
large enough to create a spacing between the lines sufficient to account for the
largest font size used.
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The last parameter that can be set in this page is Register-true. This is a typography term that is
used in printing. This term refers to the congruent imprint of the lines within a type area on the front
and the back side of book pages, newspaper pages, and magazine pages. The register-true
feature make these pages easier to read by preventing gray shadows from shining through
between the lines of text. The register-true term also refers to lines in adjacent text columns that
are of the same height.

When you define a paragraph, Paragraph Style, or Page Style as register-true, the base lines of
the affected characters are aligned to a vertical page grid, regardless of font size or of the
presence of graphics. This aligns the baseline of each line of text to a vertical document grid, so
that each line is the same height.

To use this feature, you must first activate the Register-true option for the current page style. If you
have activated the Register-true for the page style in use (refer to “General settings for the page
style” on page 235) then the Reference style and all the styles hierarchically dependent on it will
have the Activate Register-True box selected. You may also, however, want to activate the
vertical grid for other styles (or not apply it to styles dependent on the reference style) and this is
where this can be done.

Settings on the Alignment page

Use the Alignment page to modify the horizontal alignment of the text, choosing between Left,
Right, Center, and Justified. The results of the selection are shown in a preview window on the
right-hand side of the page.

When selecting the Justified alignment, you can also decide how Writer should treat the last line of
the paragraph. By default, Writer aligns the last line to the left, but you can choose to align it to the
center or to justify it (meaning that the words on the last line will be spaced in order to occupy it
fully). If you have selected to justify the last line and select the Expand single word option, then
whenever the last line of a justified paragraph consists of a single word, this word is stretched by
inserting spaces between characters so that it occupies the full length of the line.

The alignment page is also used to control the Text to Text vertical alignment—useful when you
have mixed font sizes on the same row. Choose the element of the fonts on the line that will be
aligned between Automatic, Baseline, Top, Middle, Bottom. Refer to Figure 239 for a visual
representation of these reference points.

SphinX spine SPHINX_Sphinx
Sphinx *"™ Sphinx Sphinx
Sphinx sehinx SphinX Sphinx
SphinX spnine SPhiNX Sphinx

Figure 239: Text to text vertical alignment: Baseline, Top, Middle, Bottom

Text flow options for paragraph styles

The page of the dialog controlling the text flow options is shown in Figure 240. This page is divided
into three parts: Hyphenation, Breaks, and Options.
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With Hyphenation selected, three parameters are settable:

* Characters at line end: controls the minimum number of characters to be left on a line
before inserting a hyphen.

* Characters at line begin: controls the minimum number of characters that can be placed at
the beginning of a new line following a hyphen.

*  Maximum number of consecutive hyphens: controls the number of consecutive lines that
terminate with a hyphen.

If you prefer Writer to automatically control the hyphenation, select the Automatically option.

Position Outline & Mumbering Tabs Crop Caps Background Borders
QOrganizer Indents & Spacing Alignment Text Flow Font Font Effect
Hyphenation
Automatically
2 %1 Characters at line end
2 1 Characters at line begin
a 1|  Maximum number of consecutive hyphens
Breaks
Insert Type [Page b Position [Before |w
With Page Style Default Style |» | Page number |0 &
Options

o not split paragraph

[] keep with next paragraph
Crphan contral 2

4

Lines

Lines

=]
Lt

Figure 240: The options on the Text Flow page of the Paragraph dialog

In the Breaks section, you can require a paragraph to start on a new page or column, as well as
specify the position of the break, the style of the new page, and the new page number. A typical
use for this option is to ensure that the first page of a new chapter always starts on a new (usually
right-hand) page.
To always start a style on a new page, choose the following settings on the Text Flow page of the
Paragraph Style dialog:

1) Inthe Breaks section, select Insert. Make sure that Type is set to Page and Position is set

to Before.
2) Select With Page Style and choose the page style from the list.

3) To continue page numbering from the previous chapter, leave Page number set at 0. To
restart each chapter’s page numbering at 1, set Page number to 1. Click OK.

If you want the first page of a new chapter to always start on a right (recto) page,
make sure that the page style for the first chapter page is set for the right page only

Note by making this selection in the Layout settings field on the Page tab of the Page
Style dialog.

222 LibreOffice 4.2 Writer Guide



The Options section of the Text Flow page provides settings to control what happens when a
paragraph does not fit on the bottom of a page:

* Do not split paragraph means that the paragraph is never split across two pages. If it
does not fit on the bottom of one page, the entire paragraph moves to the top of the next
page.

* Keep with next paragraph is appropriate for headings or the lead-in sentence to a list, to
ensure that it is not the last paragraph on a page.

* Orphan control and Widow control. Widows and orphans are typographic terms. An
orphan is the first line of a paragraph alone at the bottom of a page or column. A widow is
the last line of a paragraph that appears alone at the top of the next page or column. Use
these options to allow paragraphs to split across pages or columns but require at least two
or more lines to remain together at the bottom or top of a page or column. You can specify
how many lines must remain together.

Font options for the paragraph style

Three pages of the Paragraph Style dialog are dedicated to settings controlling the appearance of
the font, namely, the Font, Font Effects, and Position pages. The use of the first two pages is
straightforward. Many of the options used when creating a character style are discussed in
“Creating a new character style” on page 231. Options that can be used when creating a
paragraph style are described here.

Specifying a relative font size

If you are creating a style based on another style (linked style), you can specify a font size relative
to that other style—either as a percentage or as a plus or minus point value (—2pt or +5pt). Relative
font sizes are commonly used for Web pages.

For example, the paragraph style Heading 1 is based on the paragraph style Heading. The font
size of the paragraph style Heading is 14pt, and the font size of paragraph style Heading 1 is
specified as 130%. Thus, the resultant font size of text in a paragraph formatted with the Heading
1 paragraph style is 14pt times 130% = 18.2pt.

To specify a percentage font size: in the Paragraph Style dialog, select the Font tab. In the Size
box, enter the percentage amount followed by the symbol % (see Figure 241). Similarly, you can
enter a plus or minus sign followed by the number of points to be added or subtracted from the
base font size.

¥ 1
Paragraph 5Style: Heading 1

Position COutline & Mumbering Tabs Drop Caps Background Borders
Organizer Indents & Spacing Alignment Text Flow Font Font Effect

Font Style Size

Sitstream Vera Sans Bold 130%

Accent SF e Regular TI07s Y

Accord Heavy SF =1 |Italic 115% i |

Accord Light SF i Bold 120%

Accord SF Bold Italic 125%

Adamsky Cutline SF 130%%

Adamsky 5F 135%

Adventurer Black SF 140%%

Agency FB 145%:

Aharoni 150%

alhany ™) 1555 il

Figure 241: Selecting a type size based on a percentage
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To change from a relative font size back to an absolute font size, enter the desired font size in
points followed by the letters pt.

It is also possible to use a Percentage Font size for character styles.

Selecting a language for a paragraph style

The language you select for a document (on Tools > Options > Language Settings >
Languages) determines the dictionary used for spell checking, thesaurus, hyphenation, the
decimal and thousands delimiter used, and the default currency format.

Within the document, you can apply a separate language to any paragraph style. This setting has
priority over the language of the whole document. On the Font page of the Paragraph Style dialog,
languages with installed dictionaries are marked in the Language list by a small ABC icon (Figure
242). When checking spelling, Writer will use the correct dictionary for paragraphs with this style. If
you write documents in multiple languages, you can use the linked styles to create two paragraph
styles that differ only in the language option. If you then want to change some of the other
properties of the paragraph style, all you need do is to change the parent style.

To insert occasional words in a different language and avoid their being picked by mistake with the
check-spelling function, it is more convenient to use a character style, as discussed in “Creating a
new character style” on page 231.

Language

27 English (USA) {w]
English {Philippines) .
The same Fant will be used on both your prinker an| © English (South Africa)
English (Trinidad)
“& English (LK)
8% English (US&)
AI’ English {Zimbabmwe)

Esperanto

Figure 242: Selecting a language for a paragraph style

Options for positioning text

The Position page of the Paragraph Style dialog collects all the options that affect the position of
the text on the screen or printed page. This page is divided into three sections, plus a preview
area. They are: Position, Rotation/Scaling, and Spacing.

Organizer Indents & Spacing Alignment Text Flow Font Font Effect

Position Outline & Mumbering Tabs Crop Caps Background Borders
Position

(O superscript Raise lo

(" Subscript

Rotation / Scaling
(%) 0degrees () 90degrees () 270 degrees
Scale width | 100%: [

Spacing
Default »| by |0.0pt Pair kerning

Figure 243: The position page of the Paragraph Style dialog
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Use the Position section to control the appearance of superscripts and subscripts. However, you
will normally apply superscript and subscripts to groups of characters rather than to entire
paragraphs. Therefore, it is strongly recommended to change these parameters only when defining
a character style and, instead, leave the default settings for the paragraph styles.

The second section of the Position page controls the rotation of the paragraph area. Two common
uses for rotated paragraphs are:

* To put portrait headers and footers on a landscape page
* To fit headings above narrow table columns (as shown in Figure 244)

Another long heading

A rotaled heading
Another heading

Another heading
Anather heading
Another heading

Thisis long

Figure 244: A table with rotated headings

The Scale width box controls the percentage of the font width by which to compress or stretch the
rotated text horizontally. That is, from the first character to the last.

Chapter 4, Formatting Pages, describes how to create portrait headers and footers on landscape
pages by rotating characters. You can achieve the same effect by defining a separate header or
footer paragraph style specifically for landscape pages.

Example: Rotating the text in a paragraph style
As an example, we will apply rotated table headings to a pre-existing table.
1) Create a new paragraph style. Name it Table Heading Rotated.

2) On the Position page of the Paragraph Style dialog, in the Rotation / scaling section, select
90 degrees. Click OK to save the new style.

Rotation f scaling
() 0 degrees {*) 90 degrees () 270 degrees

Scale width 100% &

Figure 245: Rotating a paragraph 90 degrees

3) Select the heading row of the table and apply the new style. Any text in the cells of the
heading row is now rotated.

4) If the headings are aligned to the top of the cells, you may want to change the alignment to
the bottom of the cells, as shown in Figure 244. To do this, click the Bottom button on the
Table toolbar or select Format > Alignment > Bottom from the main menu.
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Spacing options
Use the Spacing section of the Position page to control the spacing between individual characters

in the paragraph. When selecting an option other than default in the drop-down menu, use the edit
box to enter the value in points by which you want to expand or condense the text.

The Pair Kerning option (selected by

default) increases or decreases the amount

of space between certain pairs of letters to | |
improve the overall appearance of the text. i ; | A i ’- i A
Kerning automatically adjusts the character |

spacing for specific letter combinations.
Kerning is only available for certain font ) ] )
types and, for printed documents, only works Figure 246: Kerning disabled (left) and enabled

if your printer supports it. (right).

Controlling tab stops

Although borderless tables are generally considered a much better solution to space out material
across a page, in many situations tabs are sufficient to do what you need, with the added
advantages of being simpler to manage and quicker to apply.

) If you need to use tabs, and you will be sending a document to other people, do not
Caution use the default tab stops. If the recipients of the document have defined default tab
stops that are different from the ones you are using, the paragraph may look very
A different on their machines. Instead, define the tab stops explicitly in the paragraph
or the paragraph style; then you can be sure that everyone will see the same layout.

To define tab stops in your paragraph style, use the Tabs page, shown in Figure 247. Here you can
choose the type of tab: left, right, centered, or decimal; the character to be used as a decimal point;
and the fill character—the characters that appear between the end of the text before the tab and
the beginning of the text after the tab. You can also create a custom fill character by entering it in
the corresponding box. Common use of a fill character is adding dots between a heading and a
page number in a table of contents or underscore character when creating a form to fill in.

QOrganizer Indents & Spacing Alignment Text Flow Font Font Effect
Position COutline & Mumbering Tabs Drop Caps Background Borders
Position Type Fill character

2.507 ® Left L (5) None =
Omwmt 3 O
L.70" (O Centered L B — Delete al

130 ) Decimal £

L] = O —
P (O Character

2.30" cl

Figure 247: Specifying tab stops for a paragraph style

Creating a new tab stop, therefore, is just a matter of deciding its position relative to the left margin,
the type, the fill character and clicking the New button. The tab stop will be entered in the Position
list on the left hand side. Unfortunately, the only way to modify the position of a tab stop is to create
a new one in the desired position and delete the old one using the buttons on the right-hand side of
the page.

Note that it is not possible to define tabs that exceed the page margin. In the rare cases where that
may be needed, use a borderless table instead.
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Using the Outline & Numbering page

Use the Outline & Numbering page if you want to number the paragraph, if for example this style is
to be used for a heading or list item.

You can assign an outline level to any paragraph style. This feature enables you to create a table
of contents that includes those headings along with the headings using styles listed in Tools >
Outline Numbering. For example, you might use a different sequence of styles for annexes
(appendixes), but you want the annex headings and subheadings to appear in the TOC at the
same levels as the chapter headings and subheadings.

To assign an outline level to a paragraph style, go to the Outline & Numbering page for the style,
and select the required outline level. Click OK to save this change.

This page should be used in combination with list styles when you need to associate a certain
paragraph style with a list style. Refer to “Combining list and paragraph styles” on page 245 for
additional information on how to use this page, as well as an example.

Crganizer Indents & Spacing Alignment Text Flow Font Font Effect

Position Outline & Murnbering Tabs Drop Caps Background Baorders
Outline

Qutline level: Level 1 w

Figure 248: Setting the outline level on the Outline & Numbering page

Setting up a drop cap

If you want your paragraph to use drop caps (usually this is suitable for a first paragraph style),
then you can predefine the properties in the Drop Caps page of the paragraph style dialog.
Selecting the option to display drop caps enables the subsequent options where you can fine tune
the appearance: the number of lines occupied, the number of characters to enlarge (if you want the
whole first word, check the corresponding box), and the space between the drop caps and the text.

Crganizer Indents & Spacing Alignment Text Flow Font Font Effect
Position COutline & Mumbering Tabs Drop Caps Background Borders
Settings

Display drop caps

[ ] whole word A

Mumber of characters: |1

4%

Lines: 3 =3
Space to text: 0.00% 5
Contents
Text: H
Character style: [Mone] il

Figure 249: Options for adding a drop cap to the paragraph style

Drop caps use the same font and have the same properties as the rest of the paragraph; however,
you can easily modify their appearance by creating a specific character style and using it. For
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example, you may want the drop caps to be of a different color or apply an outline effect. Select the
character style you want to use in the corresponding drop-down menu.

Setting up paragraph background and borders

Adding a background color and a border to a paragraph is a good way to make it stand out without
having to insert a frame. You can customize the background and border of the paragraph areas
using the corresponding pages of the Paragraph Style dialog. In addition to highlighting, borders
are also often used to separate header and footer areas from the main text area (such as in this
guide) as well as to provide decorative elements in some heading styles.

The two pages are fairly intuitive. You may want to pay attention to the following points when
working with the Background page:

* In case you do not find the desired color in the list of predefined ones, you can define your
own by selecting Tools > Options > LibreOffice > Colors.

* You can use a graphic instead of a solid color as background. In the As drop-down list,
select Graphic, then select the graphic object you want to use and adjust the parameters,
as required. Detailed instructions on working with graphic backgrounds can be found in the
Impress Guide.

¢ Different backgrounds can be selected for the paragraph area and for the characters in the
paragraph. Select Paragraph in the For box for the paragraph background, and Character
for the background of the text. View your choices in action by clicking Apply. To accept
your choices click OK. Click Standard to return all the settings to defaults for a modified
style.

* The background is only applied to the paragraph area. If you have defined an indented
paragraph, the space between the paragraph and the margin does not have the
paragraph’s background color.

f all the fishes in the sea the mermaid is the one
for me.

ow 15 the time for all good men to come to the aid
of the party.

Figure 250: Different Paragraph and Character backgrounds set
On the Borders page, the following points are worth considering:

* Watch out for the effects that the spacing between borders and paragraph area produces
on indentations and tabulations.

¢ |f you want the border to be drawn around multiple paragraphs, leave the Merge with next
paragraph option at the bottom of the page marked.

Working with conditional paragraph styles

A conditional paragraph style is another way of formatting text differently in different parts of a
document. In some cases, you may find it saves time to use conditional styles rather than
switching between styles as you type.

Making a paragraph style conditional means it changes its formatting depending on where it is
used. For example, you may want the style MyTextBody to be black by default but turn white when
inside a frame with a blue background.
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Probably the most common use for conditional formatting is with single-style outlining. Single-style
outlining is a type of outline numbering designed with a Numbering style, rather than with Tools >
Outline Numbering. Instead of using different styles, it changes the number formatting whenever
you press the Tab key to create a subordinate heading.

The only trouble with single-style outlining is that all levels look the same. This is where a
conditional paragraph style comes in handy. Assign the paragraph style to an outline numbering
style in the Outline & Numbering page and then open the Condition page. There, you can assign
the levels of the outline numbering style to other paragraph styles. Then, when you press the Tab
key while using the paragraph style, each level of the outline takes on different formatting, making
single-style outlining even more convenient than it is on its own.

Predefined styles (other than Text body) such as Default, Heading 1, and Heading

Note 2 cannot be set to be conditional.
Caution If you want to make a style conditional, you have to do it while the style window is
still open for the first time. After the window closes, the Condition tab no longer
appears in the window.

Organizer || Indents & Spadng ||Alignment || Text Flow ||Font | Font Effects |Position | Outline & Mumbering | Tabs

Drop Caps Backaround Borders Condition
Options
Conditional Style
Context Applied Styles Paragraph Styles
6th Outline Level | |List Indent S
7th Outline Level Marginalia
ath Outline Level MNumbering 1
Sth OQutline Level Mumbering 1 Cont,
10th Cutline Level Mumbering 1 End
15t Mumbering Level Mumbering 1 Numbering 1 Start
2nd Mumbering Level Mumbering 2 Numbering 2

¢ 3rd Numbering Level
4th Mumbering Lewvel
5th Numbering Level

Mumbering 2 Cont,
Mumbering 2 End

&th Numbering Level NLIIleEF!ng 2 Start

7th Mumbering Level Mumbering 3

8th Mumbering Level Mumbering 3 Cont. |,
9th Mumbering Lewvel Pbsmn b i e

10th Mumbering Lewvel * | Hidden Styles hd

ove Apply

Figure 251: Condition page for paragraph styles

R

When you create a conditional style, you are saying “in this condition make this style look like that
other style”. For example, “When typing into a footer, make this style look like the my_footer
paragraph style; when typing into a table, make this style look like the table text paragraph style”.

In addition to setting the normal (unconditional) properties of the style, you need to define which
other style it will look like in different situations. You do this on the Condition page.
To set up a conditional paragraph style:

1) Define a new paragraph style.

2) Select all the paragraph properties for the style. Do not click OK!

3) Click the Condition tab.

4) Select the Conditional Style option.
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5) Select the first condition in the Context list (left side of the dialog) and select the style you
want for this condition in the Paragraph Styles list on the right-hand side.

6) Click Apply. The name of the paragraph style appears in the middle list.
7) Repeat steps 5 and 6 for each condition you want to have linked to a different style.
8) Click OK.

When the style is selected, you will see that the formatting of your text depends on the context.

Working with character styles

Character styles complement paragraph styles and are applied to groups of characters, rather than
whole paragraphs. They are mainly used when you want to change the appearance or attributes of
parts of a paragraph without affecting other parts. Examples of effects that can be obtained by
means of character styles are bold or italic typeface or colored words.

Two of the character styles used in this document are:

* Keystroke uses a custom KeyStroke style. For example:
“To set Writer to full screen, press Control+Shift+J".

* Menu paths use a custom MenuPath style. For example:
“To turn field shadings on or off, choose View > Field Shadings”.

Other ways of using character styles are described elsewhere in the Writer Guide. These uses
include making chapter numbers, page humbers, or list numbers larger than the surrounding text
and formatting hyperlinks. When inserting words in different language or words you do not want the
spell checker to detect as mistakes (for example procedure nhames in some programming
language), character styles are quite useful because you can define the language to be applied in
the character-style properties.

Why use character styles?

New Writer users often wonder, “Why use character styles?” or “How is this different from clicking
the bold icon to change the font typeface?” The following real-life event illustrates the difference.

Jean is a technical writer from Australia. She learned the value of character styles
after her publisher told her to unbold menu paths in her 200-page book. Jean had
not used character styles. She had to edit all 200 pages by hand, with some help
from Find & Replace. This was the last time Jean failed to used character styles.

Character styles do not have as many options as paragraph styles or page styles. Their benefits
are of a different nature.

* Formatting changes
As Jean’s story illustrates, the ability to make formatting changes throughout a document
can be important. Character styles provide this.

* Consistency

Character styles help ensure that typesetting guidelines are applied consistently.
* Focus on content

“Was | supposed to bold keystrokes? How about menus?”

A writer should not have to remember the answers to these questions. Typesetting details
distract you from the real content of your work. A properly named custom character style
(such as KeyStroke or MenuPath) will remove this burden from you.
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Creating a new character style

This section illustrates the use of the Character Styles dialog for creating a new character style.

The pages used to configure the character style have already been seen in the previous section on
paragraph styles. Therefore, once you are familiar with creating paragraph styles, it will only take a
few minutes to create a character style.

Use the Organizer to set up the hierarchical level of the new character style (if needed) and
to give it a name.

Use the Font page to determine the font, style, and size for your character style. As with
paragraph styles, you can specify the size as a percentage rather than providing the
absolute value. For example, 150% means that when the character style is applied to a
10pt font size, the new font size will be 15pt, while if applied to a 14pt font size, the new
size will be 21pt. You can also specify the Language of the text to which a certain
character style is applied, so you can insert words in a different language and have them
spell checked using the correct dictionary.

In the Font Effects page, you can set up attributes such as font color, underlining, relief, or
other effects. If you frequently use hidden text, for example, it is very convenient to define a
character style where the Hidden option is marked. This way you only need a few mouse
clicks to hide text. Relief effects may be appropriate for a drop cap or to give more
emphasis to the chapter number or other parts of the title (as it is the case of this guide).

You can use the Position page to create a subscript in case you are not satisfied with the
default one or even a sub-subscript which may be useful for certain scientific publications.
In the same page, you can create rotated, condensed, or expanded text.

When rotating a group of characters, you also need to specify whether the rotated

Note text should fit in the line or if, instead, it is allowed to expand above and below the

line. This property only becomes active for character styles.

Use the Background page to apply a colored background to the text. Applying a
background to a character style yields the same effect as using the Highlighting tool on the
Standard Toolbar.

Finish creating a character style by assigning a border and a shadow to the text, if so
desired.

Migrating to character styles

For people accustomed to formatting text manually, character styles can take some getting used
to. Here are some suggestions for making the transition easier:

Never mix character styles and manual formatting. Manual formatting supersedes
character styles. If you combine them, you may end up wasting hours in frustration trying to
figure out why your character styles don’t work.

Right-clicking and choosing Clear Direct Formatting removes manual formatting but not
character styles. To remove a character style, select the characters, then select the Default
character style.

Realize that clicking the Bold icon in the toolbar is not easier than double-clicking on a
character style that is preset for bolding the font typeface.

Leave the Styles and Formatting window open to make character styles easy to access.
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Working with frame styles

Frames are often used as containers for text or graphics. To provide consistency in the appearance
of frames used for similar purposes, it is a good idea to define styles for frames. For example, you
might want photographs to be enclosed in a frame with a drop-shadowed border, line drawings in a
frame with a plain border, marginal notes in a frame without a border but with a shaded
background, and so on.

Writer provides several predefined frame styles, which you can modify as needed, and you can
define new frame styles. The technique for defining and applying frame styles is similar to that for
other styles.

There is considerable overlap between the uses of frames and of sections for
Tip some page layout purposes. You may find it useful to take a look at Chapter 4,
Formatting Pages, for information about the use of frames and sections.

How frame styles work

When an object is added to Writer, it is automatically enclosed in a frame of a predetermined type.
The frame sets how the object is placed on the page, as well as how it interacts with other
elements in the document. You can edit the frame by modifying the frame style it uses or by using
a manual override when a frame is added to the document.

Because frames and objects are used together, it is sometimes easy to forget they are separate
elements. In some cases, such as charts, you can edit the frame and object separately, so the
distinction is worth remembering.

Unlike other elements that use styles, frames can be defined only partly by their style because their
use can vary so much. Several elements of frames, such as the anchor and protected elements,
need to be defined manually for individual frames.

You can format a frame manually when you select Insert > Frame. The dialog that opens contains
all the settings available when frame styles are set up, as well as some only available when the
frame is inserted. As with other styles, the most efficient way to format frames is in the Styles and
Formatting window.

Planning the styles

If you are using a mix of graphics, you may want to define two related styles, one with a border line
for graphics with white backgrounds and one without a border for all other backgrounds. You also
may want to design one or more frames for text only.

Otherwise, the default frame styles (listed in Table 8) cover most users’ needs. The only significant
addition that many users might need is one or more styles for text frames.

Table 8: Various frame styles and their uses

Style Comments and Use

Formula The frame style used for formulas. The default includes AutoSize, which
adjusts the size of the frame to the formula.

Frame The default frame style.
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Style Comments and Use

Graphics The default style for graphics. The defaults include autosizing to fit the
graphic, no text wrap, and a thin border around the frame. These are
reasonable defaults, except for the border. Unless the background of the
graphic is white and the document’s background also is white, the border
usually is unnecessary.

Labels The default style for use with File > New > Labels. It seems to be used by
LibreOffice automatically and is not intended for users at all.

Marginalia A style for placing a frame beside the left margin. As the name suggests, the
Marginalia style is intended for comments added in the margin of text. The
style also is useful for creating sideheads—headings against the left margin,
which often are used in technical documentation. To set up sideheads, create
body-text paragraph styles with two inches or more indentation from the left.
Then, place the cursor at the start of a body-text paragraph, add the frame,
and apply the Marginalia style.

OLE The default style for OLE objects and floating frames. The default places the
frame at the top and center of a body of text.

Watermark The default style for a watermark, a graphic placed as the background to a
body of text. The default is a Through wrap, with text passing over the frame
and anything in it. The graphic should be faint enough that text still is readable
over top of it.

Creating new frame styles

You can access frame settings by selecting New or Modify in the Styles and Formatting window
for a frame style.

* Type page: sets the size and position of the frame. One of the most useful options here is
AutoSize, which automatically adjusts the frame to the object it contains. If the frame style
is one used automatically, then this option should be selected.

* QOptions page: sets whether the contents of the frame are printed and able to be edited in a
read-only document. This page also sets the text direction, which is useful if you are using
the frame for contents in a language that uses right-to-left text direction.

* Wrap page: sets how text is positioned in relation to the frame and how close text comes to
a frame. If you want the frame contents to stand out from the paragraphs around it, set the
wrap to None. This probably is the single most important page for frames.

* Background page: sets the background color or graphic. This page is useful mostly for text
frames in complex page layouts, in which a text frame has an appearance different from the
general background of the page.

* Borders page: sets the line around the frame, if any. Many new designers make the
mistake of adding a border to every frame. However, when a colored background distinctly
marks the division between the frame’s contents and the rest of the page, borders are
unnecessary.

* Columns page: this page can be ignored unless the frame is being used for text. The page
is the same as is used to set up a page style, and its parameters are described in the
section “Columns page” on page 237.

* Macro page: sets a macro to use with the frame in order to trigger an action when the user
interacts with the frame. These options are useful only in an on-line Writer or HTML
document.
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Working with page styles

Page styles control page properties (margins, page size, header and footer, among others).
However, unlike paragraphs, which can have directly applied properties, pages only have a page
style and no directly applied properties.

Christian is a lawyer from California, USA. For his letters, the first page has his
letterhead, and subsequent pages only identify the recipient, the date, and the
page number. Christian does this using page styles. He also uses page styles to
comply with the spacing requirements (such as margins) for legal briefs in
California State courts.

This section describes how to create a new page style, explains the meaning of some of the
options in the Page style dialog, and illustrates their usage.

Creating a new page style
Unlike other styles, page styles can be created or modified only by using the Styles and Formatting
window. Open the Styles and Formatting window and click the Page Styles icon ( ol ). Right-click

anywhere in the window and select New. It does not matter if you right-click a style or right-click in
blank space.

The Page Style dialog contains eight pages.

Page Style: First Page

Organizer Page |Background |Header |[Footer |Borders || Columns |Footnote

Mame First Page

Figure 252: The tabbed pages for the Page Style dialog

The Organizer page

The Organizer page is described in “The Organizer page” on page 216.

The next style property

Use the Next style property to specify the style for the subsequent page style element. This
property is particularly important for a page style, as the following example demonstrates.

Setting up a title page

Consider a common scenario: you want the document to have a title page that is different from the
rest of the document:

* It should not have a header or page number.
* The left and right margins should be the same.

For the title page, we can use the predefined First Page page style that comes with LibreOffice,
and for the rest of the document, we can use the Default page style.

Figure 253 shows the required flow of page styles. On the Organizer page of the Default page
style, leave the Next Style property set to Default. On the Organizer page of the First Page style,
make sure that the Next Style property is set to Default.
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First
Default
Page —>

Figure 253: Flow of page styles

Depending on your requirement, it may be possible to achieve this just by using the
Default page style. On the document's first page, deselect the Same content on first
page option with Header on selected. The header can thus be omitted from the first

page.

Note

General settings for the page style

The Page page of the Page Style dialog is where you can control the general settings of the page.
The page consists of three sections, plus a preview area in the top right corner.

.,

Page Style: First Page

Organizer |Page Background |Header |Footer |Borders | Columns ||Footnote

Paper format

Format  fetter v
Width 3.50" :::
Height 11.00" :$:
Orientation @ Portrait
{:} Landscape Paper tray [From printer settings] V
Margins Layout settings
Left 0,79" :: Page layout Fight and left V
Right 0.79" = Format 1,2,3.. v
Top o.79" = [ Register-true

- P I
ENCE olyie

m

e

Bottom 0.79"

o

Figure 254: The Page page for the Page Style dialog

In the Paper format section, you can specify the size of the paper choosing from one of the many
predefined formats. Selecting “user”, you can use the Width and Height fields to define your own
paper size. If using a predefined format, select the orientation of the paper between portrait and
landscape. If your printer has more than one tray, you can specify the tray from which to print
pages in the new page style.

In the Margins section, specify the size of the margins in your preferred unit of measurement. If you
select Mirrored for Page layout in the Layout settings section, then the names of the margins
change from Left and Right to Inner and Outer.
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In the Layout settings section, choose the desired Page layout from the four available options.
Decide whether the page style being defined applies to both left and right pages (default), or
applies to right or left only. Some considerations:

* |f you plan to bind the printed pages using this style like a book, select a mirrored layout.
Use the Format drop-down menu to determine the page numbering style to apply to this
page style.

* A common practice in page layouts is to have asymmetrical page margins—both for left
and right margins and for top and bottom margins. There are various schemes for
accomplishing this. The most common of them follow these two general rules for printed
page layouts: (a) The outer margin (right margin on a right-hand page) would have a wider
margin than an inner margin (left margin on a right-hand page); (b) The bottom margin
would be larger than a top margin. The rationale for an asymmetrical page layout is
allowing more space for readers to place their hands while holding the books or other
printed documents. About.com describes some page layouts on their Web site: Perfect
Proportions Using Page Margins in Desktop Publishing.

¢ |If you want the first page of a new chapter to always start on a right (recto) page, make
sure that the page style for the first chapter page is set for the right page only by making
this selection in the Layout settings field. The typical procedure for the rest of a chapter is
to define a single “mirrored” page style for both left and right pages. A mirrored page can
have different headers and footers. If done this way, every chapter will use two page styles.

* You can choose to define separate page styles for left and right pages, if you want the
pages to be very different in appearance (for example, different margins or headers and
footers only on right pages but not on left pages; imagine a book with a full-page
photograph on the left pages and text on the right pages). In that case, make sure that the
Next Style field for the first page style is then set for a left-only page, which, in turn, is then
set to be followed by a right-only page style. If done this way, every chapter will use three
page styles. A hypothetical case might have these page-style names: First page, Left, and
Right.

If you check the Register-true box, Writer will create a vertical grid on the page with a spacing
between grid points that depends on the selected Reference Style. The vertical grid makes sure
that text printed on adjacent columns, opposite pages, or even both sides of the same sheet of
paper, is aligned—making it easier to read as well as being more pleasant to see.

Background and Border pages

Use the Background page to apply a background or the Border page to draw a border around the
text area of the page (the margins). You can also add a shadow to the text area. You can choose
between a solid color or a graphic image for the background and several styles of line for the
borders. Note that the page area affected by these changes does not include the area outside the
margins. If you plan to print on colored paper and want to have a feel of the final result you will
obtain or want to use a light color for the font, rather than changing the background, then go to
Tools > Options > LibreOffice and in the Appearance section, change the Document background
color.

Header and Footer pages

You can associate a different header or footer to each page style. This property makes it very easy
to have different headers on left and right pages, to avoid headers on pages at the start of a new
chapter, and so on. You can also have a different header or footer on the same page style where it
is used for the first page of a document.
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Setting up the header and footer pages is straightforward. The instructions here refer to the
header, but the footer page has the same options. Activate the input boxes by selecting Header
on, then specify the left margin, right margin, and spacing to the main text area. For the height of
the header area, you can either select the AutoFit height box, which will make Writer adapt the
size to the contents, or specify the height manually. Clicking More opens a new dialog, where you
can set the borders and background of the header area.

If you deselect the Same content left/right box, you can specify a different header for left or right
pages, even if you use a single style for both as shown here. This option is not available on the
predefined Left and Right page styles or on any other page style defined to be a left or right page
only.

Deselecting Same content on first page allows you to set a different header on a first page when
using the same style for the Next Style.

Left Page Headar Right Page Header

bt

[N
b
[}

Figure 255: Different content on left and right pages

Columns page

Use this page to create the desired column layout for the page style. The page is subdivided into
three sections: Settings, Width and Spacing and Separator Line. The Settings section contains
thumbnails of predefined columns settings you can select, as well as a text box where you can
enter the desired number of columns if you need to create a customized one.

After you select more than one column, the Width and Spacing section becomes active. If you are
not satisfied with the predefined settings (equally spaced columns), deselect the AutoWidth option
and enter the parameters manually. When you work with multiple columns per page, you can also
fine tune the position and size of a separator line between the columns.

Footnote page

Use this page to adjust the appearance of the footnotes. Keeping the default setting Not larger
than page area, the footnotes area is calculated automatically on the basis of the number of
footnotes. If you prefer to control manually the maximum space that footnotes can take, select the
Maximum footnote height option and enter the value in the preferred unit of measurement. Use
the second section of the page to customize the separator between the footnotes and the main
area.

Example: A book chapter sequence of pages

Book chapters typically start on a right-hand page, with the first page of the chapter having a
different layout from the rest of the pages. The other pages in the chapter are “mirrored” for
double-sided printing. For example, page numbers in the header or footer may be positioned on
the outside edge of pages and in this instance a wider margin (allowing for binding) is placed on
the inside edge.

Table 9 shows the properties of two page styles (Right Page and Default) set up for a typical book
chapter’s sequence of pages.
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Table 9: Properties of customized page styles for book chapter

Page Style Desired effect Property: setting

Right Page First page always on the right (an Page > Page layout > Only right
odd-numbered page)
No header or footer Header > Header on: Not selected
Top margin of page larger than on Page > Margins > Top: 6.00cm
other pages

Default Mirrored margins Page > Page layout: Mirrored
Header with page number on the Header > Header on: Selected
top outside of the page and chapter | jesger > Header > Same content
title in the top middle center of the leftiright: Not selected
page '

Figure 256 illustrates the transitions from the Right Page to Default page styles, with the change of
header between left and right pages shown by the # symbol.

v

# #
Right _ Default | | Default
Page "| |Page "| |Page

Figure 256: Right Page and then the Default page style with
different headers for alternate pages.

Step 1. Set up the Right Page style.

1) On the Styles and Formatting window, click the Page Styles icon ( R ) to display a list of
page styles.

2) Right-click on Right Page and select Modify from the pop-up menu.

3) On the Organizer page of the Page Style: Right Page dialog, change Next Style to Default.

L 1
FPage Style: Right Page
Organizer Page | Background ||Header | Footer | Borders || Columns || Fooknoke
Mame Right Page
Mext Styvle Pight Page iv]
Default e
Endrote
Envelope
Firsk Page
. Foaknote
Conkains HTML W

Figure 257: Specifying the next style after the first page of a chapter

4) On the Page tab, specify a larger left margin for binding, and a larger top margin to move
the chapter title down the page.

238 LibreOffice 4.2 Writer Guide



Margins Layouk setkings
Left 3.00cm Page layout Only right v
Right 2.00cm Format 1,2,3, .. -
Top 6.00cm & [ ] Register-true
Eottorm 2.50cm

Figure 258: Setting page margins and layout for the Right Page style

5) On the Header and Footer pages, be sure the Header on and Footer on options are not
selected. Click OK to save your changes.

Step 2. Set up the Default page style.

1) On the Styles and Formatting window, in the list of page styles, right-click on Default and
select Modify from the pop-up menu.

2) On the Organizer page of the Page Style: Default dialog, be sure Next Style is set to
Default.

3) On the Page tab of the Page Style: Default dialog, select Mirrored for Page layout and set
the Inner and Outer margins to the same width as the Left and Right margins, respectively,
on the Right Page style.

- -,
Page Style: Default Style
Organizer |Page Background |Header |Footer |Borders |Caolumns |Footnote

Paper format

Format A4 el

Width 21.00em (2

Height 29.70am

Orientation @ Portrait

() Landscape Paper tray [From printer settings] R4

Maragins Layout settings

Inner 3.00om (5 Page layout Mirrored A

Outer 2.00cm 5 Format 1,2, 3. ™

Top 2.00cm :3: |:| Register-true

Bottom 2.00em (4 Reference style

Figure 259: Setting page margins and layout for the Default page style

4) On the Header page of the Page Style: Default dialog, select the Header on option and
deselect the Same content left/right option. Click OK to save your changes.
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Page Style: Default Style

Organizer |Page |Background |Header Footer |Borders ||Columns |[Footnote

Header
Header on

[ ]5ame content left/rightt

Same content on first page

Figure 260: Setting up the header properties for the Default page style

Step 3. Set up the Heading 1 paragraph style to start on a new right-hand page.
1) Inthe Styles and Formatting window, on the Paragraph Styles page, right-click on Heading
1 and select Modify.

2) On the Text Flow page of the Paragraph Style dialog, in the Breaks section, select Insert,
With Page Style, and Right Page. Click OK to save your changes.

Breaks
Insert Tvpe  |Page w Position |Befare w
With Page Style Fight Page fw Page number |0 ~

Figure 261: Setting a paragraph style to start on a page of a selected style
Step 4. Start a new chapter.
Apply the Heading 1 paragraph style to the first paragraph, which is the title of the chapter.

By default, the Heading 1 paragraph style is assigned to Outline Level 1. The
Note assignment of paragraph styles to outline levels is done through Tools > Outline
Numbering.

Step 5. Set up the page headers.
1) On a left page, put the cursor in the header and insert a page number field on the left
(Insert > Fields > Page Number).
2) Press Tab to put the cursor in the middle and insert a Chapter reference:

Press Control+F2 (or choose Insert > Fields > Other from the menu bar) to display the
Fields dialog (Figure 262).
On the Document page, for Type, select Chapter and for Format, select Chapter name.
Make sure that Level is set to 1 and then click Insert.

3) On aright page, put the cursor in the header, press the Tab key, insert a Chapter
reference, press Tab again, and insert a page number field.

4) If you need to adjust the tab stops for the header, modify the Header paragraph style. Do
not manually adjust the tab stops.
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Fields
Document (Cross-references |Functions |DocInformation |Variables |Database
Type select Format
Authaor Chapter name
Chapter Chapter number
Date Chapter number and name
File name Chapter number without separatg
Page
Sender
Statistics
Templates
Time
¢ ¥
Level
1 &2

Figure 262: Inserting a chapter title into the header of a page

Working with list styles

List styles (also called numbering styles) work together with paragraph styles. They define
indentation, alignment, and the numbering or bullet characters used for list items. You can define
many list styles, from simple bulleted lists to complex multi-level (nested) lists.

As with other styles, the main reasons for using list styles are consistency and speeding up your
work. Although you can create simple lists quickly by clicking the Numbering On/Off or Bullets
On/Off icons on the Formatting toolbar, and create quite complex nested lists using the buttons on
the Bullets and Numbering toolbar, the appearance of the resulting lists may not be what you want
—and you might want to have more than one style of list. You can use the Bullets and Numbering
choice on the Format menu to manually format the appearance of some or all of the lists, but if you
later need to change their appearance, you will have a lot of manual work to do.

LibreOffice uses the terms “numbering style” and “list style” inconsistently, but they
Note are the same thing. For example, the tooltip in the Styles and Formatting window
says “List Styles”, but its style dialog says “Numbering Style”.

Defining the appearance of a nested list

A nested list is a numbered or bulleted list with subordinate (usually indented) numbered or
bulleted lists. Rather than just a list of numbered items (1, 2, 3...), a nested list may have item 1,
then indented items numbered a, b, ¢ or i, ii, iii or some other numbering method before the main
number 2. With numbering styles, you can achieve any combination of numbering formats you
want. A nested list may even combine numbered items with bulleted items.

There is no difference between defining a nested list style or a simple list, although nested lists
require more work. An example of a nested list is given in Chapter 3, Working with Text. In that
case, the list was built using one of the predefined outline schemes as a starting point, while in this
section we follow a more general approach so that the list can more fully suit your needs.
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Creating a new list style

The dialog to create a new list style consists of six pages in addition to the usual Organizer page
discussed in “The Organizer page” on page 216.

Bullets, Numbering Styles, and Image pages

The Bullets, Numbering Style, and Image pages contain predefined formatting for list item symbols
(bullets or numbers). To use one of them for your style, click on the image. A thick border indicates
the selection. The bullets on the Bullets tab are font characters; those on the Image tab are
graphics.

If you choose a graphics bullet, on the Options page you can select the Link Graphics option to
create a link to the graphic object rather than embedding it in the document. If you decide to link
the graphic, keep in mind that the bullet will not be displayed when the document is opened on a
different computer (unless the same graphic file is located in the same location on both computers)
or if the graphic file used is moved to a different location on the computer.

Outline page

Use the Outline page to select from eight predefined nested lists. You can also select one and use
it as a starting point for your own style, customizing the list using the Position page and the
Options page, as described below.

Position page
Use the Position page to fine tune the indentation and spacing of the list item symbol and the text
of the list item. This page is particularly effective when used in combination with the Options page.

Crganizer |Bullets |Mumbering Style |Qutine | Image |Position Options

Level Position and spacing

...............

L. MNumbering followed by Tahb stop |w |
5 Bl
3 .

3 at [0.50 £
5 .
£ Mumbering Alignment Left el
7

8 aligned at 0.25" I3
9

10 Indent at 0.50" 13

[y
i

[y

=

1.

1.

| Default

Figure 263: Position settings for a List style
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You can adjust the following settings for each individual level or all levels at once (to make them all
the same). It is generally easier to adjust the settings in the order given below, instead of the order
on the dialog. That is, start from the overall indentation for the list elements, then fix the position of
the symbols, and finally adjust the alignment of the symbols.

* Numbering followed by: the character to follow the numbering symbol (plus any
characters—for example a punctuation mark—chosen on the Options page to appear after
the number). Choose between a tab stop, a space, or nothing. If you select the tab stop,
you can specify the position of the tab.

* Indent at: how much space is reserved for the numbering symbol, measured from the left
page margin. The alignment of the first line of the list is also affected by any tab you may
have set to follow the numbering.

* Aligned at: the position of the numbering symbol, measured from the left margin of the
page.

* Numbering alignment: how the numbering (including any text before or after as set in the
Options page) will be aligned. The Aligned at value determines the symbol alignment.

When defining an indentation different from 0, the position of the tabulation is not

Note considered.

In normal circumstances, setting the Numbering followed by distance to be equal
Tip to the Indent at distance works well. See Figure 264 for a graphic representation of
the effects of the above parameters.

'"1'?'2"'3"'5."'5""5'"?"'3"'5"'19;"11';'12'

4 L L

1. Fly me to the Moon
2. s I Wish You Love
3 em p-|l Believe in You
4 More
5 I Can't Stop Loving You
6 Numbering followed by 'Tab stop  [w
7 . -
t 000 E
8 =TT Mime
9 Mumbering alignment Rught "
15&.9 Aligned at 1.50cm o
=P} -i—indent at Fl.UUcm o

Figure 264: A numbered list of CD tracks highlighting the various elements

Position page for older documents opened in LibreOffice

If your document was created with an earlier version of a similar program such as OpenOffice.org,
or if the document was saved for compatibility reasons using the ODF file format version 1.1 or
earlier, the Position page will appear as in Figure 265.
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Organizer | Bullets | Numbering Style | Qutline | Graphics |Position | Options
Position and spacing

Level
1 Indent 0.00" -
5
E [ Relative
4
5 Width of numbering o.o0" =
]
7 Minimum space numbering <-> text 0.00" .
8
9 Mumbering alignment Left b

Figure 265: The Position page for older documents

In this case you can adjust the following settings:

Tip

Indent: the indentation of the number or bullet area, measured from the left margin of the
paragraph linked to the numbering style. In other words, if the paragraph style already has
an indentation, when the list style is applied the indentations are added together.

For any level other than Level 1, the Relative option causes the indentation to be
measured from the start of the previous level rather than from the page margin.

Width of numbering: how much space is used by the numbering symbol. Writer reserves
this space, even if only part of it is used.

Minimum spacing numbering <-> text: the spacing between the right edge of the
numbering symbol and the text. If the spacing to text is not sufficient, Writer will honor this
setting by expanding the numbering area. Setting the minimum spacing between
numbering and text is very useful when right-aligning the numbering or when there is much
text before or after the numbering.

Numbering alignment: how the numbering (including any text before or after) will be
aligned.

To fully appreciate how the Numbering alignment works, try to create a numbered
list with more than ten elements and make sure that enough room has been made
for numbers with two or more digits. You may also wish to right-align numbers 10
or greater, as in Figure 264 on page 243.

Options page
Use the Options page (Figure 266) to define the style of the outline levels. The options available on
this page depend on the type of marker selected for the list. First, on the left side, select the level

you want to modify. To modify all ten levels at once, select 1 - 10 as the level. If you started from a
predefined outline, some of the levels will already have settings.

Depending on the numbering style selected in the Number box (bullet, graphic, numbering), some
of the following options become available on the page:

Before: any text to appear before the number (for example, Step).
After: any text to appear after the number (for example, a punctuation mark).

Start at: the first value of the list (for example, you might want the list to start at 4 instead of
1).

Character Style: the style to be used for the number or bullet.
Character button: click to select the character for the bullet.
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Organizer |Bullets |Numbering Style ||Outline |[Image |Paosition | Options
Level Humbering
1 ..................... .- ﬂLIITItIEF 1, 2,3, ... W _
2 1
i Character Style  [Mumbering Symbaols W E:I:.'I
5
6 Show sublevels
7
3 Separator
9
10 Before
1-10
After
Start at 1 =
All Levels
|:| Consecutive numbering

Figure 266: The Options page for a list style

* Graphics selection button: opens a list of available graphics (Gallery) or allows the
selection of a file on the hard disk to be used as the list marker.

* Width and Height: the dimensions of the graphic marker.

e Alignment: the alignment of the graphic object.

* Keep ratio option: fixes the ratio between the width and the height of the graphic marker.

The right-hand side of the dialog shows a preview of the modifications made.

To revert to the default values, click the Reset button in the bottom right corner. Finally, if you wish
to use consecutive numbers regardless of the outline level, check the Consecutive humbering
box at the bottom of the page.

Combining list and paragraph styles

When applying a list style, the underlying paragraph style remains unchanged. If your list must also
have a certain font size, indentations, and so on, you might expect to first apply a paragraph style
and then a list style (or the other way around). However, you can embed a list style in a paragraph
style using the Numbering page of the Paragraph Style dialog, and then apply only the paragraph
style to the list.
This section gives an example of combining list and paragraph styles.

1) Create a list style you want to use for the paragraph. For example: MyNumberedList.

2) Create a new paragraph style.

3) On the Organizer page of the Paragraph Style dialog:

a) Give the new paragraph style a name, say NumberedParagraph.

b) For the Next Style, choose NumberedParagraph (this will make the following
paragraph also be in this style, until you choose a different style).
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c) InLinked with, choose None.
d) Leave Custom Styles, in the Category field.

4) Set up this paragraph style to your liking. Because the indentation is controlled by the List
style, to avoid undesired interactions do not change the indent settings on the Indents &
Spacing page. (You might want to change the spacing above and below the paragraph.)

5) On the Outline & Numbering page, choose the MyNumberedList style created in step 1.

6) Click OK to save this style.

To have full control, it is common practice to define three base paragraph styles for lists: List Start
for the first element of the list, List Continue for the subsequent elements of the list, and List End
for the last element of the list. You should also define a paragraph style to be used for unnumbered
list items (one for each nested level you intend to use) as well as an introductory style for the
paragraph preceding the start of the list (to allow for keeping the introductory paragraph with the
first list item, or for specifying spacing before the first list item that is different from the spacing
between other paragraphs).

Example: Creating a simple list style

In this example, we will create a numbered list that is used to number the songs on a CD. The
numbers are right aligned, and some space is left between the number and the title of the track.

As we want to reuse the same numbered list for other CDs, we will define a new list style and then
apply it to the tracks list.

Creating the CDTracks numbered list
As for the previous example, start by clicking the List Styles icon (fifth from the left) in the Styles
and Formatting window. Then right-click anywhere in the list box and choose New.

The Numbering style dialog is displayed. For the CDTracks style, we need to customize fields in
the Organizer, the Options, and the Position pages.

Style fields Description
Name Enter CDTr